]> git.pld-linux.org Git - packages/hdf-eos.git/blob - hdf-eos.spec
f95cd996e014fb9dcf268a54084901810ef48710
[packages/hdf-eos.git] / hdf-eos.spec
1 #
2 # Conditional build:
3 %bcond_without  szip            # SZIP support (must match hdf build bcond)
4 %bcond_without  tests           # don't perform "make check"
5 #
6 Summary:        HDF-EOS 2 library
7 Summary(pl.UTF-8):      Biblioteka HDF-EOS 2
8 Name:           hdf-eos
9 Version:        2.18.1.00
10 Release:        1
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos/latest_release/HDF-EOS2.18v1.00.tar.Z
14 # Source0-md5:  755a75c7ce82f0df943c81bc94b32fe4
15 # needed for auto* rebuild
16 Source1:        ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos/latest_release/HDF-EOS2.18v1.00_TestDriver.tar.Z
17 # Source1-md5:  d95c510f24a598e6eeeefdf92009ba15
18 Patch0:         %{name}-cc.patch
19 Patch1:         %{name}-link.patch
20 URL:            http://hdfeos.org/software/library.php#HDF-EOS2
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake
23 BuildRequires:  hdf-devel >= 4
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libtool
26 %{?with_szip:BuildRequires:     szip-devel}
27 BuildRequires:  zlib-devel
28 Requires:       hdf >= 4
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 HDF-EOS is a software library designed to support EOS-specific data
33 structures, namely Grid, Point, and Swath. The new data structures are
34 constructed from standard HDF data objects, using EOS conventions,
35 through the use of a software library. A key feature of HDF-EOS files
36 is that instrument-independent services, such as subsetting by
37 geolocation, can be applied to the files across a wide variety of data
38 products. The library is extensible and new data structures can be
39 added.
40
41 %description -l pl.UTF-8
42 HDF-EOS to biblioteka programowa zaprojektowana w celu obsługi
43 struktur danych związanych z EOS, takich jak Grid, Point i Swath. Nowe
44 struktury danych są tworzone z obiektów danych HDF, przy użyciu
45 konwencji EOS, poprzez bibliotekę programową. Kluczową cechą plików
46 HDF-EOS jest to, że usługi niezależne od przyrządu, takie jak na
47 przykład podział według geolokalizacji, można wykonywać na plikach
48 zawierających różnorodne zbiory danych. Biblioteka jest rozszerzalna i
49 pozwala na dodawanie nowych struktur danych.
50
51 %package devel
52 Summary:        Header files for HDF-EOS 2 library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF-EOS 2
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       hdf-devel >= 4
57 Requires:       libjpeg-devel
58 %{?with_szip:Requires:  szip-devel}
59 Requires:       zlib-devel
60
61 %description devel
62 Header files for HDF-EOS 2 library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki HDF-EOS 2.
66
67 %package static
68 Summary:        Static HDF-EOS 2 library
69 Summary(pl.UTF-8):      Statyczna biblioteka HDF-EOS 2
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static HDF-EOS 2 library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka HDF-EOS 2.
78
79 %prep
80 %setup -q -n hdfeos -b1
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 # as hdf 4 extension, use the same include dir as hdf 4
91 %configure \
92         --includedir=%{_includedir}/hdf \
93         --enable-install-include \
94         --enable-shared \
95         --with-hdf4=%{_includedir}/hdf, \
96         %{?with_szip:--with-szlib}
97
98 %{__make}
99
100 %{?with_tests:%{__make} check}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc doc/{HDFEOS-DEFINITION.TXT,README}
117 %attr(755,root,root) %{_libdir}/libGctp.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libGctp.so.0
119 %attr(755,root,root) %{_libdir}/libhdfeos.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libhdfeos.so.0
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libGctp.so
125 %attr(755,root,root) %{_libdir}/libhdfeos.so
126 %{_libdir}/libGctp.la
127 %{_libdir}/libhdfeos.la
128 %{_includedir}/hdf/HDFEOSVersion.h
129 %{_includedir}/hdf/HE2_config.h
130 %{_includedir}/hdf/HdfEosDef.h
131 %{_includedir}/hdf/bcea.h
132 %{_includedir}/hdf/cfortHdf.h
133 %{_includedir}/hdf/cproj.h
134 %{_includedir}/hdf/cproj_prototypes.h
135 %{_includedir}/hdf/ease.h
136 %{_includedir}/hdf/gctp_prototypes.h
137 %{_includedir}/hdf/isin.h
138 %{_includedir}/hdf/proj.h
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libGctp.a
143 %{_libdir}/libhdfeos.a
This page took 0.159477 seconds and 2 git commands to generate.