]> git.pld-linux.org Git - packages/handlersocket.git/blob - handlersocket.spec
rebuild with perl 5.32
[packages/handlersocket.git] / handlersocket.spec
1 # NOTE: plugin itself is built within main mysql/percona-server package
2 Summary:        HandlerSocket plugin for MySQL
3 Summary(pl.UTF-8):      Wtyczka HandlerSocket dla MySQL-a
4 Name:           handlersocket
5 Version:        1.1.2
6 Release:        7
7 License:        BSD
8 Group:          Libraries
9 Source0:        https://github.com/DeNA/HandlerSocket-Plugin-for-MySQL/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  b5aa5df200ce59b25d5becead76724e5
11 URL:            https://github.com/DeNA/HandlerSocket-Plugin-for-MySQL
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRequires:  perl-devel >= 1:5.10
17 BuildRequires:  rpm-perlprov
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
22 the mysqld process, accept TCP connections, and execute requests from
23 clients. HandlerSocket does not support SQL queries. Instead, it
24 supports simple CRUD operations on tables.
25
26 %description -l pl.UTF-8
27 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
28 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
29 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
30 operacje CRUD na tabelach.
31
32 %package client
33 Summary:        HandlerSocket client program
34 Summary(pl.UTF-8):      Program kliencki HandlerSocket
35 Group:          Applications/Databases
36 Requires:       libhsclient = %{version}-%{release}
37
38 %description client
39 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
40 the mysqld process, accept TCP connections, and execute requests from
41 clients. HandlerSocket does not support SQL queries. Instead, it
42 supports simple CRUD operations on tables.
43
44 This package contains command line client.
45
46 %description client -l pl.UTF-8
47 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
48 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
49 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
50 operacje CRUD na tabelach.
51
52 Ten pakiet zawiera klienta działającego z linii poleceń.
53
54 %package -n libhsclient
55 Summary:        HandlerSocket client library
56 Summary(pl.UTF-8):      Biblioteka kliencka HandlerSocket
57 Group:          Libraries
58
59 %description -n libhsclient
60 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
61 the mysqld process, accept TCP connections, and execute requests from
62 clients. HandlerSocket does not support SQL queries. Instead, it
63 supports simple CRUD operations on tables.
64
65 This package contains C++ client library.
66
67 %description -n libhsclient -l pl.UTF-8
68 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
69 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
70 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
71 operacje CRUD na tabelach.
72
73 Ten pakiet zawiera bibliotekę kliencką C++.
74
75 %package -n libhsclient-devel
76 Summary:        Header files for HandlerSocket client library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki klienckiej HandlerSocket
78 Group:          Development/Libraries
79 Requires:       libhsclient = %{version}-%{release}
80 Requires:       libstdc++-devel
81
82 %description -n libhsclient-devel
83 Header files for HandlerSocket client library.
84
85 %description -n libhsclient-devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki klienckiej HandlerSocket.
87
88 %package -n libhsclient-static
89 Summary:        Static HandlerSocket client library
90 Summary(pl.UTF-8):      Statyczna biblioteka kliencka HandlerSocket
91 Group:          Development/Libraries
92 Requires:       libhsclient-devel = %{version}-%{release}
93
94 %description -n libhsclient-static
95 Static HandlerSocket client library.
96
97 %description -n libhsclient-static -l pl.UTF-8
98 Statyczna biblioteka kliencka HandlerSocket.
99
100 %package -n perl-Net-HandlerSocket
101 Summary:        HandlerSocket client library for Perl
102 Summary(pl.UTF-8):      Biblioteka kliencka HandlerSocket dla Perla
103 Group:          Development/Languages/Perl
104 Requires:       libhsclient = %{version}-%{release}
105
106 %description -n perl-Net-HandlerSocket
107 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
108 the mysqld process, accept TCP connections, and execute requests from
109 clients. HandlerSocket does not support SQL queries. Instead, it
110 supports simple CRUD operations on tables.
111
112 This package contains Perl client library.
113
114 %description -n perl-Net-HandlerSocket -l pl.UTF-8
115 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
116 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
117 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
118 operacje CRUD na tabelach.
119
120 Ten pakiet zawiera bibliotekę kliencką dla Perla.
121
122 %prep
123 %setup -q -n HandlerSocket-Plugin-for-MySQL-%{version}
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         --disable-handlersocket_server
133
134 %{__make} \
135         libhsclient_la_LDFLAGS=
136
137 # not build when not building plugin
138 %{__make} -C client hsclient \
139         hsclient_LDADD='$(top_builddir)/libhsclient/libhsclient.la' \
140         hsclient_LDFLAGS=
141
142 cd perl-Net-HandlerSocket
143 %{__perl} Makefile.PL \
144         CC="%{__cxx}" \
145         OPTIMIZE="%{rpmcxxflags}" \
146         INSTALLDIRS=vendor
147 %{__make}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install -D client/hsclient $RPM_BUILD_ROOT%{_bindir}/hsclient
156
157 %{__make} -C perl-Net-HandlerSocket pure_install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -n libhsclient -p /sbin/ldconfig
164 %postun -n libhsclient -p /sbin/ldconfig
165
166 %files client
167 %defattr(644,root,root,755)
168 %doc AUTHORS COPYING ChangeLog README docs-en
169 %lang(ja) %doc docs-ja
170 %attr(755,root,root) %{_bindir}/hsclient
171
172 %files -n libhsclient
173 %defattr(644,root,root,755)
174 %doc libhsclient/COPYRIGHT.txt
175 %attr(755,root,root) %{_libdir}/libhsclient.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libhsclient.so.0
177
178 %files -n libhsclient-devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libhsclient.so
181 %{_libdir}/libhsclient.la
182 %{_includedir}/handlersocket
183
184 %files -n libhsclient-static
185 %defattr(644,root,root,755)
186 %{_libdir}/libhsclient.a
187
188 %files -n perl-Net-HandlerSocket
189 %defattr(644,root,root,755)
190 %doc perl-Net-HandlerSocket/{COPYRIGHT.txt,Changes,README}
191 %{perl_vendorarch}/Net/HandlerSocket.pm
192 %{perl_vendorarch}/Net/HandlerSocket
193 %dir %{perl_vendorarch}/auto/Net/HandlerSocket
194 %attr(755,root,root) %{perl_vendorarch}/auto/Net/HandlerSocket/HandlerSocket.so
195 %{_mandir}/man3/Net::HandlerSocket.3pm*
This page took 0.108348 seconds and 3 git commands to generate.