]> git.pld-linux.org Git - packages/handlersocket.git/blob - handlersocket.spec
- release 4
[packages/handlersocket.git] / handlersocket.spec
1 # NOTE: plugin itself is built within main mysql/percona-server package
2 %include        /usr/lib/rpm/macros.perl
3 Summary:        HandlerSocket plugin for MySQL
4 Summary(pl.UTF-8):      Wtyczka HandlerSocket dla MySQL-a
5 Name:           handlersocket
6 Version:        1.1.2
7 Release:        4
8 License:        BSD
9 Group:          Libraries
10 Source0:        https://github.com/DeNA/HandlerSocket-Plugin-for-MySQL/archive/%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  b5aa5df200ce59b25d5becead76724e5
12 URL:            https://github.com/DeNA/HandlerSocket-Plugin-for-MySQL
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  perl-devel >= 1:5.10
18 BuildRequires:  rpm-perlprov
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
23 the mysqld process, accept TCP connections, and execute requests from
24 clients. HandlerSocket does not support SQL queries. Instead, it
25 supports simple CRUD operations on tables.
26
27 %description -l pl.UTF-8
28 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
29 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
30 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
31 operacje CRUD na tabelach.
32
33 %package client
34 Summary:        HandlerSocket client program
35 Summary(pl.UTF-8):      Program kliencki HandlerSocket
36 Group:          Applications/Databases
37 Requires:       libhsclient = %{version}-%{release}
38
39 %description client
40 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
41 the mysqld process, accept TCP connections, and execute requests from
42 clients. HandlerSocket does not support SQL queries. Instead, it
43 supports simple CRUD operations on tables.
44
45 This package contains command line client.
46
47 %description client -l pl.UTF-8
48 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
49 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
50 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
51 operacje CRUD na tabelach.
52
53 Ten pakiet zawiera klienta działającego z linii poleceń.
54
55 %package -n libhsclient
56 Summary:        HandlerSocket client library
57 Summary(pl.UTF-8):      Biblioteka kliencka HandlerSocket
58 Group:          Libraries
59
60 %description -n libhsclient
61 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
62 the mysqld process, accept TCP connections, and execute requests from
63 clients. HandlerSocket does not support SQL queries. Instead, it
64 supports simple CRUD operations on tables.
65
66 This package contains C++ client library.
67
68 %description -n libhsclient -l pl.UTF-8
69 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
70 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
71 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
72 operacje CRUD na tabelach.
73
74 Ten pakiet zawiera bibliotekę kliencką C++.
75
76 %package -n libhsclient-devel
77 Summary:        Header files for HandlerSocket client library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki klienckiej HandlerSocket
79 Group:          Development/Libraries
80 Requires:       libhsclient = %{version}-%{release}
81 Requires:       libstdc++-devel
82
83 %description -n libhsclient-devel
84 Header files for HandlerSocket client library.
85
86 %description -n libhsclient-devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki klienckiej HandlerSocket.
88
89 %package -n libhsclient-static
90 Summary:        Static HandlerSocket client library
91 Summary(pl.UTF-8):      Statyczna biblioteka kliencka HandlerSocket
92 Group:          Development/Libraries
93 Requires:       libhsclient-devel = %{version}-%{release}
94
95 %description -n libhsclient-static
96 Static HandlerSocket client library.
97
98 %description -n libhsclient-static -l pl.UTF-8
99 Statyczna biblioteka kliencka HandlerSocket.
100
101 %package -n perl-Net-HandlerSocket
102 Summary:        HandlerSocket client library for Perl
103 Summary(pl.UTF-8):      Biblioteka kliencka HandlerSocket dla Perla
104 Group:          Development/Languages/Perl
105 Requires:       libhsclient = %{version}-%{release}
106
107 %description -n perl-Net-HandlerSocket
108 HandlerSocket is a NoSQL plugin for MySQL. It works as a daemon inside
109 the mysqld process, accept TCP connections, and execute requests from
110 clients. HandlerSocket does not support SQL queries. Instead, it
111 supports simple CRUD operations on tables.
112
113 This package contains Perl client library.
114
115 %description -n perl-Net-HandlerSocket -l pl.UTF-8
116 HandlerSocket to wtyczka NoSQL dla MySQL-a. Działa jako demon wewnątrz
117 procesu mysqld, przyjmuje połączenia TCP i wykonuje żądania od
118 klientów. HandlerSocket nie obsługuje zapytań SQL, a jedynie proste
119 operacje CRUD na tabelach.
120
121 Ten pakiet zawiera bibliotekę kliencką dla Perla.
122
123 %prep
124 %setup -q -n HandlerSocket-Plugin-for-MySQL-%{version}
125
126 %build
127 %{__libtoolize}
128 %{__aclocal} -I m4
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure \
133         --disable-handlersocket_server
134
135 %{__make} \
136         libhsclient_la_LDFLAGS=
137
138 # not build when not building plugin
139 %{__make} -C client hsclient \
140         hsclient_LDADD='$(top_builddir)/libhsclient/libhsclient.la' \
141         hsclient_LDFLAGS=
142
143 cd perl-Net-HandlerSocket
144 %{__perl} Makefile.PL \
145         CC="%{__cxx}" \
146         OPTIMIZE="%{rpmcxxflags}" \
147         INSTALLDIRS=vendor
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 install -D client/hsclient $RPM_BUILD_ROOT%{_bindir}/hsclient
157
158 %{__make} -C perl-Net-HandlerSocket pure_install \
159         DESTDIR=$RPM_BUILD_ROOT
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post   -n libhsclient -p /sbin/ldconfig
165 %postun -n libhsclient -p /sbin/ldconfig
166
167 %files client
168 %defattr(644,root,root,755)
169 %doc AUTHORS COPYING ChangeLog README docs-en
170 %lang(ja) %doc docs-ja
171 %attr(755,root,root) %{_bindir}/hsclient
172
173 %files -n libhsclient
174 %defattr(644,root,root,755)
175 %doc libhsclient/COPYRIGHT.txt
176 %attr(755,root,root) %{_libdir}/libhsclient.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libhsclient.so.0
178
179 %files -n libhsclient-devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libhsclient.so
182 %{_libdir}/libhsclient.la
183 %{_includedir}/handlersocket
184
185 %files -n libhsclient-static
186 %defattr(644,root,root,755)
187 %{_libdir}/libhsclient.a
188
189 %files -n perl-Net-HandlerSocket
190 %defattr(644,root,root,755)
191 %doc perl-Net-HandlerSocket/{COPYRIGHT.txt,Changes,README}
192 %{perl_vendorarch}/Net/HandlerSocket.pm
193 %{perl_vendorarch}/Net/HandlerSocket
194 %dir %{perl_vendorarch}/auto/Net/HandlerSocket
195 %attr(755,root,root) %{perl_vendorarch}/auto/Net/HandlerSocket/HandlerSocket.so
196 %{_mandir}/man3/Net::HandlerSocket.3pm*
This page took 0.105113 seconds and 3 git commands to generate.