]> git.pld-linux.org Git - packages/handbrake.git/blob - handbrake.spec
40016207a07692a46570de391f7dadcd6d4df362
[packages/handbrake.git] / handbrake.spec
1 Summary:        A program to transcode DVDs and other sources to MPEG-4 and MKV
2 Name:           handbrake
3 Version:        1.4.1
4 Release:        2
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        https://github.com/HandBrake/HandBrake/releases/download/%{version}/HandBrake-%{version}-source.tar.bz2
8 # Source0-md5:  73fe8df8340ac7b7c23a8c09974d6906
9 # Source1 is a tarball of the downloads/ folder that contains third party
10 # libraries required and automatically downloaded by HandBrake the first
11 # time 'make' is run. If you update Source0 to a newer release you must
12 # recreate an updated Source1 tarball for it too!
13 Source1:        HandBrake-%{version}-contrib-tarballs.tar
14 # Source1-md5:  11691c785ee60b58651c5405eeeb5f22
15 Patch0:         binutils2.41.patch
16 URL:            https://handbrake.fr/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 BuildRequires:  cmake
21 BuildRequires:  curl-devel
22 BuildRequires:  dbus-glib-devel
23 BuildRequires:  fontconfig-devel
24 BuildRequires:  freetype-devel
25 BuildRequires:  fribidi-devel
26 BuildRequires:  glib2-devel
27 BuildRequires:  gstreamer-devel
28 BuildRequires:  gstreamer-plugins-base-devel
29 BuildRequires:  gtk+3-devel
30 BuildRequires:  gtk-webkit3-devel
31 BuildRequires:  harfbuzz-devel
32 BuildRequires:  intltool
33 BuildRequires:  jansson-devel
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  libass-devel
36 BuildRequires:  libnotify-devel
37 BuildRequires:  libogg-devel
38 BuildRequires:  libsamplerate-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtheora-devel
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel
43 BuildRequires:  libx264-devel
44 BuildRequires:  libxml2-devel
45 BuildRequires:  m4
46 BuildRequires:  opus-devel
47 BuildRequires:  pkgconfig
48 BuildRequires:  python
49 BuildRequires:  rpmbuild(macros) >= 2.005
50 BuildRequires:  subversion
51 BuildRequires:  udev-glib-devel
52 BuildRequires:  yasm
53 BuildRequires:  zlib-devel
54 BuildConflicts: libudfread-devel
55 ExclusiveArch:  %{x8664}
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _debugsource_packages   0
59
60 %description
61 HandBrake is an open-source, GPL-licensed, multi-platform,
62 multi-threaded transcoder, available for MacOS X, Linux and Windows.
63
64 %package gui
65 Summary:        A program to transcode DVDs and other sources to MPEG-4 and MKV
66 Group:          Applications/Multimedia
67 Requires:       gstreamer-plugins-bad
68 Requires:       gstreamer-plugins-ugly
69 Requires:       gtk+3
70 Requires:       libdvdcss
71 Obsoletes:      HandBrake
72 Obsoletes:      handbrake
73
74 %package cli
75 Summary:        A program to transcode DVDs and other sources to MPEG-4 and MKV
76 Group:          Applications/Multimedia
77 Requires:       gtk-update-icon-cache
78 Requires:       libdvdcss
79 Obsoletes:      HandBrake
80 Obsoletes:      handbrake
81
82 %description gui
83 HandBrake is an open-source, GPL-licensed, multi-platform,
84 multi-threaded transcoder, available for MacOS X, Linux and Windows.
85
86 This is the GTK GUI version of HandBrake.
87
88 %description cli
89 HandBrake is an open-source, GPL-licensed, multi-platform,
90 multi-threaded transcoder, available for MacOS X, Linux and Windows.
91
92 This is the CLI tool version of HandBrake.
93
94 %prep
95 %setup -q -n HandBrake-%{version} -a1
96
97 cp -p %{PATCH0} contrib/ffmpeg/A77-%{basename:%{PATCH0}}
98
99 %build
100 export CFLAGS="%{rpmcflags}"
101 export CXXFLAGS="%{rpmcxxflags}"
102 export LDFLAGS="%{rpmldflags}"
103 ./configure \
104         --force \
105         --prefix=%{_prefix} \
106         --disable-df-fetch
107
108 cat > build/GNUmakefile.custom.defs <<EOF
109 STRIP.exe = /bin/true
110 BUILD.jobs = %{__jobs}
111 GCC.args.g.none = %{rpmcflags}
112 GCC.args.O.speed = %{rpmcflags}
113 EOF
114
115 %{__make} -C build
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 cat > build/GNUmakefile.custom.defs <<EOF
120 STRIP.exe = /bin/true
121 CONF.args = --prefix=$RPM_BUILD_ROOT%{_prefix}
122 PREFIX    = $RPM_BUILD_ROOT%{_prefix}
123 PREFIX/   = $RPM_BUILD_ROOT%{_prefix}/
124 EOF
125 %{__make} -C build install
126
127 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
128
129 %{__mv} $RPM_BUILD_ROOT%{_localedir}/sl{_SI,}
130 %{__mv} $RPM_BUILD_ROOT%{_localedir}/uk{_UA,}
131 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{no,nb}
132
133 %find_lang ghb
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post gui
139 %update_icon_cache hicolor
140
141 %postun gui
142 %update_icon_cache hicolor
143
144 %files gui -f ghb.lang
145 %defattr(644,root,root,755)
146 %doc COPYING AUTHORS.markdown NEWS.markdown README.markdown THANKS.markdown
147 %attr(755,root,root) %{_bindir}/ghb
148 %{_desktopdir}/fr.handbrake.ghb.desktop
149 %{_iconsdir}/hicolor/scalable/apps/hb-icon.svg
150 %{_iconsdir}/hicolor/scalable/apps/fr.handbrake.ghb.svg
151 %{_datadir}/metainfo/fr.handbrake.ghb.metainfo.xml
152
153 %files cli
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/HandBrakeCLI
This page took 0.052409 seconds and 2 git commands to generate.