]> git.pld-linux.org Git - packages/gzip.git/blob - gzip.spec
- updated to 1.11
[packages/gzip.git] / gzip.spec
1 Summary:        GNU gzip file compression
2 Summary(de.UTF-8):      Dateikomprimierung GNU-gzip
3 Summary(es.UTF-8):      Compresor de archivos gzip GNU
4 Summary(fr.UTF-8):      GNU gzip pour la compression de fichiers
5 Summary(pl.UTF-8):      GNU gzip
6 Summary(pt_BR.UTF-8):   Compressor de arquivos gzip GNU
7 Summary(ru.UTF-8):      Программа сжатия данных GNU gzip
8 Summary(tr.UTF-8):      GNU gzip dosya sıkıştırma aracı
9 Summary(uk.UTF-8):      Програма компресії даних GNU gzip
10 Name:           gzip
11 Version:        1.11
12 Release:        1
13 License:        GPL v3+
14 Group:          Applications/Archiving
15 Source0:        http://ftp.gnu.org/gnu/gzip/%{name}-%{version}.tar.xz
16 # Source0-md5:  d1e93996dba00cab0caa7903cd01d454
17 Source1:        %{name}-non-english-man-pages.tar.bz2
18 # Source1-md5:  ea70155215d7b7d413ff476b668bcbbd
19 Patch0:         %{name}-mktemp.patch
20 Patch1:         %{name}-info.patch
21 URL:            http://www.gnu.org/software/gzip/
22 BuildRequires:  autoconf >= 2.63
23 %if "%{pld_release}" == "ac"
24 BuildRequires:  automake >= 1:1.10
25 %else
26 BuildRequires:  automake >= 1:1.11
27 %endif
28 BuildRequires:  rpm >= 4.4.9-56
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  texinfo
31 BuildRequires:  xz
32 Requires:       mktemp
33 Provides:       gzip(rsyncable)
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This is the popular GNU file compression and decompression program,
38 gzip.
39
40 %description -l de.UTF-8
41 Dies ist das beliebte GNU-Dateikompressions- und
42 Dekompressionsprogramm, gzip.
43
44 %description -l es.UTF-8
45 Este es el popular programa GNU de compresión y descompresión de
46 archivos, gzip.
47
48 %description -l fr.UTF-8
49 Programme de compression et de décompression gzip de GNU
50
51 %description -l pl.UTF-8
52 GNU gzip to popularny program służący do kompresji i dekompresji
53 danych.
54
55 %description -l pt_BR.UTF-8
56 Este é o popular programa GNU de compressão e descompressão de
57 arquivos, gzip.
58
59 %description -l ru.UTF-8
60 Пакет gzip содержит популярную программу сжатия данных GNU gzip.
61 Сжатые ею файлы имеют расширение .gz.
62
63 %description -l tr.UTF-8
64 gzip, Unix işletim sistemlerinde çok yaygın olarak kullanılan bir
65 dosya sıkıştırma ve açma aracıdır.
66
67 %description -l uk.UTF-8
68 Пакет gzip містить популярну програму компресії даних GNU gzip.
69 Оброблені нею файли мають розширення .gz.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75
76 %if "%{pld_release}" == "ac"
77 %{__sed} -i -e '/AM_SILENT_RULES/d' configure.ac
78 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s,1\.11,1.10,' configure.ac
79 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s,dist-xz,,' configure.ac
80 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s,color-tests,,' configure.ac
81 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s,parallel-tests,,' configure.ac
82 %endif
83
84 %build
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --disable-silent-rules
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{/bin,%{_mandir}/pt/man1}
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %{__mv} $RPM_BUILD_ROOT%{_bindir}/gzip $RPM_BUILD_ROOT/bin
101 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gunzip $RPM_BUILD_ROOT%{_bindir}/zcat
102
103 cat > $RPM_BUILD_ROOT/bin/gunzip <<'EOF'
104 #!/bin/sh
105 exec /bin/gzip -d "$@"
106 EOF
107 cat > $RPM_BUILD_ROOT/bin/zcat <<'EOF'
108 #!/bin/sh
109 exec /bin/gzip -cd "$@"
110 EOF
111 ln -sf /bin/gzip $RPM_BUILD_ROOT%{_bindir}/gzip
112 ln -sf /bin/gunzip $RPM_BUILD_ROOT%{_bindir}/gunzip
113
114 # conflicts with ncompress
115 %{__rm} $RPM_BUILD_ROOT%{_bindir}/uncompress
116
117 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
118 %{__mv} $RPM_BUILD_ROOT%{_mandir}/pt/*.1 $RPM_BUILD_ROOT%{_mandir}/pt/man1
119
120 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
121 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gzip-non-english-man-pages*
122 %{__rm} $RPM_BUILD_ROOT%{_mandir}/gzip-da_de_gzip.patch*
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/postshell
128 -/usr/sbin/fix-info-dir -c %{_infodir}
129
130 %postun -p /sbin/postshell
131 -/usr/sbin/fix-info-dir -c %{_infodir}
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README* THANKS TODO
136 %attr(755,root,root) /bin/gzip
137 %attr(755,root,root) /bin/gunzip
138 %attr(755,root,root) /bin/zcat
139 %attr(755,root,root) %{_bindir}/gzexe
140 %attr(755,root,root) %{_bindir}/gzip
141 %attr(755,root,root) %{_bindir}/gunzip
142 %attr(755,root,root) %{_bindir}/zcmp
143 %attr(755,root,root) %{_bindir}/zdiff
144 %attr(755,root,root) %{_bindir}/zegrep
145 %attr(755,root,root) %{_bindir}/zfgrep
146 %attr(755,root,root) %{_bindir}/zforce
147 %attr(755,root,root) %{_bindir}/zgrep
148 %attr(755,root,root) %{_bindir}/zless
149 %attr(755,root,root) %{_bindir}/zmore
150 %attr(755,root,root) %{_bindir}/znew
151 %{_mandir}/man1/gzexe.1*
152 %{_mandir}/man1/gzip.1*
153 %{_mandir}/man1/gunzip.1*
154 %{_mandir}/man1/zcat.1*
155 %{_mandir}/man1/zcmp.1*
156 %{_mandir}/man1/zdiff.1*
157 %{_mandir}/man1/zforce.1*
158 %{_mandir}/man1/zgrep.1*
159 %{_mandir}/man1/zless.1*
160 %{_mandir}/man1/zmore.1*
161 %{_mandir}/man1/znew.1*
162 %lang(de) %{_mandir}/de/man1/*
163 %lang(es) %{_mandir}/es/man1/*
164 %lang(fi) %{_mandir}/fi/man1/*
165 %lang(fr) %{_mandir}/fr/man1/*
166 %lang(hu) %{_mandir}/hu/man1/*
167 %lang(id) %{_mandir}/id/man1/*
168 %lang(it) %{_mandir}/it/man1/*
169 %lang(ja) %{_mandir}/ja/man1/*
170 %lang(ko) %{_mandir}/ko/man1/*
171 %lang(pl) %{_mandir}/pl/man1/*
172 %lang(pt) %{_mandir}/pt/man1/*
173 %{_infodir}/gzip.info*
This page took 0.25595 seconds and 3 git commands to generate.