]> git.pld-linux.org Git - packages/gwenhywfar.git/blob - gwenhywfar.spec
- updated to 5.6.0
[packages/gwenhywfar.git] / gwenhywfar.spec
1 #
2 # TODO: - define _one_, system-wide place for ca-bundle.crt and use one, up-to-date file
3 #       - fix qt5 link error and bring back qt5 gui subpackage
4 #
5 # Conditional build:
6 %bcond_without  fox             # FOX 1.6 GUI
7 %bcond_without  qt              # any Qt GUI (convenience)
8 %bcond_without  qt4             # Qt 4 GUI
9 %bcond_with     qt5             # Qt 5 GUI
10 %bcond_without  static_libs     # static libraries
11 %bcond_with     tests           # run tests
12
13 #
14 %if %{without qt}
15 %undefine       with_qt4
16 %undefine       with_qt5
17 %endif
18 Summary:        Gwenhywfar - a multi-platform helper library for networking and security
19 Summary(pl.UTF-8):      Gwenhywfar - wieloplatformowa biblioteka pomocnicza do sieci i bezpieczeństwa
20 Name:           gwenhywfar
21 Version:        5.6.0
22 Release:        0.2
23 License:        LGPL v2.1+ with OpenSSL linking exception
24 Group:          Libraries
25 # https://www.aquamaniac.de/sites/download/packages.php
26 Source0:        https://www.aquamaniac.de/rdm/attachments/download/364/%{name}-%{version}.tar.gz
27 # Source0-md5:  d01434890cb213337c27a47dca28cc32
28 Patch0:         gcc.patch
29 Patch1:         %{name}-qt5.patch
30 URL:            https://www.aquamaniac.de/sites/aqbanking/
31 BuildRequires:  autoconf >= 2.60
32 BuildRequires:  automake
33 %{?with_fox:BuildRequires:      fox16-devel >= 1.6}
34 BuildRequires:  gettext-tools
35 BuildRequires:  gnutls-devel >= 2.9.8
36 BuildRequires:  gtk+2-devel >= 2:2.17.5
37 BuildRequires:  gtk+3-devel >= 3.10.8
38 BuildRequires:  libgcrypt-devel >= 1.2.0
39 BuildRequires:  libgpg-error-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool >= 2:1.5
42 BuildRequires:  openssl-devel
43 BuildRequires:  pkgconfig
44 %if %{with qt4}
45 BuildRequires:  QtCore-devel >= 4
46 BuildRequires:  QtGui-devel >= 4
47 BuildRequires:  qt4-build
48 %endif
49 %if %{with qt5}
50 BuildRequires:  Qt5Core-devel >= 5
51 BuildRequires:  Qt5Gui-devel >= 5
52 BuildRequires:  Qt5Widgets-devel >= 5
53 BuildRequires:  qt5-build >= 5
54 BuildRequires:  qt5-qmake >= 5
55 %endif
56 Requires:       gnutls-libs >= 2.9.8
57 Requires:       libgcrypt >= 1.2.0
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         ver_cmake       %(echo %{version} | cut -d. -f 1-2)
61
62 %description
63 This is Gwenhywfar, a multi-platform helper library for networking and
64 security applications and libraries. It is used by:
65  - Libchipcard (http://www.libchipcard.de/),
66  - OpenHBCI2 (http://www.openhbci.de/),
67  - Simthetic, the simulation tool (http://simthetic.sourceforge.net/)
68  - AqBanking/AqHBCI (http://www.aquamaniac.de/aqbanking/).
69
70 %description -l pl.UTF-8
71 To jest Gwenhywfar - wieloplatformowa biblioteka pomocnicza do
72 aplikacji i bibliotek związanych z siecią i bezpieczeństwem. Jest
73 używana przez:
74  - Libchipcard (http://www.libchipcard.de/),
75  - OpenHBCI2 (http://www.openhbci.de/),
76  - narzędzie do symulacji Simthetic (http://simthetic.sourceforge.net/)
77  - AqBanking/AqHBCI (http://www.aquamaniac.de/aqbanking/).
78
79 %package devel
80 Summary:        Header files for Gwenhywfar library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gwenhywfar
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       gnutls-devel >= 2.9.8
85 Requires:       libgcrypt-devel >= 1.2.0
86
87 %description devel
88 Header files for Gwenhywfar library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki Gwenhywfar.
92
93 %package static
94 Summary:        Static Gwenhywfar library
95 Summary(pl.UTF-8):      Statyczna biblioteka Gwenhywfar
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static Gwenhywfar library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka Gwenhywfar.
104
105 %package gui-cpp
106 Summary:        C++ wrapper classes for Gwenhywfar GUI functions
107 Summary(pl.UTF-8):      Klasy C++ obudowujące funkcje GUI biblioteki Gwenhywfar
108 Group:          Libraries
109 Requires:       %{name} = %{version}-%{release}
110
111 %description gui-cpp
112 C++ wrapper classes for Gwenhywfar GUI functions.
113
114 %description gui-cpp -l pl.UTF-8
115 Klasy C++ obudowujące funkcje GUI biblioteki Gwenhywfar.
116
117 %package gui-cpp-devel
118 Summary:        Header files for Gwenhywfar GUI C++ library
119 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gwenhywfar GUI C++
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122 Requires:       %{name}-gui-cpp = %{version}-%{release}
123 Requires:       libstdc++-devel
124
125 %description gui-cpp-devel
126 Header files for Gwenhywfar GUI C++ library.
127
128 %description gui-cpp-devel -l pl.UTF-8
129 Pliki nagłówkowe biblioteki Gwenhywfar GUI C++.
130
131 %package gui-cpp-static
132 Summary:        Static Gwenhywfar GUI C++ library
133 Summary(pl.UTF-8):      Statyczna biblioteka Gwenhywfar GUI C++
134 Group:          Development/Libraries
135 Requires:       %{name}-gui-cpp-devel = %{version}-%{release}
136
137 %description gui-cpp-static
138 Static Gwenhywfar GUI C++ library.
139
140 %description gui-cpp-static -l pl.UTF-8
141 Statyczna biblioteka Gwenhywfar GUI C++.
142
143 # TODO: rename to gui-fox[16] when something changes
144 %package fox
145 Summary:        FOX 1.6 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
146 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar
147 Group:          X11/Libraries
148 Requires:       %{name}-gui-cpp = %{version}-%{release}
149
150 %description fox
151 FOX 1.6 Gwenhywfar GUI library, containing FOX implementation of the
152 GWEN_DIALOG framework.
153
154 %description fox -l pl.UTF-8
155 Biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar, zawierająca
156 implementację FOX szkieletu GWEN_DIALOG.
157
158 %package fox-devel
159 Summary:        Header files for FOX 1.6 Gwenhywfar GUI library
160 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu FOX 1.6 do Gwenhywfar
161 Group:          X11/Development/Libraries
162 Requires:       %{name}-fox = %{version}-%{release}
163 Requires:       %{name}-gui-cpp-devel = %{version}-%{release}
164 Requires:       fox16-devel >= 1.6
165
166 %description fox-devel
167 Header files for FOX 1.6 Gwenhywfar GUI library
168
169 %description fox-devel -l pl.UTF-8
170 Pliki nagłówkowe biblioteki graficznego interfejsu FOX 1.6 do
171 Gwenhywfar.
172
173 %package fox-static
174 Summary:        Static FOX 1.6 Gwenhywfar GUI library
175 Summary(pl.UTF-8):      Statyczna biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar
176 Group:          X11/Development/Libraries
177 Requires:       %{name}-fox-devel = %{version}-%{release}
178
179 %description fox-static
180 Static FOX 1.6 Gwenhywfar GUI library.
181
182 %description fox-static -l pl.UTF-8
183 Statyczna biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar.
184
185 %package gui-gtk2
186 Summary:        GTK+ 2 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
187 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar
188 Group:          X11/Libraries
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       gtk+2 >= 2:2.17.5
191 Obsoletes:      gwenhywfar-gtk < 5.6.0
192
193 %description gui-gtk2
194 GTK+ 2 Gwenhywfar GUI library, containing GTK+ 2 implementation of the
195 GWEN_DIALOG framework.
196
197 %description gui-gtk2 -l pl.UTF-8
198 Biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar, zawierająca
199 implementację gui-gtk2+ 2 szkieletu GWEN_DIALOG.
200
201 %package gui-gtk2-devel
202 Summary:        Header files for GTK+ 2 Gwenhywfar GUI library
203 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 2 do Gwenhywfar
204 Group:          X11/Development/Libraries
205 Requires:       %{name}-devel = %{version}-%{release}
206 Requires:       %{name}-gui-gtk2 = %{version}-%{release}
207 Requires:       gtk+2-devel >= 2:2.17.5
208 Obsoletes:      gwenhywfar-gtk-devel < 5.6.0
209
210 %description gui-gtk2-devel
211 Header files for GTK+ 2 Gwenhywfar GUI library
212
213 %description gui-gtk2-devel -l pl.UTF-8
214 Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 2 do
215 Gwenhywfar.
216
217 %package gui-gtk2-static
218 Summary:        Static GTK+ 2 Gwenhywfar GUI library
219 Summary(pl.UTF-8):      Statyczna biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar
220 Group:          X11/Development/Libraries
221 Requires:       %{name}-gui-gtk2-devel = %{version}-%{release}
222 Obsoletes:      gwenhywfar-gtk-static < 5.6.0
223
224 %description gui-gtk2-static
225 Static GTK+ 2 Gwenhywfar GUI library.
226
227 %description gui-gtk2-static -l pl.UTF-8
228 Statyczna biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar.
229
230 %package gui-gtk3
231 Summary:        GTK+ 3 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
232 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar
233 Group:          X11/Libraries
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       gtk+3 >= 3.10.8
236
237 %description gui-gtk3
238 GTK+ 3 Gwenhywfar GUI library, containing GTK+ 3 implementation of the
239 GWEN_DIALOG framework.
240
241 %description gui-gtk3 -l pl.UTF-8
242 Biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar, zawierająca
243 implementację GTK+ 3 szkieletu GWEN_DIALOG.
244
245 %package gui-gtk3-devel
246 Summary:        Header files for GTK+ 3 Gwenhywfar GUI library
247 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 2 do Gwenhywfar
248 Group:          X11/Development/Libraries
249 Requires:       %{name}-devel = %{version}-%{release}
250 Requires:       %{name}-gui-gtk3 = %{version}-%{release}
251 Requires:       gtk+3-devel >= 3.10.8
252
253 %description gui-gtk3-devel
254 Header files for GTK+ 3 Gwenhywfar GUI library
255
256 %description gui-gtk3-devel -l pl.UTF-8
257 Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 3 do
258 Gwenhywfar.
259
260 %package gui-gtk3-static
261 Summary:        Static GTK+ 3 Gwenhywfar GUI library
262 Summary(pl.UTF-8):      Statyczna biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar
263 Group:          X11/Development/Libraries
264 Requires:       %{name}-gui-gtk3-devel = %{version}-%{release}
265
266 %description gui-gtk3-static
267 Static GTK+ 3 Gwenhywfar GUI library.
268
269 %description gui-gtk3-static -l pl.UTF-8
270 Statyczna biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar.
271
272 %package gui-qt4
273 Summary:        Qt 4 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
274 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu Qt 4 do Gwenhywfar
275 Group:          X11/Libraries
276 Requires:       %{name}-gui-cpp = %{version}-%{release}
277 Obsoletes:      gwenhywfar-qt < 4.15
278
279 %description gui-qt4
280 Qt 4 Gwenhywfar GUI library, containing Qt 4 implementation of the
281 GWEN_DIALOG framework.
282
283 %description gui-qt4 -l pl.UTF-8
284 Biblioteka graficznego interfejsu Qt 4 do Gwenhywfar, zawierająca
285 implementację Qt 4 szkieletu GWEN_DIALOG.
286
287 %package gui-qt4-devel
288 Summary:        Header files for Qt 4 Gwenhywfar GUI library
289 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu Qt 4 do Gwenhywfar
290 Group:          X11/Development/Libraries
291 Requires:       %{name}-gui-cpp-devel = %{version}-%{release}
292 Requires:       %{name}-gui-qt4 = %{version}-%{release}
293 Requires:       QtCore-devel >= 4
294 Requires:       QtGui-devel >= 4
295 Obsoletes:      gwenhywfar-qt-devel < 4.15
296
297 %description gui-qt4-devel
298 Header files for Qt 4 Gwenhywfar GUI library
299
300 %description gui-qt4-devel -l pl.UTF-8
301 Pliki nagłówkowe biblioteki graficznego interfejsu Qt 4 do Gwenhywfar.
302
303 %package gui-qt4-static
304 Summary:        Static Qt 4 Gwenhywfar GUI library
305 Summary(pl.UTF-8):      Statyczna biblioteka graficznego interfejsu Qt 4 do Gwenhywfar
306 Group:          X11/Development/Libraries
307 Requires:       %{name}-gui-qt4-devel = %{version}-%{release}
308 Obsoletes:      gwenhywfar-qt-static < 4.15
309
310 %description gui-qt4-static
311 Static Qt 4 Gwenhywfar GUI library.
312
313 %description gui-qt4-static -l pl.UTF-8
314 Statyczna biblioteka graficznego interfejsu Qt 4 do Gwenhywfar.
315
316 %package gui-qt5
317 Summary:        Qt 5 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
318 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu Qt 5 do Gwenhywfar
319 Group:          X11/Libraries
320 Requires:       %{name}-gui-cpp = %{version}-%{release}
321
322 %description gui-qt5
323 Qt 5 Gwenhywfar GUI library, containing Qt 5 implementation of the
324 GWEN_DIALOG framework.
325
326 %description gui-qt5 -l pl.UTF-8
327 Biblioteka graficznego interfejsu Qt 5 do Gwenhywfar, zawierająca
328 implementację Qt 5 szkieletu GWEN_DIALOG.
329
330 %package gui-qt5-devel
331 Summary:        Header files for Qt 5 Gwenhywfar GUI library
332 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu Qt 5 do Gwenhywfar
333 Group:          X11/Development/Libraries
334 Requires:       %{name}-gui-cpp-devel = %{version}-%{release}
335 Requires:       %{name}-gui-qt5 = %{version}-%{release}
336 Requires:       Qt5Core-devel >= 5
337 Requires:       Qt5Gui-devel >= 5
338 Requires:       Qt5Widgets-devel >= 5
339
340 %description gui-qt5-devel
341 Header files for Qt 5 Gwenhywfar GUI library
342
343 %description gui-qt5-devel -l pl.UTF-8
344 Pliki nagłówkowe biblioteki graficznego interfejsu Qt 5 do Gwenhywfar.
345
346 %package gui-qt5-static
347 Summary:        Static Qt 5 Gwenhywfar GUI library
348 Summary(pl.UTF-8):      Statyczna biblioteka graficznego interfejsu Qt 5 do Gwenhywfar
349 Group:          X11/Development/Libraries
350 Requires:       %{name}-gui-qt5-devel = %{version}-%{release}
351
352 %description gui-qt5-static
353 Static Qt 5 Gwenhywfar GUI library.
354
355 %description gui-qt5-static -l pl.UTF-8
356 Statyczna biblioteka graficznego interfejsu Qt 5 do Gwenhywfar.
357
358 %prep
359 %setup -q
360 %patch0 -p1
361 %patch1 -p1
362
363 %build
364 # gettextize not used (custom support instead of AM_GNU_GETTEXT)
365 touch config.rpath
366 %{__libtoolize}
367 %{__aclocal} -I m4
368 %{__autoconf}
369 %{__autoheader}
370 %{__automake}
371 %configure \
372         --disable-network-checks \
373         %{?with_static_libs:--enable-static} \
374         --with-guis="%{?with_fox:fox16 }gtk2 gtk3%{?with_qt4: qt4}%{?with_qt5: qt5}" \
375         --with-openssl-libs=%{_libdir} \
376         --with-qt4-libs=%{_libdir} \
377         --with-qt5-moc=%{_bindir}/moc-qt5 \
378         --with-qt5-qmake=%{_bindir}/qmake-qt5 \
379         --with-qt5-uic=%{_bindir}/uic-qt5
380
381 %{__make}
382
383 %if %{with tests}
384 %{__make} check
385 %endif
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389
390 %{__make} install \
391         DESTDIR=$RPM_BUILD_ROOT
392
393 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
394         $RPM_BUILD_ROOT%{_libdir}/gwenhywfar/plugins/*/*/*.la
395 %if %{with static_libs}
396 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gwenhywfar/plugins/*/*/*.a
397 %endif
398
399 %find_lang %{name}
400
401 %clean
402 rm -rf $RPM_BUILD_ROOT
403
404 %post   -p /sbin/ldconfig
405 %postun -p /sbin/ldconfig
406
407 %post   gui-cpp -p /sbin/ldconfig
408 %postun gui-cpp -p /sbin/ldconfig
409
410 %post   fox -p /sbin/ldconfig
411 %postun fox -p /sbin/ldconfig
412
413 %post   gui-gtk2 -p /sbin/ldconfig
414 %postun gui-gtk2 -p /sbin/ldconfig
415
416 %post   gui-gtk3 -p /sbin/ldconfig
417 %postun gui-gtk3 -p /sbin/ldconfig
418
419 %post   gui-qt4 -p /sbin/ldconfig
420 %postun gui-qt4 -p /sbin/ldconfig
421
422 %post   gui-qt5 -p /sbin/ldconfig
423 %postun gui-qt5 -p /sbin/ldconfig
424
425 %files -f %{name}.lang
426 %defattr(644,root,root,755)
427 %doc AUTHORS ChangeLog NEWS README TODO
428 %attr(755,root,root) %{_bindir}/gct-tool
429 %attr(755,root,root) %{_bindir}/gsa
430 %attr(755,root,root) %{_bindir}/mklistdoc
431 %attr(755,root,root) %{_bindir}/typemaker
432 %attr(755,root,root) %{_bindir}/typemaker2
433 %attr(755,root,root) %{_bindir}/xmlmerge
434 %attr(755,root,root) %{_libdir}/libgwenhywfar.so.*.*.*
435 %ghost %{_libdir}/libgwenhywfar.so.??
436 %dir %{_libdir}/gwenhywfar
437 %dir %{_libdir}/gwenhywfar/plugins
438 %dir %{_libdir}/gwenhywfar/plugins/*
439 %dir %{_libdir}/gwenhywfar/plugins/*/ct
440 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/ct/*.so*
441 %{_libdir}/gwenhywfar/plugins/*/ct/*.xml
442 %dir %{_libdir}/gwenhywfar/plugins/*/dbio
443 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/dbio/*.so*
444 %{_libdir}/gwenhywfar/plugins/*/dbio/*.xml
445 %dir %{_libdir}/gwenhywfar/plugins/*/configmgr
446 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/configmgr/*.so
447 %{_libdir}/gwenhywfar/plugins/*/configmgr/*.xml
448 # just ca-bundle.crt
449 %{_datadir}/gwenhywfar
450
451 %files devel
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{_bindir}/gwenhywfar-config
454 %attr(755,root,root) %{_libdir}/libgwenhywfar.so
455 %dir %{_includedir}/gwenhywfar5
456 %{_includedir}/gwenhywfar5/gwenhywfar
457 %{_aclocaldir}/gwenhywfar.m4
458 %{_pkgconfigdir}/gwenhywfar.pc
459 %{_libdir}/cmake/gwenhywfar-%{ver_cmake}
460
461 %if %{with static_libs}
462 %files static
463 %defattr(644,root,root,755)
464 %{_libdir}/libgwenhywfar.a
465 %endif
466
467 %files gui-cpp
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libdir}/libgwengui-cpp.so.*.*.*
470 %ghost %{_libdir}/libgwengui-cpp.so.??
471
472 %files gui-cpp-devel
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{_libdir}/libgwengui-cpp.so
475 %{_includedir}/gwenhywfar5/gwen-gui-cpp
476 %{_libdir}/cmake/gwengui-cpp-%{ver_cmake}
477
478 %if %{with static_libs}
479 %files gui-cpp-static
480 %defattr(644,root,root,755)
481 %{_libdir}/libgwengui-cpp.a
482 %endif
483
484 %if %{with fox}
485 %files fox
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libdir}/libgwengui-fox16.so.*.*.*
488 %ghost %{_libdir}/libgwengui-fox16.so.??
489
490 %files fox-devel
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_libdir}/libgwengui-fox16.so
493 %{_includedir}/gwenhywfar5/gwen-gui-fox16
494 %{_pkgconfigdir}/gwengui-fox16.pc
495
496 %if %{with static_libs}
497 %files fox-static
498 %defattr(644,root,root,755)
499 %{_libdir}/libgwengui-fox16.a
500 %endif
501 %endif
502
503 %files gui-gtk2
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_libdir}/libgwengui-gtk2.so.*.*.*
506 %ghost %{_libdir}/libgwengui-gtk2.so.??
507
508 %files gui-gtk2-devel
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/libgwengui-gtk2.so
511 %{_includedir}/gwenhywfar5/gwen-gui-gtk2
512 %{_pkgconfigdir}/gwengui-gtk2.pc
513
514 %if %{with static_libs}
515 %files gui-gtk2-static
516 %defattr(644,root,root,755)
517 %{_libdir}/libgwengui-gtk2.a
518 %endif
519
520 %files gui-gtk3
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/libgwengui-gtk3.so.*.*.*
523 %ghost %{_libdir}/libgwengui-gtk3.so.??
524
525 %files gui-gtk3-devel
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_libdir}/libgwengui-gtk3.so
528 %{_includedir}/gwenhywfar5/gwen-gui-gtk3
529 %{_pkgconfigdir}/gwengui-gtk3.pc
530
531 %if %{with static_libs}
532 %files gui-gtk3-static
533 %defattr(644,root,root,755)
534 %{_libdir}/libgwengui-gtk3.a
535 %endif
536
537 %if %{with qt4}
538 %files gui-qt4
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_libdir}/libgwengui-qt4.so.*.*.*
541 %ghost %{_libdir}/libgwengui-qt4.so.??
542
543 %files gui-qt4-devel
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libgwengui-qt4.so
546 %{_includedir}/gwenhywfar5/gwen-gui-qt4
547 %{_pkgconfigdir}/gwengui-qt4.pc
548 %{_libdir}/cmake/gwengui-qt4-%{ver_cmake}
549
550 %if %{with static_libs}
551 %files gui-qt4-static
552 %defattr(644,root,root,755)
553 %{_libdir}/libgwengui-qt4.a
554 %endif
555 %endif
556
557 %if %{with qt5}
558 %files gui-qt5
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/libgwengui-qt5.so.*.*.*
561 %ghost %{_libdir}/libgwengui-qt5.so.??
562
563 %files gui-qt5-devel
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libgwengui-qt5.so
566 %{_includedir}/gwenhywfar5/gwen-gui-qt5
567 %{_pkgconfigdir}/gwengui-qt5.pc
568 %{_libdir}/cmake/gwengui-qt5-%{ver_cmake}
569
570 %if %{with static_libs}
571 %files gui-qt5-static
572 %defattr(644,root,root,755)
573 %{_libdir}/libgwengui-qt5.a
574 %endif
575 %endif
This page took 0.306223 seconds and 3 git commands to generate.