]> git.pld-linux.org Git - packages/gvfs.git/blob - gvfs.spec
- updated gettext BR
[packages/gvfs.git] / gvfs.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # docs building and packaging
4 %bcond_without  afc     # AFC backend
5 %bcond_without  afp     # AFP support
6 %bcond_without  archive # archive support
7 %bcond_without  avahi   # DNS-SD / Avahi support
8 %bcond_without  bluray  # bluray metadata support
9 %bcond_without  cdda    # CDDA backend
10 %bcond_without  fuse    # FUSE support
11 %bcond_without  goa     # GOA backend
12 %bcond_with     gdu     # GDU (Gnome Disk Utility) volume monitor (3.0.2 <= v < 3.4)
13 %bcond_without  gphoto2 # gphoto2 support
14 %bcond_without  gtk     # GTK+
15 %bcond_without  gudev   # gudev support (if disabled, HAL could be used)
16 %bcond_without  http    # HTTP/DAV backend
17 %bcond_without  keyring # GNOME Keyring support in gvfs and udisks plugin
18 %bcond_without  mtp     # MTP support
19 %bcond_without  obexftp # ObexFTP backend
20 %bcond_without  samba   # SMB support
21 %bcond_without  systemd # libsystemd-login support
22 %bcond_without  udev    # udev support (needed also for gphoto2, mtp, udisks2)
23 %bcond_without  udisks2 # libudisks2 support
24
25 %if %{without gudev}
26 %undefine       with_gphoto2
27 %undefine       with_mtp
28 %undefine       with_udisks2
29 %endif
30
31 %ifarch s390 s390x
32 %undefine       with_afc
33 %endif
34
35 Summary:        gvfs - userspace virtual filesystem
36 Summary(pl.UTF-8):      gvfs - wirtualny system plików w przestrzeni użytkownika
37 Name:           gvfs
38 Version:        1.22.2
39 Release:        1
40 License:        LGPL v2+
41 Group:          Libraries
42 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.22/%{name}-%{version}.tar.xz
43 # Source0-md5:  6b00ec682a6851bcdad7814dd799e228
44 Patch0:         set_attributes_from_info-v1.patch
45 URL:            https://live.gnome.org/gvfs
46 BuildRequires:  autoconf >= 2.64
47 BuildRequires:  automake >= 1:1.11.1
48 %{?with_avahi:BuildRequires:    avahi-devel >= 0.6.22}
49 %{?with_avahi:BuildRequires:    avahi-glib-devel >= 0.6.22}
50 %{?with_obexftp:BuildRequires:  bluez-libs-devel >= 4.0}
51 %{?with_cdda:BuildRequires:     cdparanoia-III-devel >= 1:10}
52 BuildRequires:  dbus-devel
53 %{?with_obexftp:BuildRequires:  dbus-glib-devel}
54 %{?with_doc:BuildRequires:      docbook-dtd42-xml}
55 %{?with_doc:BuildRequires:      docbook-style-xsl}
56 %{?with_obexftp:BuildRequires:  expat-devel >= 1.95}
57 BuildRequires:  gettext-tools
58 BuildRequires:  glib2-devel >= 1:2.38.0
59 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel < 3.4}
60 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel >= 3.0.2}
61 %{?with_goa:BuildRequires:      gnome-online-accounts-devel >= 3.8.0}
62 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.0}
63 BuildRequires:  intltool >= 0.40.0
64 %{?with_archive:BuildRequires:  libarchive-devel >= 3.0.22}
65 %{?with_bluray:BuildRequires:   libbluray-devel}
66 %{?with_cdda:BuildRequires:     libcdio-paranoia-devel >= 0.78.2}
67 %{?with_fuse:BuildRequires:     libfuse-devel >= 2.8.0}
68 BuildRequires:  libgcrypt-devel >= 1.2.2
69 %{?with_gphoto2:BuildRequires:  libgphoto2-devel >= 2.5.0}
70 %{?with_afc:BuildRequires:      libimobiledevice-devel >= 1.1.5}
71 %{?with_mtp:BuildRequires:      libmtp-devel >= 1.1.6}
72 %{?with_afc:BuildRequires:      libplist-devel >= 0.15}
73 %{?with_keyring:BuildRequires:  libsecret-devel}
74 %{?with_samba:BuildRequires:    libsmbclient-devel >= 3.4}
75 %{?with_http:BuildRequires:     libsoup-devel >= 2.42.0}
76 BuildRequires:  libtool >= 2:2.2
77 %{?with_http:BuildRequires:     libxml2-devel >= 1:2.6.31}
78 %{?with_doc:BuildRequires:      libxslt-progs}
79 BuildRequires:  pkgconfig
80 BuildRequires:  rpmbuild(macros) >= 1.592
81 %{?with_systemd:BuildRequires:  systemd-devel >= 44}
82 BuildRequires:  tar >= 1:1.22
83 %{?with_udev:BuildRequires:     udev-devel >= 1:138}
84 %{?with_gudev:BuildRequires:    udev-glib-devel >= 1:147}
85 %{?with_udisks2:BuildRequires:  udisks2-devel >= 1.97.0}
86 BuildRequires:  xz
87 Requires(post,postun):  glib2 >= 1:2.38.0
88 %{?with_avahi:Requires: avahi-glib >= 0.6.22}
89 %{?with_cdda:Requires:  cdparanoia-III-libs >= 1:10}
90 %{?with_cdda:Requires:  libcdio-paranoia >= 0.78.2}
91 Requires:       libplist >= 0.15
92 Requires:       libsoup >= 2.42.0
93 Requires:       libxml2 >= 1:2.6.31
94 %{?with_gudev:Requires: udev-glib >= 1:147}
95 %{?with_udev:Requires:  udev-libs >= 1:138}
96 %{?with_udisks2:Requires:       udisks2 >= 1.97.0}
97 %{?with_afc:Suggests:   %{name}-afc}
98 %{?with_afp:Suggests:   %{name}-afp}
99 %{?with_archive:Suggests:       %{name}-archive}
100 %{?with_fuse:Suggests:  %{name}-fuse}
101 %{?with_goa:Suggests:   %{name}-goa}
102 %{?with_gphoto2:Suggests:       %{name}-gphoto2}
103 %{?with_mtp:Suggests:   %{name}-mtp}
104 %{?with_samba:Suggests: %{name}-smb}
105 %{?with_obexftp:Suggests:       obex-data-server >= 0.4}
106 Obsoletes:      gnome-mount <= 0.8
107 Obsoletes:      gvfs-libs < 1.20.0
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define         _libexecdir     %{_libdir}/%{name}
111
112 %description
113 gvfs is a userspace virtual filesystem where mount runs as a separate
114 processes which you talk to via D-BUS. It contains a gio module that
115 seamlessly adds gvfs support to all applications using the gio API.
116
117 %description -l pl.UTF-8
118 gvfs to wirtualny system plik w przestrzeni użytkownika. Montowanie w
119 nim działa jako oddzielny proces, z którym komunikacja odbywa się
120 przez D-BUS. Zawiera moduł gio dodający w sposób przezroczysty obsługę
121 gfvs-a do wszystkich aplikacji używających API gio.
122
123 %package devel
124 Summary:        Header files for gvfs library
125 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gvfs
126 Group:          Development/Libraries
127 Requires:       glib2-devel >= 1:2.38.0
128
129 %description devel
130 Header files for gvfs library.
131
132 %description devel -l pl.UTF-8
133 Pliki nagłówkowe biblioteki gvfs.
134
135 %package afc
136 Summary:        AFC support for gvfs
137 Summary(pl.UTF-8):      Obsługa AFC dla gvfs
138 Group:          Libraries
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       libimobiledevice >= 1.1.5
141 Requires:       usbmuxd
142
143 %description afc
144 This package provides support for reading files on mobile devices
145 including phones and music players to applications using gvfs.
146
147 %description afc -l pl.UTF-8
148 Ten pakiet zapewnia obsługę odczytu plików na urządzeniach
149 przenośnych, w tym telefonach i odtwarzaczach muzyki dla aplikacji
150 wykorzystujących gvfs.
151
152 %package afp
153 Summary:        AFP support for gvfs
154 Summary(pl.UTF-8):      Obsługa AFP dla gvfs
155 Group:          Libraries
156 Requires:       %{name} = %{version}-%{release}
157
158 %description afp
159 This package provides support for reading and writing files on Mac OS
160 X and original Mac OS network shares via Apple Filing Protocol to
161 applications using gvfs.
162
163 %description afp -l pl.UTF-8
164 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
165 sieciowych Mac OS X oraz oryginalnego Mac OS poprzez Apple Filing
166 Protocol dla aplikacji wykorzystujących gvfs.
167
168 %package archive
169 Summary:        Archiving support for gvfs
170 Summary(pl.UTF-8):      Obsługa archiwów dla gvfs
171 Group:          Libraries
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       libarchive >= 3.0.22
174
175 %description archive
176 This package provides support for accessing files inside Zip and Tar
177 archives, as well as ISO images, to applications using gvfs.
178
179 %description archive -l pl.UTF-8
180 Ten pakiet zapewnia dostęp do plików wewnątrz archiwów Zip i Tar oraz
181 obrazów ISO dla aplikacji wykorzystujących gvfs.
182
183 %package fuse
184 Summary:        FUSE support for gvfs
185 Summary(pl.UTF-8):      Obsługa FUSE dla gvfs
186 Group:          Libraries
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       libfuse
189
190 %description fuse
191 This package provides support for applications not using gio to access
192 the gvfs filesystems.
193
194 %description fuse -l pl.UTF-8
195 Ten pakiet zapewnia obsługę aplikacji nie używających gio do dostępu
196 do systemów plików gvfs.
197
198 %package goa
199 Summary:        GOA support for gvfs
200 Summary(pl.UTF-8):      Obsługa GOA dla gvfs
201 Group:          Libraries
202 Requires:       %{name} = %{version}-%{release}
203 Requires:       gnome-online-accounts-libs >= 3.8.0
204
205 %description goa
206 This package provides seamless integration with gnome-online-accounts
207 file services.
208
209 %description goa -l pl.UTF-8
210 Ten pakiet zapewnia przezroczystą integrację z usługami plikowymi
211 gnome-online-accounts.
212
213 %package gphoto2
214 Summary:        gphoto2 support for gvfs
215 Summary(pl.UTF-8):      Obsługa gphoto2 dla gvfs
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218
219 %description gphoto2
220 This package provides support for reading and writing files on PTP
221 based cameras (Picture Transfer Protocol) and MTP based media players
222 (Media Transfer Protocol) to applications using gvfs.
223
224 %description gphoto2 -l pl.UTF-8
225 Ten pakiet zapewnia obsługę odczytu i zapisu plików na aparatach
226 obsługujących protokół PTP (Picture Transfer Protocol) oraz
227 odtwarzaczach multimedialnych obsługujących protokół MTP (Media
228 Transfer Protocol) dla aplikacji wykorzystujących gvfs.
229
230 %package mtp
231 Summary:        MTP support for gvfs
232 Summary(pl.UTF-8):      Obsługa MTP dla gvfs
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       libmtp >= 1.1.6
236
237 %description mtp
238 This package provides support for reading and writing files on MTP
239 based devices (Media Transfer Protocol) to applications using gvfs.
240
241 %description mtp -l pl.UTF-8
242 Ten pakiet zapewnia obsługę odczytu i zapisu plików na urządzeniach
243 obsługujących protokół MTP (Media Transfer Protocol) dla aplikacji
244 wykorzystujących gvfs.
245
246 %package smb
247 Summary:        Windows fileshare support for gvfs
248 Summary(pl.UTF-8):      Obsługa udziałów sieciowych Windows dla gvfs
249 Group:          Libraries
250 Requires:       %{name} = %{version}-%{release}
251
252 %description smb
253 This package provides support for reading and writing files on Windows
254 shares (SMB) to applications using gvfs.
255
256 %description smb -l pl.UTF-8
257 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
258 sieciowych Windows (SMB) dla aplikacji wykorzystujących gvfs.
259
260 %package -n bash-completion-gvfs
261 Summary:        bash-completion for gvfs
262 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gvfs
263 Group:          Applications/Shells
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       bash-completion >= 2
266
267 %description -n bash-completion-gvfs
268 This package provides bash-completion for gvfs.
269
270 %description -n bash-completion-gvfs -l pl.UTF-8
271 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gvfs.
272
273 %prep
274 %setup -q
275 %patch0 -p1
276
277 %build
278 %{__intltoolize}
279 %{__libtoolize}
280 %{__aclocal}
281 %{__autoconf}
282 %{__autoheader}
283 %{__automake}
284 %configure \
285         SSH_PROGRAM=/usr/bin/ssh \
286         %{__enable_disable afc} \
287         %{__enable_disable afp} \
288         %{__enable_disable archive} \
289         %{__enable_disable avahi} \
290         %{__enable_disable bluray} \
291         %{__enable_disable cdda} \
292         %{__enable_disable doc documentation} \
293         %{__enable_disable fuse} \
294         %{__enable_disable gdu} \
295         %{__enable_disable goa} \
296         %{__enable_disable gphoto2} \
297         %{__enable_disable gtk} \
298         %{__enable_disable gudev} \
299         %{__enable_disable http} \
300         %{__enable_disable keyring} \
301         %{__enable_disable mtp libmtp} \
302         %{__enable_disable obexftp} \
303         %{__enable_disable samba} \
304         %{__enable_disable systemd libsystemd-login} \
305         %{__enable_disable udev} \
306         %{__enable_disable udisks2} \
307         --disable-hal \
308         --disable-silent-rules
309
310 %{__make}
311
312 %install
313 rm -rf $RPM_BUILD_ROOT
314 %{__make} install \
315         DESTDIR=$RPM_BUILD_ROOT
316
317 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{gio/modules,gvfs}/*.la
318
319 %find_lang gvfs
320
321 %clean
322 rm -rf $RPM_BUILD_ROOT
323
324 %post
325 %glib_compile_schemas
326 umask 022
327 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
328 # Reload .mount files:
329 killall -USR1 gvfsd >/dev/null 2>&1 || :
330
331 %postun
332 if [ "$1" = "0" ]; then
333         %glib_compile_schemas
334 fi
335 umask 022
336 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
337 exit 0
338
339 # Reload .mount files when single subpackage is installed:
340 %post afc
341 killall -USR1 gvfsd >/dev/null 2>&1 || :
342
343 %post archive
344 killall -USR1 gvfsd >/dev/null 2>&1 || :
345
346 %post goa
347 killall -USR1 gvfsd >/dev/null 2>&1 || :
348
349 %post gphoto2
350 killall -USR1 gvfsd >/dev/null 2>&1 || :
351
352 %post mtp
353 killall -USR1 gvfsd >/dev/null 2>&1 || :
354
355 %post smb
356 %glib_compile_schemas
357 killall -USR1 gvfsd >/dev/null 2>&1 || :
358
359 %postun smb
360 if [ "$1" = "0" ]; then
361         %glib_compile_schemas
362 fi
363
364 %files -f gvfs.lang
365 %defattr(644,root,root,755)
366 %doc AUTHORS ChangeLog NEWS README TODO
367 %attr(755,root,root) %{_bindir}/gvfs-cat
368 %attr(755,root,root) %{_bindir}/gvfs-copy
369 %attr(755,root,root) %{_bindir}/gvfs-info
370 %attr(755,root,root) %{_bindir}/gvfs-less
371 %attr(755,root,root) %{_bindir}/gvfs-ls
372 %attr(755,root,root) %{_bindir}/gvfs-mime
373 %attr(755,root,root) %{_bindir}/gvfs-mkdir
374 %attr(755,root,root) %{_bindir}/gvfs-monitor-dir
375 %attr(755,root,root) %{_bindir}/gvfs-monitor-file
376 %attr(755,root,root) %{_bindir}/gvfs-mount
377 %attr(755,root,root) %{_bindir}/gvfs-move
378 %attr(755,root,root) %{_bindir}/gvfs-open
379 %attr(755,root,root) %{_bindir}/gvfs-rename
380 %attr(755,root,root) %{_bindir}/gvfs-rm
381 %attr(755,root,root) %{_bindir}/gvfs-save
382 %attr(755,root,root) %{_bindir}/gvfs-set-attribute
383 %attr(755,root,root) %{_bindir}/gvfs-trash
384 %attr(755,root,root) %{_bindir}/gvfs-tree
385 %attr(755,root,root) %{_libdir}/gio/modules/libgioremote-volume-monitor.so
386 %attr(755,root,root) %{_libdir}/gio/modules/libgvfsdbus.so
387 %dir %{_libexecdir}
388 %attr(755,root,root) %{_libexecdir}/gvfsd
389 %attr(755,root,root) %{_libexecdir}/gvfsd-burn
390 %attr(755,root,root) %{_libexecdir}/gvfsd-computer
391 %attr(755,root,root) %{_libexecdir}/gvfsd-ftp
392 %attr(755,root,root) %{_libexecdir}/gvfsd-localtest
393 %attr(755,root,root) %{_libexecdir}/gvfsd-metadata
394 %attr(755,root,root) %{_libexecdir}/gvfsd-network
395 %attr(755,root,root) %{_libexecdir}/gvfsd-sftp
396 %attr(755,root,root) %{_libexecdir}/gvfsd-trash
397 %attr(755,root,root) %{_libexecdir}/libgvfscommon.so
398 %attr(755,root,root) %{_libexecdir}/libgvfsdaemon.so
399 %{_datadir}/dbus-1/services/gvfs-daemon.service
400 %{_datadir}/dbus-1/services/gvfs-metadata.service
401 %dir %{_datadir}/gvfs
402 %dir %{_datadir}/gvfs/mounts
403 %dir %{_datadir}/gvfs/remote-volume-monitors
404 %{_datadir}/gvfs/mounts/burn.mount
405 %{_datadir}/gvfs/mounts/computer.mount
406 %{_datadir}/gvfs/mounts/ftp.mount
407 %{_datadir}/gvfs/mounts/localtest.mount
408 %{_datadir}/gvfs/mounts/network.mount
409 %{_datadir}/gvfs/mounts/sftp.mount
410 %{_datadir}/gvfs/mounts/trash.mount
411 %{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
412
413 # cdda
414 %if %{with cdda}
415 %attr(755,root,root) %{_libexecdir}/gvfsd-cdda
416 %{_datadir}/gvfs/mounts/cdda.mount
417 %endif
418
419 # http
420 %if %{with http}
421 %attr(755,root,root) %{_libexecdir}/gvfsd-dav
422 %attr(755,root,root) %{_libexecdir}/gvfsd-http
423 %{_datadir}/gvfs/mounts/http.mount
424 %{_datadir}/gvfs/mounts/dav.mount
425 %{?with_avahi:%{_datadir}/gvfs/mounts/dav+sd.mount}
426 %endif
427
428 # obexftp
429 %if %{with obexftp}
430 %attr(755,root,root) %{_libexecdir}/gvfsd-obexftp
431 %{_datadir}/gvfs/mounts/obexftp.mount
432 %endif
433
434 # gtk
435 %if %{with gtk}
436 %attr(755,root,root) %{_libexecdir}/gvfsd-recent
437 %{_datadir}/gvfs/mounts/recent.mount
438 %endif
439
440 # udisks2
441 %if %{with udisks2}
442 %attr(755,root,root) %{_libexecdir}/gvfs-udisks2-volume-monitor
443 %{_datadir}/dbus-1/services/org.gtk.Private.UDisks2VolumeMonitor.service
444 %{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
445 %endif
446
447 # avahi
448 %if %{with avahi}
449 %attr(755,root,root) %{_libexecdir}/gvfsd-dnssd
450 %{_datadir}/gvfs/mounts/dns-sd.mount
451 %{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
452 %{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
453 %endif
454
455 %if %{with doc}
456 %{_mandir}/man1/gvfs-*.1*
457 %{_mandir}/man1/gvfsd.1*
458 %{_mandir}/man1/gvfsd-metadata.1*
459 %{_mandir}/man7/gvfs.7*
460 %endif
461
462 %files devel
463 %defattr(644,root,root,755)
464 %{_includedir}/gvfs-client
465
466 %if %{with afc}
467 %files afc
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libexecdir}/gvfs-afc-volume-monitor
470 %attr(755,root,root) %{_libexecdir}/gvfsd-afc
471 %{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
472 %{_datadir}/gvfs/mounts/afc.mount
473 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
474 %endif
475
476 %if %{with afp}
477 %files afp
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{_libexecdir}/gvfsd-afp
480 %attr(755,root,root) %{_libexecdir}/gvfsd-afp-browse
481 %{_datadir}/gvfs/mounts/afp-browse.mount
482 %{_datadir}/gvfs/mounts/afp.mount
483 %endif
484
485 %if %{with archive}
486 %files archive
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_libexecdir}/gvfsd-archive
489 %{_datadir}/gvfs/mounts/archive.mount
490 %endif
491
492 %if %{with fuse}
493 %files fuse
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libexecdir}/gvfsd-fuse
496 %if %{with doc}
497 %{_mandir}/man1/gvfsd-fuse.1*
498 %endif
499 %if %{with systemd}
500 # FIXME: reusing USE_LIBSYSTEMD_LOGIN as systemd has no universal header or pkg-config file
501 %{systemdtmpfilesdir}/gvfsd-fuse-tmpfiles.conf
502 %endif
503 %endif
504
505 %if %{with goa}
506 %files goa
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_libexecdir}/gvfs-goa-volume-monitor
509 %{_datadir}/dbus-1/services/org.gtk.Private.GoaVolumeMonitor.service
510 %{_datadir}/gvfs/remote-volume-monitors/goa.monitor
511 %endif
512
513 %if %{with gphoto2}
514 %files gphoto2
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_libexecdir}/gvfs-gphoto2-volume-monitor
517 %attr(755,root,root) %{_libexecdir}/gvfsd-gphoto2
518 %{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
519 %{_datadir}/gvfs/mounts/gphoto2.mount
520 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
521 %endif
522
523 %if %{with mtp}
524 %files mtp
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libexecdir}/gvfs-mtp-volume-monitor
527 %attr(755,root,root) %{_libexecdir}/gvfsd-mtp
528 %{_datadir}/dbus-1/services/org.gtk.Private.MTPVolumeMonitor.service
529 %{_datadir}/gvfs/mounts/mtp.mount
530 %{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
531 %endif
532
533 %if %{with samba}
534 %files smb
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libexecdir}/gvfsd-smb
537 %attr(755,root,root) %{_libexecdir}/gvfsd-smb-browse
538 %{_datadir}/gvfs/mounts/smb-browse.mount
539 %{_datadir}/gvfs/mounts/smb.mount
540 %{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
541 %{_datadir}/GConf/gsettings/gvfs-smb.convert
542 %endif
543
544 %files -n bash-completion-gvfs
545 %defattr(644,root,root,755)
546 %{bash_compdir}/gvfs
This page took 0.149297 seconds and 3 git commands to generate.