]> git.pld-linux.org Git - packages/gvfs.git/blob - gvfs.spec
c6925cd89127e61afd645367c7783d5fef2709b5
[packages/gvfs.git] / gvfs.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # docs building and packaging
4 %bcond_without  admin   # admin backend
5 %bcond_without  afc     # AFC backend
6 %bcond_without  afp     # AFP support
7 %bcond_without  archive # archive support
8 %bcond_without  avahi   # DNS-SD / Avahi support
9 %bcond_without  bluray  # bluray metadata support
10 %bcond_without  cdda    # CDDA backend
11 %bcond_without  fuse    # FUSE support
12 %bcond_without  goa     # GOA backend (needed also for google)
13 %bcond_without  google  # Google backend
14 %bcond_without  gphoto2 # gphoto2 support
15 %bcond_without  gtk     # GTK+
16 %bcond_without  gudev   # gudev support (needed for gphoto2, mtp, udisks2)
17 %bcond_without  http    # HTTP/DAV backend
18 %bcond_without  keyring # GNOME Keyring support in gvfs and udisks plugin
19 %bcond_without  mtp     # MTP support
20 %bcond_without  nfs     # NFS support
21 %bcond_without  samba   # SMB support
22 %bcond_without  systemd # libsystemd-login support
23 %bcond_without  udev    # udev support (needed also for gphoto2, mtp, udisks2)
24 %bcond_without  udisks2 # libudisks2 support
25
26 %if %{without gudev}
27 %undefine       with_gphoto2
28 %undefine       with_mtp
29 %undefine       with_udisks2
30 %endif
31 %if %{without goa}
32 %undefine       with_google
33 %endif
34
35 %ifarch s390 s390x
36 %undefine       with_afc
37 %endif
38
39 Summary:        gvfs - userspace virtual filesystem
40 Summary(pl.UTF-8):      gvfs - wirtualny system plików w przestrzeni użytkownika
41 Name:           gvfs
42 Version:        1.44.1
43 Release:        1
44 License:        LGPL v2+
45 Group:          Libraries
46 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.44/%{name}-%{version}.tar.xz
47 # Source0-md5:  72383474f52d05c21ef2be96d0b91974
48 Patch0:         set_attributes_from_info-v1.patch
49 URL:            https://live.gnome.org/gvfs
50 %{?with_avahi:BuildRequires:    avahi-devel >= 0.6.22}
51 %{?with_avahi:BuildRequires:    avahi-glib-devel >= 0.6.22}
52 BuildRequires:  dbus-devel
53 %{?with_doc:BuildRequires:      docbook-dtd42-xml}
54 %{?with_doc:BuildRequires:      docbook-style-xsl}
55 BuildRequires:  gcr-devel >= 3
56 BuildRequires:  gettext-tools >= 0.19.4
57 BuildRequires:  glib2-devel >= 1:2.58.0
58 %{?with_goa:BuildRequires:      gnome-online-accounts-devel >= 3.18.0}
59 BuildRequires:  gsettings-desktop-schemas-devel >= 3.33.0
60 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.0}
61 %{?with_archive:BuildRequires:  libarchive-devel >= 3.0.22}
62 %{?with_bluray:BuildRequires:   libbluray-devel}
63 %{?with_admin:BuildRequires:    libcap-devel}
64 %{?with_cdda:BuildRequires:     libcdio-paranoia-devel >= 0.78.2}
65 %{?with_fuse:BuildRequires:     libfuse3-devel >= 3.0.0}
66 BuildRequires:  libgcrypt-devel >= 1.2.2
67 %{?with_google:BuildRequires:   libgdata-devel >= 0.17.11}
68 %{?with_gphoto2:BuildRequires:  libgphoto2-devel >= 2.5.0}
69 %{?with_afc:BuildRequires:      libimobiledevice-devel >= 1.2.0}
70 %{?with_mtp:BuildRequires:      libmtp-devel >= 1.1.15}
71 %{?with_nfs:BuildRequires:      libnfs-devel >= 1.9.8}
72 %{?with_afc:BuildRequires:      libplist-devel >= 0.15}
73 %{?with_keyring:BuildRequires:  libsecret-devel}
74 %{?with_samba:BuildRequires:    libsmbclient-devel >= 3.4}
75 %{?with_http:BuildRequires:     libsoup-devel >= 2.58.0}
76 BuildRequires:  libtool >= 2:2.2
77 BuildRequires:  libusb-devel >= 1.0.21
78 BuildRequires:  libxml2-devel >= 1:2.6.31
79 %{?with_doc:BuildRequires:      libxslt-progs}
80 BuildRequires:  meson >= 0.50.0
81 BuildRequires:  ninja >= 1.5
82 BuildRequires:  openssh-clients
83 BuildRequires:  pkgconfig
84 %{?with_admin:BuildRequires:    polkit-devel >= 0.114}
85 BuildRequires:  rpmbuild(macros) >= 1.727
86 %{?with_systemd:BuildRequires:  systemd-devel >= 1:206}
87 BuildRequires:  tar >= 1:1.22
88 %{?with_udev:BuildRequires:     udev-devel >= 1:138}
89 %{?with_gudev:BuildRequires:    udev-glib-devel >= 1:147}
90 %{?with_udisks2:BuildRequires:  udisks2-devel >= 1.97.0}
91 BuildRequires:  xz
92 Requires(post,postun):  glib2 >= 1:2.58.0
93 Requires:       %{name}-libs = %{version}-%{release}
94 %{?with_avahi:Requires: avahi-glib >= 0.6.22}
95 Requires:       gsettings-desktop-schemas >= 3.33.0
96 %{?with_cdda:Requires:  libcdio-paranoia >= 0.78.2}
97 %{?with_nfs:Requires:   libnfs >= 1.9.8}
98 Requires:       libplist >= 0.15
99 Requires:       libsoup >= 2.58.0
100 Requires:       libusb >= 1.0.21
101 Requires:       libxml2 >= 1:2.6.31
102 Requires:       polkit-libs >= 0.114
103 %{?with_gudev:Requires: udev-glib >= 1:147}
104 %{?with_udev:Requires:  udev-libs >= 1:138}
105 %{?with_udisks2:Requires:       udisks2 >= 1.97.0}
106 %{?with_afc:Suggests:   %{name}-afc}
107 %{?with_afp:Suggests:   %{name}-afp}
108 %{?with_archive:Suggests:       %{name}-archive}
109 %{?with_fuse:Suggests:  %{name}-fuse}
110 %{?with_goa:Suggests:   %{name}-goa}
111 %{?with_google:Suggests:        %{name}-google}
112 %{?with_gphoto2:Suggests:       %{name}-gphoto2}
113 %{?with_mtp:Suggests:   %{name}-mtp}
114 %{?with_samba:Suggests: %{name}-smb}
115 Obsoletes:      bash-completion-gvfs
116 Obsoletes:      gnome-mount <= 0.8
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define         _libexecdir     %{_libdir}/%{name}
120
121 %description
122 gvfs is a userspace virtual filesystem where mount runs as a separate
123 processes which you talk to via D-BUS. It contains a gio module that
124 seamlessly adds gvfs support to all applications using the gio API.
125
126 %description -l pl.UTF-8
127 gvfs to wirtualny system plik w przestrzeni użytkownika. Montowanie w
128 nim działa jako oddzielny proces, z którym komunikacja odbywa się
129 przez D-BUS. Zawiera moduł gio dodający w sposób przezroczysty obsługę
130 gfvs-a do wszystkich aplikacji używających API gio.
131
132 %package libs
133 Summary:        Common GVFS shared libraries
134 Summary(pl.UTF-8):      Wspólne biblioteki współdzielone GVFS
135 Group:          Libraries
136 Requires:       glib2 >= 1:2.58.0
137 Conflicts:      gvfs < 1.22.3-2
138
139 %description libs
140 Common GVFS (private) shared libraries.
141
142 %description libs -l pl.UTF-8
143 Wspólne (prywatne) biblioteki współdzielone GVFS.
144
145 %package devel
146 Summary:        Header files for gvfs library
147 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gvfs
148 Group:          Development/Libraries
149 Requires:       %{name}-libs = %{version}-%{release}
150 Requires:       glib2-devel >= 1:2.58.0
151
152 %description devel
153 Header files for gvfs library.
154
155 %description devel -l pl.UTF-8
156 Pliki nagłówkowe biblioteki gvfs.
157
158 %package afc
159 Summary:        AFC support for gvfs
160 Summary(pl.UTF-8):      Obsługa AFC dla gvfs
161 Group:          Libraries
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       libimobiledevice >= 1.2.0
164 Requires:       usbmuxd
165
166 %description afc
167 This package provides support for reading files on mobile devices
168 including phones and music players to applications using gvfs.
169
170 %description afc -l pl.UTF-8
171 Ten pakiet zapewnia obsługę odczytu plików na urządzeniach
172 przenośnych, w tym telefonach i odtwarzaczach muzyki dla aplikacji
173 wykorzystujących gvfs.
174
175 %package afp
176 Summary:        AFP support for gvfs
177 Summary(pl.UTF-8):      Obsługa AFP dla gvfs
178 Group:          Libraries
179 Requires:       %{name} = %{version}-%{release}
180
181 %description afp
182 This package provides support for reading and writing files on Mac OS
183 X and original Mac OS network shares via Apple Filing Protocol to
184 applications using gvfs.
185
186 %description afp -l pl.UTF-8
187 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
188 sieciowych Mac OS X oraz oryginalnego Mac OS poprzez Apple Filing
189 Protocol dla aplikacji wykorzystujących gvfs.
190
191 %package archive
192 Summary:        Archiving support for gvfs
193 Summary(pl.UTF-8):      Obsługa archiwów dla gvfs
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       libarchive >= 3.0.22
197
198 %description archive
199 This package provides support for accessing files inside Zip and Tar
200 archives, as well as ISO images, to applications using gvfs.
201
202 %description archive -l pl.UTF-8
203 Ten pakiet zapewnia dostęp do plików wewnątrz archiwów Zip i Tar oraz
204 obrazów ISO dla aplikacji wykorzystujących gvfs.
205
206 %package fuse
207 Summary:        FUSE support for gvfs
208 Summary(pl.UTF-8):      Obsługa FUSE dla gvfs
209 Group:          Libraries
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       libfuse3
212
213 %description fuse
214 This package provides support for applications not using gio to access
215 the gvfs filesystems.
216
217 %description fuse -l pl.UTF-8
218 Ten pakiet zapewnia obsługę aplikacji nie używających gio do dostępu
219 do systemów plików gvfs.
220
221 %package goa
222 Summary:        GOA support for gvfs
223 Summary(pl.UTF-8):      Obsługa GOA dla gvfs
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       gnome-online-accounts-libs >= 3.18.0
227
228 %description goa
229 This package provides seamless integration with gnome-online-accounts
230 file services.
231
232 %description goa -l pl.UTF-8
233 Ten pakiet zapewnia przezroczystą integrację z usługami plikowymi
234 gnome-online-accounts.
235
236 %package google
237 Summary:        Google Drive support for gvfs
238 Summary(pl.UTF-8):      Obsługa Google Drive dla gvfs
239 Group:          Libraries
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       gnome-online-accounts-libs >= 3.18.0
242 Requires:       libgdata >= 0.17.11
243
244 %description google
245 This package provides support for Google Drive to applications using
246 gvfs.
247
248 %description google -l pl.UTF-8
249 Ten pakiet zapewnia obsługę Google Drive dla aplikacji
250 wykorzystujących gvfs.
251
252 %package gphoto2
253 Summary:        gphoto2 support for gvfs
254 Summary(pl.UTF-8):      Obsługa gphoto2 dla gvfs
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257
258 %description gphoto2
259 This package provides support for reading and writing files on PTP
260 based cameras (Picture Transfer Protocol) and MTP based media players
261 (Media Transfer Protocol) to applications using gvfs.
262
263 %description gphoto2 -l pl.UTF-8
264 Ten pakiet zapewnia obsługę odczytu i zapisu plików na aparatach
265 obsługujących protokół PTP (Picture Transfer Protocol) oraz
266 odtwarzaczach multimedialnych obsługujących protokół MTP (Media
267 Transfer Protocol) dla aplikacji wykorzystujących gvfs.
268
269 %package mtp
270 Summary:        MTP support for gvfs
271 Summary(pl.UTF-8):      Obsługa MTP dla gvfs
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       libmtp >= 1.1.15
275
276 %description mtp
277 This package provides support for reading and writing files on MTP
278 based devices (Media Transfer Protocol) to applications using gvfs.
279
280 %description mtp -l pl.UTF-8
281 Ten pakiet zapewnia obsługę odczytu i zapisu plików na urządzeniach
282 obsługujących protokół MTP (Media Transfer Protocol) dla aplikacji
283 wykorzystujących gvfs.
284
285 %package smb
286 Summary:        Windows fileshare support for gvfs
287 Summary(pl.UTF-8):      Obsługa udziałów sieciowych Windows dla gvfs
288 Group:          Libraries
289 Requires:       %{name} = %{version}-%{release}
290
291 %description smb
292 This package provides support for reading and writing files on Windows
293 shares (SMB) to applications using gvfs.
294
295 %description smb -l pl.UTF-8
296 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
297 sieciowych Windows (SMB) dla aplikacji wykorzystujących gvfs.
298
299 %prep
300 %setup -q
301 #%%patch0 -p1
302
303 %build
304 %meson build \
305         -Dadmin=%{?with_admin:true}%{!?with_admin:false} \
306         -Dafc=%{?with_afc:true}%{!?with_afc:false} \
307         -Dafp=%{?with_afp:true}%{!?with_afp:false} \
308         -Darchive=%{?with_archive:true}%{!?with_archive:false} \
309         -Davahi=%{?with_avahi:true}%{!?with_avahi:false} \
310         -Dbluray=%{?with_bluray:true}%{!?with_bluray:false} \
311         -Dcdda=%{?with_cdda:true}%{!?with_cdda:false} \
312         -Ddocumentation=%{?with_doc:true}%{!?with_doc:false} \
313         -Dfuse=%{?with_fuse:true}%{!?with_fuse:false} \
314         -Dgoa=%{?with_goa:true}%{!?with_goa:false} \
315         -Dgoogle=%{?with_google:true}%{!?with_google:false} \
316         -Dgphoto2=%{?with_gphoto2:true}%{!?with_gphoto2:false} \
317         -Dgtk=%{?with_gtk:true}%{!?with_gtk:false} \
318         -Dgudev=%{?with_gudev:true}%{!?with_gudev:false} \
319         -Dhttp=%{?with_http:true}%{!?with_http:false} \
320         -Dkeyring=%{?with_keyring:true}%{!?with_keyring:false} \
321         -Dlibmtp=%{?with_mtp:true}%{!?with_mtp:false} \
322         -Dman=%{?with_doc:true}%{!?with_doc:false} \
323         -Dnfs=%{?with_nfs:true}%{!?with_nfs:false} \
324         -Dsmb=%{?with_samba:true}%{!?with_samba:false} \
325         -Dlogind=%{?with_systemd:true}%{!?with_systemd:false} \
326         -Dudev=%{?with_udev:true}%{!?with_udev:false} \
327         -Dudisks2=%{?with_udisks2:true}%{!?with_udisks2:false}
328
329 %meson_build -C build
330
331 %install
332 rm -rf $RPM_BUILD_ROOT
333
334 install -d $RPM_BUILD_ROOT%{bash_compdir}
335 %meson_install -C build
336
337 %find_lang gvfs
338
339 %clean
340 rm -rf $RPM_BUILD_ROOT
341
342 # Reload .mount files
343 %define reload_mount_files killall -USR1 gvfsd >/dev/null 2>&1 || :;
344
345 %post
346 %glib_compile_schemas
347 umask 022
348 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
349 %reload_mount_files
350
351 %postun
352 if [ "$1" = "0" ]; then
353         %glib_compile_schemas
354 fi
355 umask 022
356 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
357 exit 0
358
359 # Reload .mount files when single subpackage is installed:
360 %post afc
361 %reload_mount_files
362
363 %post archive
364 %reload_mount_files
365
366 %post goa
367 %reload_mount_files
368
369 %post google
370 %reload_mount_files
371
372 %post gphoto2
373 %reload_mount_files
374
375 %post mtp
376 %reload_mount_files
377
378 %post smb
379 %glib_compile_schemas
380 %reload_mount_files
381
382 %postun smb
383 if [ "$1" = "0" ]; then
384         %glib_compile_schemas
385 fi
386
387 %files -f gvfs.lang
388 %defattr(644,root,root,755)
389 %doc CONTRIBUTING.md NEWS README.md
390 %attr(755,root,root) %{_libdir}/gio/modules/libgioremote-volume-monitor.so
391 %attr(755,root,root) %{_libdir}/gio/modules/libgvfsdbus.so
392 #%dir %{_libexecdir}  # equal %{_libdir}/%{name}, packaged in -libs
393 %attr(755,root,root) %{_libexecdir}/gvfsd
394 %attr(755,root,root) %{_libexecdir}/gvfsd-burn
395 %attr(755,root,root) %{_libexecdir}/gvfsd-computer
396 %attr(755,root,root) %{_libexecdir}/gvfsd-ftp
397 %attr(755,root,root) %{_libexecdir}/gvfsd-localtest
398 %attr(755,root,root) %{_libexecdir}/gvfsd-metadata
399 %attr(755,root,root) %{_libexecdir}/gvfsd-network
400 %attr(755,root,root) %{_libexecdir}/gvfsd-sftp
401 %attr(755,root,root) %{_libexecdir}/gvfsd-trash
402 %{_datadir}/dbus-1/services/org.gtk.vfs.Daemon.service
403 %{_datadir}/dbus-1/services/org.gtk.vfs.Metadata.service
404 %dir %{_datadir}/gvfs
405 %dir %{_datadir}/gvfs/mounts
406 %dir %{_datadir}/gvfs/remote-volume-monitors
407 %{_datadir}/gvfs/mounts/burn.mount
408 %{_datadir}/gvfs/mounts/computer.mount
409 %{_datadir}/gvfs/mounts/ftp.mount
410 %{_datadir}/gvfs/mounts/ftps.mount
411 %{_datadir}/gvfs/mounts/localtest.mount
412 %{_datadir}/gvfs/mounts/network.mount
413 %{_datadir}/gvfs/mounts/sftp.mount
414 %{_datadir}/gvfs/mounts/trash.mount
415 %{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
416 %{systemduserunitdir}/gvfs-daemon.service
417 %{systemduserunitdir}/gvfs-metadata.service
418
419 # admin
420 %if %{with admin}
421 %attr(755,root,root) %{_libexecdir}/gvfsd-admin
422 %{_datadir}/gvfs/mounts/admin.mount
423 %{_datadir}/polkit-1/actions/org.gtk.vfs.file-operations.policy
424 %{_datadir}/polkit-1/rules.d/org.gtk.vfs.file-operations.rules
425 %endif
426
427 # cdda
428 %if %{with cdda}
429 %attr(755,root,root) %{_libexecdir}/gvfsd-cdda
430 %{_datadir}/gvfs/mounts/cdda.mount
431 %endif
432
433 # http
434 %if %{with http}
435 %attr(755,root,root) %{_libexecdir}/gvfsd-dav
436 %attr(755,root,root) %{_libexecdir}/gvfsd-http
437 %{_datadir}/gvfs/mounts/http.mount
438 %{_datadir}/gvfs/mounts/dav.mount
439 %{?with_avahi:%{_datadir}/gvfs/mounts/dav+sd.mount}
440 %endif
441
442 # gtk
443 %if %{with gtk}
444 %attr(755,root,root) %{_libexecdir}/gvfsd-recent
445 %{_datadir}/gvfs/mounts/recent.mount
446 %endif
447
448 # nfs
449 %if %{with nfs}
450 %attr(755,root,root) %{_libexecdir}/gvfsd-nfs
451 %{_datadir}/gvfs/mounts/nfs.mount
452 %endif
453
454 # udisks2
455 %if %{with udisks2}
456 %attr(755,root,root) %{_libexecdir}/gvfs-udisks2-volume-monitor
457 %{_datadir}/dbus-1/services/org.gtk.vfs.UDisks2VolumeMonitor.service
458 %{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
459 %{systemduserunitdir}/gvfs-udisks2-volume-monitor.service
460 %endif
461
462 # avahi
463 %if %{with avahi}
464 %attr(755,root,root) %{_libexecdir}/gvfsd-dnssd
465 %{_datadir}/gvfs/mounts/dns-sd.mount
466 %{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
467 %{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
468 %endif
469
470 %if %{with doc}
471 %{_mandir}/man1/gvfsd.1*
472 %{_mandir}/man1/gvfsd-metadata.1*
473 %{_mandir}/man7/gvfs.7*
474 %endif
475
476 %files libs
477 %defattr(644,root,root,755)
478 %dir %{_libdir}/%{name}
479 %attr(755,root,root) %{_libdir}/%{name}/libgvfscommon.so
480 %attr(755,root,root) %{_libdir}/%{name}/libgvfsdaemon.so
481
482 %files devel
483 %defattr(644,root,root,755)
484 %{_includedir}/gvfs-client
485
486 %if %{with afc}
487 %files afc
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libexecdir}/gvfs-afc-volume-monitor
490 %attr(755,root,root) %{_libexecdir}/gvfsd-afc
491 %{_datadir}/dbus-1/services/org.gtk.vfs.AfcVolumeMonitor.service
492 %{_datadir}/gvfs/mounts/afc.mount
493 %{_datadir}/gvfs/mounts/ftpis.mount
494 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
495 %{systemduserunitdir}/gvfs-afc-volume-monitor.service
496 %endif
497
498 %if %{with afp}
499 %files afp
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{_libexecdir}/gvfsd-afp
502 %attr(755,root,root) %{_libexecdir}/gvfsd-afp-browse
503 %{_datadir}/gvfs/mounts/afp-browse.mount
504 %{_datadir}/gvfs/mounts/afp.mount
505 %endif
506
507 %if %{with archive}
508 %files archive
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libexecdir}/gvfsd-archive
511 %{_datadir}/gvfs/mounts/archive.mount
512 %endif
513
514 %if %{with fuse}
515 %files fuse
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libexecdir}/gvfsd-fuse
518 %if %{with doc}
519 %{_mandir}/man1/gvfsd-fuse.1*
520 %endif
521 %if %{with systemd}
522 # FIXME: reusing USE_LIBSYSTEMD_LOGIN as systemd has no universal header or pkg-config file
523 %{systemdtmpfilesdir}/gvfsd-fuse-tmpfiles.conf
524 %endif
525 %endif
526
527 %if %{with goa}
528 %files goa
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libexecdir}/gvfs-goa-volume-monitor
531 %{_datadir}/dbus-1/services/org.gtk.vfs.GoaVolumeMonitor.service
532 %{_datadir}/gvfs/remote-volume-monitors/goa.monitor
533 %{systemduserunitdir}/gvfs-goa-volume-monitor.service
534 %endif
535
536 %if %{with google}
537 %files google
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libexecdir}/gvfsd-google
540 %{_datadir}/gvfs/mounts/google.mount
541 %endif
542
543 %if %{with gphoto2}
544 %files gphoto2
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_libexecdir}/gvfs-gphoto2-volume-monitor
547 %attr(755,root,root) %{_libexecdir}/gvfsd-gphoto2
548 %{_datadir}/dbus-1/services/org.gtk.vfs.GPhoto2VolumeMonitor.service
549 %{_datadir}/gvfs/mounts/gphoto2.mount
550 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
551 %{systemduserunitdir}/gvfs-gphoto2-volume-monitor.service
552 %endif
553
554 %if %{with mtp}
555 %files mtp
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libexecdir}/gvfs-mtp-volume-monitor
558 %attr(755,root,root) %{_libexecdir}/gvfsd-mtp
559 %{_datadir}/dbus-1/services/org.gtk.vfs.MTPVolumeMonitor.service
560 %{_datadir}/gvfs/mounts/mtp.mount
561 %{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
562 %{systemduserunitdir}/gvfs-mtp-volume-monitor.service
563 %endif
564
565 %if %{with samba}
566 %files smb
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libexecdir}/gvfsd-smb
569 %attr(755,root,root) %{_libexecdir}/gvfsd-smb-browse
570 %{_datadir}/gvfs/mounts/smb-browse.mount
571 %{_datadir}/gvfs/mounts/smb.mount
572 %{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
573 %{_datadir}/GConf/gsettings/gvfs-smb.convert
574 %endif
This page took 0.090495 seconds and 2 git commands to generate.