]> git.pld-linux.org Git - packages/gupnp1.6.git/blob - gupnp1.6.spec
- gupnp updated to 1.6.3 as gupnp1.6 (libsoup3 based, parallel installable with libso...
[packages/gupnp1.6.git] / gupnp1.6.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # gi-docgen based API documentation
4 %bcond_without  vala    # Vala API
5
6 Summary:        UPnP library based on GObject and libsoup
7 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
8 Name:           gupnp1.6
9 # note: 1.6.x is stable, 1.7.x unstable
10 Version:        1.6.3
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/gupnp/1.6/gupnp-%{version}.tar.xz
15 # Source0-md5:  2ea0b9bd891e48893293b5915ee547c4
16 URL:            https://wiki.gnome.org/Projects/GUPnP
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  docbook-dtd44-xml
19 BuildRequires:  docbook-dtd45-xml
20 BuildRequires:  docbook-style-xsl
21 BuildRequires:  glib2-devel >= 1:2.70
22 BuildRequires:  gobject-introspection-devel >= 1.36.0
23 BuildRequires:  gssdp1.6-devel >= 1.6.2
24 %{?with_apidocs:BuildRequires:  gi-docgen >= 2021.1}
25 BuildRequires:  libsoup3-devel >= 3.0
26 BuildRequires:  libxml2-devel >= 1:2.6.30
27 BuildRequires:  libxslt-progs
28 BuildRequires:  meson >= 0.54.0
29 BuildRequires:  ninja >= 1.5
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.736
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  tar >= 1:1.22
36 %{?with_vala:BuildRequires:     vala >= 2:0.20}
37 %{?with_vala:BuildRequires:     vala-gssdp1.6 >= 1.6.2}
38 BuildRequires:  xz
39 Requires:       glib2 >= 1:2.70
40 Requires:       gssdp1.6 >= 1.6.2
41 Requires:       libsoup3 >= 3.0
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GUPnP is an object-oriented open source framework for creating UPnP
46 devices and control points, written in C using GObject and libsoup.
47 The GUPnP API is intended to be easy to use, efficient and flexible.
48
49 %description -l pl.UTF-8
50 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
51 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
52 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
53 i elastyczne.
54
55 %package devel
56 Summary:        Header files for gupnp
57 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       glib2-devel >= 1:2.70
61 Requires:       gssdp1.6-devel >= 1.6.2
62 Requires:       libsoup3-devel >= 3.0
63 Requires:       libxml2-devel >= 1:2.6.30
64
65 %description devel
66 This package contains header files for the Linux SDK for UPnP Devices
67 (gupnp).
68
69 %description devel -l pl.UTF-8
70 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
71 programistycznego do urządzeń UPnP (gupnp).
72
73 %package static
74 Summary:        Static gupnp libraries
75 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static gupnp libraries.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki gupnp.
84
85 %package apidocs
86 Summary:        gupnp API documentation
87 Summary(pl.UTF-8):      Dokumentacja API gupnp
88 Group:          Documentation
89 Requires:       gtk-doc-common
90 BuildArch:      noarch
91
92 %description apidocs
93 gupnp API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API gupnp.
97
98 %package -n vala-gupnp1.6
99 Summary:        Vala API for gupnp library
100 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       vala >= 2:0.20
104 Requires:       vala-gssdp1.6 >= 1.6.2
105 BuildArch:      noarch
106
107 %description -n vala-gupnp1.6
108 Vala API for gupnp library.
109
110 %description -n vala-gupnp1.6 -l pl.UTF-8
111 API języka Vala dla biblioteki gupnp.
112
113 %prep
114 %setup -q -n gupnp-%{version}
115
116 %build
117 %meson build \
118         -Dcontext_manager=network-manager \
119         %{?with_apidocs:-Dgtk_doc=true}
120
121 %ninja_build -C build
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %ninja_install -C build
127
128 %if %{with apidocs}
129 # FIXME: where to package gi-docgen generated docs?
130 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
131 %{__mv} $RPM_BUILD_ROOT%{_docdir}/gupnp-1.6 $RPM_BUILD_ROOT%{_gtkdocdir}
132 %endif
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS NEWS README.md
143 %attr(755,root,root) %{_bindir}/gupnp-binding-tool-1.6
144 %attr(755,root,root) %{_libdir}/libgupnp-1.6.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.6.so.0
146 %{_libdir}/girepository-1.0/GUPnP-1.6.typelib
147 %{_mandir}/man1/gupnp-binding-tool-1.6.1*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libgupnp-1.6.so
152 %{_datadir}/gir-1.0/GUPnP-1.6.gir
153 %{_includedir}/gupnp-1.6
154 %{_pkgconfigdir}/gupnp-1.6.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libgupnp-1.6.a
159
160 %if %{with apidocs}
161 %files apidocs
162 %defattr(644,root,root,755)
163 %{_gtkdocdir}/gupnp-1.6
164 %endif
165
166 %if %{with vala}
167 %files -n vala-gupnp1.6
168 %defattr(644,root,root,755)
169 %{_datadir}/vala/vapi/gupnp-1.6.deps
170 %{_datadir}/vala/vapi/gupnp-1.6.vapi
171 %endif
This page took 0.279537 seconds and 3 git commands to generate.