]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
cc2d3977602ae6c90f34591aa9b8908dede1b07b
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # gtk-doc based API documentation
4 %bcond_without  vala    # Vala API
5
6 Summary:        UPnP library based on GObject and libsoup
7 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
8 Name:           gupnp
9 # note: 1.4.x is stable, 1.5.x unstable
10 Version:        1.4.4
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/gupnp/1.4/%{name}-%{version}.tar.xz
15 # Source0-md5:  f73c965454a5a37c1b18ca8a11bebbbf
16 URL:            https://wiki.gnome.org/Projects/GUPnP
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  docbook-dtd44-xml
19 BuildRequires:  docbook-dtd45-xml
20 BuildRequires:  docbook-style-xsl
21 BuildRequires:  glib2-devel >= 1:2.66
22 BuildRequires:  gobject-introspection-devel >= 1.36.0
23 BuildRequires:  gssdp-devel >= 1.3.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
25 BuildRequires:  libsoup-devel >= 2.48.0
26 BuildRequires:  libuuid-devel >= 1.36
27 BuildRequires:  libxml2-devel >= 1:2.6.30
28 BuildRequires:  libxslt-progs
29 BuildRequires:  meson >= 0.54.0
30 BuildRequires:  ninja >= 1.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpm-build >= 4.6
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  tar >= 1:1.22
37 %{?with_vala:BuildRequires:     vala >= 2:0.20}
38 %{?with_vala:BuildRequires:     vala-gssdp >= 1.3.0}
39 BuildRequires:  xz
40 Requires:       glib2 >= 1:2.66
41 Requires:       gssdp >= 1.3.0
42 Requires:       libsoup >= 2.48.0
43 Requires:       libuuid >= 1.36
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 GUPnP is an object-oriented open source framework for creating UPnP
48 devices and control points, written in C using GObject and libsoup.
49 The GUPnP API is intended to be easy to use, efficient and flexible.
50
51 %description -l pl.UTF-8
52 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
53 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
54 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
55 i elastyczne.
56
57 %package devel
58 Summary:        Header files for gupnp
59 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       glib2-devel >= 1:2.66
63 Requires:       gssdp-devel >= 1.3.0
64 Requires:       libsoup-devel >= 2.48.0
65 Requires:       libuuid-devel >= 1.36
66 Requires:       libxml2-devel >= 1:2.6.30
67
68 %description devel
69 This package contains header files for the Linux SDK for UPnP Devices
70 (gupnp).
71
72 %description devel -l pl.UTF-8
73 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
74 programistycznego do urządzeń UPnP (gupnp).
75
76 %package static
77 Summary:        Static gupnp libraries
78 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static gupnp libraries.
84
85 %description static -l pl.UTF-8
86 Statyczne biblioteki gupnp.
87
88 %package apidocs
89 Summary:        gupnp API documentation
90 Summary(pl.UTF-8):      Dokumentacja API gupnp
91 Group:          Documentation
92 Requires:       gtk-doc-common
93 BuildArch:      noarch
94
95 %description apidocs
96 gupnp API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API gupnp.
100
101 %package -n vala-gupnp
102 Summary:        Vala API for gupnp library
103 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Requires:       vala >= 2:0.20
107 Requires:       vala-gssdp >= 1.3.0
108 BuildArch:      noarch
109
110 %description -n vala-gupnp
111 Vala API for gupnp library.
112
113 %description -n vala-gupnp -l pl.UTF-8
114 API języka Vala dla biblioteki gupnp.
115
116 %prep
117 %setup -q
118
119 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' tools/gupnp-binding-tool-1.2
120
121 %build
122 %meson build \
123         -Dcontext_manager=network-manager \
124         %{?with_apidocs:-Dgtk_doc=true}
125
126 %ninja_build -C build
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %ninja_install -C build
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS NEWS README.md
142 %attr(755,root,root) %{_bindir}/gupnp-binding-tool-1.2
143 %attr(755,root,root) %{_libdir}/libgupnp-1.2.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.2.so.1
145 %{_libdir}/girepository-1.0/GUPnP-1.2.typelib
146 %{_mandir}/man1/gupnp-binding-tool-1.2.1*
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libgupnp-1.2.so
151 %{_datadir}/gir-1.0/GUPnP-1.2.gir
152 %{_includedir}/gupnp-1.2
153 %{_pkgconfigdir}/gupnp-1.2.pc
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libgupnp-1.2.a
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_gtkdocdir}/gupnp
163 %endif
164
165 %if %{with vala}
166 %files -n vala-gupnp
167 %defattr(644,root,root,755)
168 %{_datadir}/vala/vapi/gupnp-1.2.deps
169 %{_datadir}/vala/vapi/gupnp-1.2.vapi
170 %endif
This page took 0.063054 seconds and 2 git commands to generate.