]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
- updated to 1.4.0
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # gtk-doc based API documentation
4 %bcond_without  vala    # Vala API
5
6 Summary:        UPnP library based on GObject and libsoup
7 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
8 Name:           gupnp
9 # note: 1.4.x is stable, 1.5.x unstable
10 Version:        1.4.0
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/gupnp/1.4/%{name}-%{version}.tar.xz
15 # Source0-md5:  91e9d1b925c084bcf6265b1391752275
16 URL:            https://wiki.gnome.org/Projects/GUPnP
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  docbook-dtd44-xml
19 BuildRequires:  glib2-devel >= 1:2.66
20 BuildRequires:  gobject-introspection-devel >= 1.36.0
21 BuildRequires:  gssdp-devel >= 1.3.0
22 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
23 BuildRequires:  libsoup-devel >= 2.48.0
24 BuildRequires:  libuuid-devel >= 1.36
25 BuildRequires:  libxml2-devel >= 1:2.6.30
26 BuildRequires:  meson >= 0.54.0
27 BuildRequires:  ninja >= 1.5
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-build >= 4.6
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.736
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  tar >= 1:1.22
34 %{?with_vala:BuildRequires:     vala >= 2:0.20}
35 %{?with_vala:BuildRequires:     vala-gssdp >= 1.3.0}
36 BuildRequires:  xz
37 Requires:       glib2 >= 1:2.66
38 Requires:       gssdp >= 1.3.0
39 Requires:       libsoup >= 2.48.0
40 Requires:       libuuid >= 1.36
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GUPnP is an object-oriented open source framework for creating UPnP
45 devices and control points, written in C using GObject and libsoup.
46 The GUPnP API is intended to be easy to use, efficient and flexible.
47
48 %description -l pl.UTF-8
49 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
50 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
51 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
52 i elastyczne.
53
54 %package devel
55 Summary:        Header files for gupnp
56 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.66
60 Requires:       gssdp-devel >= 1.3.0
61 Requires:       libsoup-devel >= 2.48.0
62 Requires:       libuuid-devel >= 1.36
63 Requires:       libxml2-devel >= 1:2.6.30
64
65 %description devel
66 This package contains header files for the Linux SDK for UPnP Devices
67 (gupnp).
68
69 %description devel -l pl.UTF-8
70 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
71 programistycznego do urządzeń UPnP (gupnp).
72
73 %package static
74 Summary:        Static gupnp libraries
75 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static gupnp libraries.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki gupnp.
84
85 %package apidocs
86 Summary:        gupnp API documentation
87 Summary(pl.UTF-8):      Dokumentacja API gupnp
88 Group:          Documentation
89 Requires:       gtk-doc-common
90 BuildArch:      noarch
91
92 %description apidocs
93 gupnp API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API gupnp.
97
98 %package -n vala-gupnp
99 Summary:        Vala API for gupnp library
100 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       vala >= 2:0.20
104 Requires:       vala-gssdp >= 1.3.0
105 BuildArch:      noarch
106
107 %description -n vala-gupnp
108 Vala API for gupnp library.
109
110 %description -n vala-gupnp -l pl.UTF-8
111 API języka Vala dla biblioteki gupnp.
112
113 %prep
114 %setup -q
115
116 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' tools/gupnp-binding-tool-1.2
117
118 %build
119 %meson build \
120         -Dcontext_manager=network-manager \
121         %{?with_apidocs:-Dgtk_doc=true}
122
123 %ninja_build -C build
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %ninja_install -C build
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README.md
139 %attr(755,root,root) %{_bindir}/gupnp-binding-tool-1.2
140 %attr(755,root,root) %{_libdir}/libgupnp-1.2.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.2.so.1
142 %{_libdir}/girepository-1.0/GUPnP-1.2.typelib
143 %{_mandir}/man1/gupnp-binding-tool-1.2.1*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libgupnp-1.2.so
148 %{_datadir}/gir-1.0/GUPnP-1.2.gir
149 %{_includedir}/gupnp-1.2
150 %{_pkgconfigdir}/gupnp-1.2.pc
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libgupnp-1.2.a
155
156 %if %{with apidocs}
157 %files apidocs
158 %defattr(644,root,root,755)
159 %{_gtkdocdir}/gupnp
160 %endif
161
162 %if %{with vala}
163 %files -n vala-gupnp
164 %defattr(644,root,root,755)
165 %{_datadir}/vala/vapi/gupnp-1.2.deps
166 %{_datadir}/vala/vapi/gupnp-1.2.vapi
167 %endif
This page took 0.095035 seconds and 3 git commands to generate.