]> git.pld-linux.org Git - packages/gupnp-igd.git/blob - gupnp-igd.spec
cfb0c65ae9d8556414b9127a1f55ca82d22008f6
[packages/gupnp-igd.git] / gupnp-igd.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4
5 Summary:        Library to handle UPnP IGD port mapping
6 Summary(pl.UTF-8):      Biblioteka do obsługi odwzorowywania portów IGD dla UPnP
7 Name:           gupnp-igd
8 Version:        0.2.5
9 Release:        2
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-igd/0.2/%{name}-%{version}.tar.xz
13 # Source0-md5:  d164e096d0f140bb1f5d9503727b424a
14 Patch0:         %{name}-gupnp.patch
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.53
17 BuildRequires:  automake
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  glib2-devel >= 1:2.26
20 BuildRequires:  gobject-introspection-devel >= 0.10
21 BuildRequires:  gssdp-devel >= 1.0
22 BuildRequires:  gtk-doc >= 1.10
23 BuildRequires:  gupnp-devel >= 0.18.0
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 %{?with_python:BuildRequires:   python-pygobject-devel >= 2.16.0}
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.219
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       glib2 >= 1:2.26
32 Requires:       gupnp >= 0.18.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Library to handle UPnP Internet Gateway Device port mappings.
37
38 %description -l pl.UTF-8
39 Biblioteka do obsługi odwzorowywania portów IGD (Internet Gateway
40 Device - bramek internetowych) dla UPnP.
41
42 %package devel
43 Summary:        Header files for gupnp-igd library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-igd
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 1:2.26
48 Requires:       gupnp-devel >= 0.18.0
49
50 %description devel
51 Header files for gupnp-igd library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki gupnp-igd.
55
56 %package static
57 Summary:        Static gupnp-igd library
58 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-igd
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static gupnp-igd library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka gupnp-igd.
67
68 %package apidocs
69 Summary:        gupnp-igd library API documentation
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-igd
71 Group:          Documentation
72 Requires:       gtk-doc-common
73 %if "%{_rpmversion}" >= "5"
74 BuildArch:      noarch
75 %endif
76
77 %description apidocs
78 gupnp-igd library API documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki gupnp-igd.
82
83 %package -n python-gupnp-igd
84 Summary:        gupnp-igd Python bindings
85 Summary(pl.UTF-8):      Wiązania Pythona do gupnp-igd
86 Group:          Development/Languages/Python
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       python-pygobject >= 2.16.0
89
90 %description -n python-gupnp-igd
91 gupnp-igd Python bindings.
92
93 %description -n python-gupnp-igd -l pl.UTF-8
94 Wiązania Pythona do gupnp-igd.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %build
101 %{__gtkdocize}
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         --enable-gtk-doc \
110         %{?with_python:--enable-python} \
111         --with-html-dir=%{_gtkdocdir}
112
113 # there are some races with gir generation
114 %{__make} -j1
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %if %{with python}
123 %py_postclean
124 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gupnp/*.{a,la}
125 %endif
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-igd-1.0.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog NEWS README TODO
139 %attr(755,root,root) %{_libdir}/libgupnp-igd-1.0.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libgupnp-igd-1.0.so.4
141 %{_libdir}/girepository-1.0/GUPnPIgd-1.0.typelib
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libgupnp-igd-1.0.so
146 %{_includedir}/gupnp-igd-1.0
147 %{_pkgconfigdir}/gupnp-igd-1.0.pc
148 %{_datadir}/gir-1.0/GUPnPIgd-1.0.gir
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libgupnp-igd-1.0.a
153
154 %files apidocs
155 %defattr(644,root,root,755)
156 %{_gtkdocdir}/gupnp-igd
157
158 %if %{with python}
159 %files -n python-gupnp-igd
160 %defattr(644,root,root,755)
161 %dir %{py_sitedir}/gupnp
162 %attr(755,root,root) %{py_sitedir}/gupnp/igd.so
163 %{py_sitedir}/gupnp/*.py[co]
164 %endif
This page took 0.09163 seconds and 2 git commands to generate.