]> git.pld-linux.org Git - packages/gupnp-igd.git/blob - gupnp-igd.spec
- updated to 0.2.4
[packages/gupnp-igd.git] / gupnp-igd.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4
5 Summary:        Library to handle UPnP IGD port mapping
6 Summary(pl.UTF-8):      Biblioteka do obsługi odwzorowywania portów IGD dla UPnP
7 Name:           gupnp-igd
8 Version:        0.2.4
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-igd/0.2/%{name}-%{version}.tar.xz
13 # Source0-md5:  124371136b5a7b1056a3681780a62772
14 URL:            http://gupnp.org/
15 BuildRequires:  autoconf >= 2.53
16 BuildRequires:  automake
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  glib2-devel >= 1:2.26
19 BuildRequires:  gobject-introspection-devel >= 0.10
20 BuildRequires:  gssdp-devel
21 BuildRequires:  gtk-doc >= 1.0
22 BuildRequires:  gupnp-devel >= 0.18.0
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig
25 %{?with_python:BuildRequires:   python-pygobject-devel >= 2.16.0}
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.219
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       glib2 >= 1:2.26
31 Requires:       gupnp >= 0.18.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Library to handle UPnP Internet Gateway Device port mappings.
36
37 %description -l pl.UTF-8
38 Biblioteka do obsługi odwzorowywania portów IGD (Internet Gateway
39 Device - bramek internetowych) dla UPnP.
40
41 %package devel
42 Summary:        Header files for gupnp-igd library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-igd
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.26
47 Requires:       gupnp-devel >= 0.18.0
48
49 %description devel
50 Header files for gupnp-igd library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki gupnp-igd.
54
55 %package static
56 Summary:        Static gupnp-igd library
57 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-igd
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static gupnp-igd library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka gupnp-igd.
66
67 %package apidocs
68 Summary:        gupnp-igd library API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-igd
70 Group:          Documentation
71 Requires:       gtk-doc-common
72 %if "%{_rpmversion}" >= "5"
73 BuildArch:      noarch
74 %endif
75
76 %description apidocs
77 gupnp-igd library API documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API biblioteki gupnp-igd.
81
82 %package -n python-gupnp-igd
83 Summary:        gupnp-igd Python bindings
84 Summary(pl.UTF-8):      Wiązania Pythona do gupnp-igd
85 Group:          Development/Languages/Python
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       python-pygobject >= 2.16.0
88
89 %description -n python-gupnp-igd
90 gupnp-igd Python bindings.
91
92 %description -n python-gupnp-igd -l pl.UTF-8
93 Wiązania Pythona do gupnp-igd.
94
95 %prep
96 %setup -q
97
98 %build
99 %{__gtkdocize}
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --disable-silent-rules \
107         --enable-gtk-doc \
108         %{?with_python:--enable-python} \
109         --with-html-dir=%{_gtkdocdir}
110
111 # there are some races with gir generation
112 %{__make} -j1
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %if %{with python}
120 %py_postclean
121 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gupnp/*.{a,la}
122 %endif
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-igd-1.0.la
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README TODO
136 %attr(755,root,root) %{_libdir}/libgupnp-igd-1.0.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libgupnp-igd-1.0.so.4
138 %{_libdir}/girepository-1.0/GUPnPIgd-1.0.typelib
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgupnp-igd-1.0.so
143 %{_includedir}/gupnp-igd-1.0
144 %{_pkgconfigdir}/gupnp-igd-1.0.pc
145 %{_datadir}/gir-1.0/GUPnPIgd-1.0.gir
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgupnp-igd-1.0.a
150
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/gupnp-igd
154
155 %if %{with python}
156 %files -n python-gupnp-igd
157 %defattr(644,root,root,755)
158 %dir %{py_sitedir}/gupnp
159 %attr(755,root,root) %{py_sitedir}/gupnp/igd.so
160 %{py_sitedir}/gupnp/*.py[co]
161 %endif
This page took 0.087415 seconds and 3 git commands to generate.