]> git.pld-linux.org Git - packages/gupnp-av.git/blob - gupnp-av.spec
c5a70b028efb241ece41a7b1caeec2e1c08a3d17
[packages/gupnp-av.git] / gupnp-av.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5
6 Summary:        Library for building UPnP A/V applications
7 Summary(pl.UTF-8):      Biblioteka do budowania aplikacji UPnP A/V
8 Name:           gupnp-av
9 # note: 0.12.x is stable, 0.13.x unstable
10 Version:        0.12.11
11 Release:        2
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-av/0.12/%{name}-%{version}.tar.xz
15 # Source0-md5:  f09e99ae20271b0a8cadce806098ae8b
16 Patch0:         %{name}-pc.patch
17 URL:            http://gupnp.org/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  glib2-devel >= 1:2.38
22 BuildRequires:  gobject-introspection-devel >= 1.36.0
23 BuildRequires:  gtk-doc >= 1.10
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 %{?with_vala:BuildRequires:     vala >= 2:0.22}
29 BuildRequires:  xz
30 Requires:       glib2 >= 1:2.38
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 gupnp-av is a small library that aims to easy the handling and
35 implementation of UPnP A/V profiles.
36
37 %description -l pl.UTF-8
38 gupnp-av jest małą biblioteką, której celem jest uproszczenie obsługi
39 i implementacji profili UPnP A/V.
40
41 %package devel
42 Summary:        Header files for gupnp-av library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-av
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.38
47 Requires:       libxml2-devel >= 2.0
48
49 %description devel
50 Header files for gupnp-av library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki gupnp-av.
54
55 %package static
56 Summary:        Static gupnp-av library
57 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-av
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static gupnp-av library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka gupnp-av.
66
67 %package apidocs
68 Summary:        gupnp-av library API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-av
70 Group:          Documentation
71 Requires:       gtk-doc-common
72 BuildArch:      noarch
73
74 %description apidocs
75 API and internal documentation for gupnp-av library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki gupnp-av.
79
80 %package -n vala-gupnp-av
81 Summary:        Vala API for gupnp-av library
82 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp-av
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Requires:       vala >= 2:0.22
86 BuildArch:      noarch
87
88 %description -n vala-gupnp-av
89 Vala API for gupnp-av library.
90
91 %description -n vala-gupnp-av -l pl.UTF-8
92 API języka Vala dla biblioteki gupnp-av.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__gtkdocize}
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --disable-silent-rules \
107         %{?with_apidocs:--enable-gtk-doc} \
108         --with-html-dir=%{_gtkdocdir}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 # obsoleted by pkg-config
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-av-1.0.la
120
121 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README
132 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgupnp-av-1.0.so.2
134 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
135 %{_datadir}/gupnp-av
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so
140 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
141 %{_includedir}/gupnp-av-1.0
142 %{_pkgconfigdir}/gupnp-av-1.0.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgupnp-av-1.0.a
147
148 %if %{with apidocs}
149 %files apidocs
150 %defattr(644,root,root,755)
151 %{_gtkdocdir}/gupnp-av
152 %endif
153
154 %if %{with vala}
155 %files -n vala-gupnp-av
156 %defattr(644,root,root,755)
157 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
158 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
159 %endif
This page took 0.056563 seconds and 2 git commands to generate.