]> git.pld-linux.org Git - packages/gupnp-av.git/blob - gupnp-av.spec
- updated to 0.12.11
[packages/gupnp-av.git] / gupnp-av.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5
6 Summary:        Library for building UPnP A/V applications
7 Summary(pl.UTF-8):      Biblioteka do budowania aplikacji UPnP A/V
8 Name:           gupnp-av
9 # note: 0.12.x is stable, 0.13.x unstable
10 Version:        0.12.11
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-av/0.12/%{name}-%{version}.tar.xz
15 # Source0-md5:  f09e99ae20271b0a8cadce806098ae8b
16 URL:            http://gupnp.org/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  glib2-devel >= 1:2.38
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gtk-doc >= 1.10
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  libxml2-devel >= 2.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 2:0.22}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.38
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 gupnp-av is a small library that aims to easy the handling and
34 implementation of UPnP A/V profiles.
35
36 %description -l pl.UTF-8
37 gupnp-av jest małą biblioteką, której celem jest uproszczenie obsługi
38 i implementacji profili UPnP A/V.
39
40 %package devel
41 Summary:        Header files for gupnp-av library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-av
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       glib2-devel >= 1:2.38
46 Requires:       libxml2-devel >= 2.0
47
48 %description devel
49 Header files for gupnp-av library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki gupnp-av.
53
54 %package static
55 Summary:        Static gupnp-av library
56 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-av
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static gupnp-av library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka gupnp-av.
65
66 %package apidocs
67 Summary:        gupnp-av library API documentation
68 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-av
69 Group:          Documentation
70 Requires:       gtk-doc-common
71 %if "%{_rpmversion}" >= "5"
72 BuildArch:      noarch
73 %endif
74
75 %description apidocs
76 API and internal documentation for gupnp-av library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki gupnp-av.
80
81 %package -n vala-gupnp-av
82 Summary:        Vala API for gupnp-av library
83 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp-av
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala >= 2:0.22
87 %if "%{_rpmversion}" >= "5"
88 BuildArch:      noarch
89 %endif
90
91 %description -n vala-gupnp-av
92 Vala API for gupnp-av library.
93
94 %description -n vala-gupnp-av -l pl.UTF-8
95 API języka Vala dla biblioteki gupnp-av.
96
97 %prep
98 %setup -q
99
100 %build
101 %{__gtkdocize}
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         %{?with_apidocs:--enable-gtk-doc} \
110         --with-html-dir=%{_gtkdocdir}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-av-1.0.la
122
123 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README
134 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgupnp-av-1.0.so.2
136 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
137 %{_datadir}/gupnp-av
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so
142 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
143 %{_includedir}/gupnp-av-1.0
144 %{_pkgconfigdir}/gupnp-av-1.0.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgupnp-av-1.0.a
149
150 %if %{with apidocs}
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/gupnp-av
154 %endif
155
156 %if %{with vala}
157 %files -n vala-gupnp-av
158 %defattr(644,root,root,755)
159 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
160 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
161 %endif
This page took 0.073664 seconds and 3 git commands to generate.