]> git.pld-linux.org Git - packages/gupnp-av.git/blob - gupnp-av.spec
8fb0ed7a3d412858d8e1100cdd73b2094b2eee9e
[packages/gupnp-av.git] / gupnp-av.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5
6 Summary:        Library for building UPnP A/V applications
7 Summary(pl.UTF-8):      Biblioteka do budowania aplikacji UPnP A/V
8 Name:           gupnp-av
9 # note: 0.12.x is stable, 0.13.x unstable
10 Version:        0.12.10
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-av/0.12/%{name}-%{version}.tar.xz
15 # Source0-md5:  215f626508d76b767f5da7c9b92e87d8
16 URL:            http://gupnp.org/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  glib2-devel >= 1:2.34
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gtk-doc >= 1.10
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  libxml2-devel >= 2.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 2:0.22}
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 gupnp-av is a small library that aims to easy the handling and
33 implementation of UPnP A/V profiles.
34
35 %description -l pl.UTF-8
36 gupnp-av jest małą biblioteką, której celem jest uproszczenie obsługi
37 i implementacji profili UPnP A/V.
38
39 %package devel
40 Summary:        Header files for gupnp-av library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-av
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       glib2-devel >= 1:2.34
45 Requires:       libxml2-devel >= 2.0
46
47 %description devel
48 Header files for gupnp-av library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki gupnp-av.
52
53 %package static
54 Summary:        Static gupnp-av library
55 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-av
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static gupnp-av library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka gupnp-av.
64
65 %package apidocs
66 Summary:        gupnp-av library API documentation
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-av
68 Group:          Documentation
69 Requires:       gtk-doc-common
70 %if "%{_rpmversion}" >= "5"
71 BuildArch:      noarch
72 %endif
73
74 %description apidocs
75 API and internal documentation for gupnp-av library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki gupnp-av.
79
80 %package -n vala-gupnp-av
81 Summary:        Vala API for gupnp-av library
82 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp-av
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Requires:       vala >= 2:0.22
86 %if "%{_rpmversion}" >= "5"
87 BuildArch:      noarch
88 %endif
89
90 %description -n vala-gupnp-av
91 Vala API for gupnp-av library.
92
93 %description -n vala-gupnp-av -l pl.UTF-8
94 API języka Vala dla biblioteki gupnp-av.
95
96 %prep
97 %setup -q
98
99 %build
100 %{__gtkdocize}
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         --disable-silent-rules \
108         %{?with_apidocs:--enable-gtk-doc} \
109         --with-html-dir=%{_gtkdocdir}
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 # obsoleted by pkg-config
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-av-1.0.la
121
122 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README
133 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libgupnp-av-1.0.so.2
135 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
136 %{_datadir}/gupnp-av
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so
141 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
142 %{_includedir}/gupnp-av-1.0
143 %{_pkgconfigdir}/gupnp-av-1.0.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libgupnp-av-1.0.a
148
149 %if %{with apidocs}
150 %files apidocs
151 %defattr(644,root,root,755)
152 %{_gtkdocdir}/gupnp-av
153 %endif
154
155 %if %{with vala}
156 %files -n vala-gupnp-av
157 %defattr(644,root,root,755)
158 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
159 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
160 %endif
This page took 0.067069 seconds and 2 git commands to generate.