]> git.pld-linux.org Git - packages/gupnp-av.git/blob - gupnp-av.spec
75cc6b4cf7832e59c1d24862a0f090659236da32
[packages/gupnp-av.git] / gupnp-av.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5
6 Summary:        Library for building UPnP A/V applications
7 Summary(pl.UTF-8):      Biblioteka do budowania aplikacji UPnP A/V
8 Name:           gupnp-av
9 # note: 0.12.x is stable, 0.13.x unstable
10 Version:        0.12.8
11 Release:        2
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-av/0.12/%{name}-%{version}.tar.xz
15 # Source0-md5:  f6b04a99caea21fe969512bf2b5b8321
16 URL:            http://gupnp.org/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  glib2-devel >= 2.0
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gtk-doc >= 1.10
23 BuildRequires:  gupnp-devel >= 0.19.0
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 %{?with_vala:BuildRequires:     vala >= 2:0.22}
29 %{?with_vala:BuildRequires:     vala-gupnp >= 0.19.0}
30 BuildRequires:  xz
31 Requires:       gupnp >= 0.19.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 gupnp-av is a small library that aims to easy the handling and
36 implementation of UPnP A/V profiles.
37
38 %description -l pl.UTF-8
39 gupnp-av jest małą biblioteką, której celem jest uproszczenie obsługi
40 i implementacji profili UPnP A/V.
41
42 %package devel
43 Summary:        Header files for gupnp-av library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-av
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 2.0
48 Requires:       gupnp-devel >= 0.19.0
49 Requires:       libxml2-devel >= 2.0
50
51 %description devel
52 Header files for gupnp-av library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki gupnp-av.
56
57 %package static
58 Summary:        Static gupnp-av library
59 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-av
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static gupnp-av library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka gupnp-av.
68
69 %package apidocs
70 Summary:        gupnp-av library API documentation
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-av
72 Group:          Documentation
73 Requires:       gtk-doc-common
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API and internal documentation for gupnp-av library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki gupnp-av.
83
84 %package -n vala-gupnp-av
85 Summary:        Vala API for gupnp-av library
86 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp-av
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.22
90 Requires:       vala-gupnp >= 0.19.0
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description -n vala-gupnp-av
96 Vala API for gupnp-av library.
97
98 %description -n vala-gupnp-av -l pl.UTF-8
99 API języka Vala dla biblioteki gupnp-av.
100
101 %prep
102 %setup -q
103
104 %build
105 %{__gtkdocize}
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --disable-silent-rules \
113         %{?with_apidocs:--enable-gtk-doc} \
114         --with-html-dir=%{_gtkdocdir}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-av-1.0.la
126
127 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README
138 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libgupnp-av-1.0.so.2
140 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
141 %{_datadir}/gupnp-av
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so
146 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
147 %{_includedir}/gupnp-av-1.0
148 %{_pkgconfigdir}/gupnp-av-1.0.pc
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libgupnp-av-1.0.a
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %{_gtkdocdir}/gupnp-av
158 %endif
159
160 %if %{with vala}
161 %files -n vala-gupnp-av
162 %defattr(644,root,root,755)
163 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
164 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
165 %endif
This page took 0.07891 seconds and 2 git commands to generate.