]> git.pld-linux.org Git - packages/gupnp-av.git/blob - gupnp-av.spec
- updated to 0.12.3
[packages/gupnp-av.git] / gupnp-av.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5 #
6 Summary:        Library for building UPnP A/V applications
7 Summary(pl.UTF-8):      Biblioteka do budowania aplikacji UPnP A/V
8 Name:           gupnp-av
9 # note: 0.12.x is stable, 0.13.x unstable
10 Version:        0.12.3
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp-av/0.12/%{name}-%{version}.tar.xz
15 # Source0-md5:  56f15dc57edd9d5d55990492726b7f49
16 URL:            http://gupnp.org/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  glib2-devel >= 2.0
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gtk-doc >= 1.10
23 BuildRequires:  gupnp-devel >= 0.19.0
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 %{?with_vala:BuildRequires:     vala >= 2:0.20}
29 %{?with_vala:BuildRequires:     vala-gupnp >= 0.19.0}
30 BuildRequires:  xz
31 Requires:       gupnp >= 0.19.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 gupnp-av is a small library that aims to easy the handling and
36 implementation of UPnP A/V profiles.
37
38 %description -l pl.UTF-8
39 gupnp-av jest małą biblioteką, której celem jest uproszczenie obsługi
40 i implementacji profili UPnP A/V.
41
42 %package devel
43 Summary:        Header files for gupnp-av library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-av
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 2.0
48 Requires:       gupnp-devel >= 0.19.0
49 Requires:       libxml2-devel >= 2.0
50
51 %description devel
52 Header files for gupnp-av library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki gupnp-av.
56
57 %package static
58 Summary:        Static gupnp-av library
59 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-av
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static gupnp-av library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka gupnp-av.
68
69 %package apidocs
70 Summary:        gupnp-av library API documentation
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-av
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 API and internal documentation for gupnp-av library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki gupnp-av.
80
81 %package -n vala-gupnp-av
82 Summary:        Vala API for gupnp-av library
83 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp-av
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala >= 2:0.20
87 Requires:       vala-gupnp >= 0.19.0
88
89 %description -n vala-gupnp-av
90 Vala API for gupnp-av library.
91
92 %description -n vala-gupnp-av -l pl.UTF-8
93 API języka Vala dla biblioteki gupnp-av.
94
95 %prep
96 %setup -q
97
98 %build
99 %{__gtkdocize}
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --disable-silent-rules \
107         %{?with_apidocs:--enable-gtk-doc} \
108         --with-html-dir=%{_gtkdocdir}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 # obsoleted by pkg-config
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgupnp-av-1.0.la
120
121 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README
132 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgupnp-av-1.0.so.2
134 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
135 %{_datadir}/gupnp-av
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so
140 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
141 %{_includedir}/gupnp-av-1.0
142 %{_pkgconfigdir}/gupnp-av-1.0.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgupnp-av-1.0.a
147
148 %if %{with apidocs}
149 %files apidocs
150 %defattr(644,root,root,755)
151 %{_gtkdocdir}/gupnp-av
152 %endif
153
154 %if %{with vala}
155 %files -n vala-gupnp-av
156 %defattr(644,root,root,755)
157 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
158 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
159 %endif
This page took 0.09885 seconds and 3 git commands to generate.