]> git.pld-linux.org Git - packages/gupnp-av.git/blob - gupnp-av.spec
- updated to 0.14.0 (new soname)
[packages/gupnp-av.git] / gupnp-av.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5
6 Summary:        Library for building UPnP A/V applications
7 Summary(pl.UTF-8):      Biblioteka do budowania aplikacji UPnP A/V
8 Name:           gupnp-av
9 # note: 0.14.x is stable, 0.15.x unstable
10 Version:        0.14.0
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/gupnp-av/0.14/%{name}-%{version}.tar.xz
15 # Source0-md5:  50bea03f3f19f5b6d5e3445ca83661d7
16 URL:            https://wiki.gnome.org/Projects/GUPnP
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  glib2-devel >= 1:2.58
19 BuildRequires:  gobject-introspection-devel >= 1.36.0
20 BuildRequires:  gtk-doc >= 1.10
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  meson
23 BuildRequires:  ninja >= 1.5
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpm-build >= 4.6
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 2:0.22}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.58
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 gupnp-av is a small library that aims to easy the handling and
34 implementation of UPnP A/V profiles.
35
36 %description -l pl.UTF-8
37 gupnp-av jest małą biblioteką, której celem jest uproszczenie obsługi
38 i implementacji profili UPnP A/V.
39
40 %package devel
41 Summary:        Header files for gupnp-av library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gupnp-av
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       glib2-devel >= 1:2.58
46 Requires:       libxml2-devel >= 2.0
47
48 %description devel
49 Header files for gupnp-av library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki gupnp-av.
53
54 %package static
55 Summary:        Static gupnp-av library
56 Summary(pl.UTF-8):      Statyczna biblioteka gupnp-av
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static gupnp-av library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka gupnp-av.
65
66 %package apidocs
67 Summary:        gupnp-av library API documentation
68 Summary(pl.UTF-8):      Dokumentacja API biblioteki gupnp-av
69 Group:          Documentation
70 Requires:       gtk-doc-common
71 BuildArch:      noarch
72
73 %description apidocs
74 API and internal documentation for gupnp-av library.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API biblioteki gupnp-av.
78
79 %package -n vala-gupnp-av
80 Summary:        Vala API for gupnp-av library
81 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp-av
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84 Requires:       vala >= 2:0.22
85 BuildArch:      noarch
86
87 %description -n vala-gupnp-av
88 Vala API for gupnp-av library.
89
90 %description -n vala-gupnp-av -l pl.UTF-8
91 API języka Vala dla biblioteki gupnp-av.
92
93 %prep
94 %setup -q
95
96 %build
97 %meson build \
98         %{?with_apidocs:-Dgtk_doc=true} \
99         %{!?with_vala:-Dvapi=false}
100
101 %ninja_build -C build
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %ninja_install -C build
107
108 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS NEWS README.md
119 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libgupnp-av-1.0.so.3
121 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
122 %{_datadir}/gupnp-av
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libgupnp-av-1.0.so
127 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
128 %{_includedir}/gupnp-av-1.0
129 %{_pkgconfigdir}/gupnp-av-1.0.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libgupnp-av-1.0.a
134
135 %if %{with apidocs}
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_gtkdocdir}/gupnp-av
139 %endif
140
141 %if %{with vala}
142 %files -n vala-gupnp-av
143 %defattr(644,root,root,755)
144 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
145 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
146 %endif
This page took 0.068564 seconds and 3 git commands to generate.