]> git.pld-linux.org Git - packages/gumbo-parser.git/blob - gumbo-parser.spec
b668968b085600c5d56d0d49d5212fc80c56a3b9
[packages/gumbo-parser.git] / gumbo-parser.spec
1 Summary:        Google's HTML5 parser library for C99
2 Name:           gumbo-parser
3 Version:        0.10.1
4 Release:        1
5 Epoch:          1
6 License:        Apache v2.0
7 Group:          Development/Libraries
8 Source0:        https://github.com/google/gumbo-parser/archive/v%{version}.tar.gz
9 # Source0-md5:  c6f75c9eda65e897c242f8958a34aed0
10 URL:            http://github.com/google/gumbo-parser
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  libtool
15 BuildRequires:  pkgconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Gumbo is an implementation of the HTML5 parsing algorithm implemented
20 as a C99 library. It is fully conformant with the HTML5 specification,
21 robust and resilient to bad input, supports source locations and
22 pointers back to the original text.
23
24 %package devel
25 Summary:        Development files for Google's C99 HTML5 parser
26 Group:          Development/Libraries
27 Requires:       %{name} = %{epoch}:%{version}-%{release}
28
29 %description devel
30 Gumbo is an implementation of the HTML5 parsing algorithm implemented
31 as a C99 library. It is fully conformant with the HTML5 specification,
32 robust and resilient to bad input, supports source locations and
33 pointers back to the original text.
34
35 This subpackage contains libraries and header files for developing
36 applications that want to make use of gumbo-parser.
37
38 %prep
39 %setup -q
40
41 %build
42 %{__libtoolize}
43 %{__aclocal}
44 %{__autoconf}
45 %{__automake}
46 %configure \
47         --disable-silent-rules \
48         --disable-static
49
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgumbo.la
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post   -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(644,root,root,755)
67 %attr(755,root,root) %{_libdir}/libgumbo.so.*.*.*
68 %ghost %{_libdir}/libgumbo.so.1
69
70 %files devel
71 %defattr(644,root,root,755)
72 %{_includedir}/gumbo.h
73 %{_includedir}/tag_enum.h
74 %attr(755,root,root) %{_libdir}/libgumbo.so
75 %{_pkgconfigdir}/gumbo.pc
This page took 0.063472 seconds and 2 git commands to generate.