]> git.pld-linux.org Git - packages/guichan.git/blob - guichan.spec
- split allegro/opengl/sdl interface libraries; release 4
[packages/guichan.git] / guichan.spec
1 #
2 # Conditional build:
3 %bcond_without  allegro     # allegro support
4 #
5 Summary:        Guichan - small, efficient C++ GUI library designed for games
6 Summary(pl.UTF-8):      Guichan - mała, wydajna biblioteka GUI w C++ przeznaczona do gier
7 Name:           guichan
8 Version:        0.8.2
9 Release:        4
10 License:        BSD
11 Group:          Libraries
12 # NOTE: now sources available at https://gitorious.org/guichan/mainline
13 Source0:        http://guichan.googlecode.com/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  af535d7f387e774e3197cef8023ea105
15 Patch0:         link.patch
16 URL:            http://guichan.sourceforge.net/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  SDL-devel
19 BuildRequires:  SDL_image-devel
20 %{?with_allegro:BuildRequires:      allegro-devel}
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1.4
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Guichan is a small, efficient C++ GUI library designed for games. It
30 comes with a standard set of widgets and can use several different
31 objects for displaying graphics and grabbing user input.
32
33 %description -l pl.UTF-8
34 Guichan to mała, wydajna biblioteka GUI w C++ przeznaczona do gier.
35 Zawiera standardowy zestaw widgetów, może używać kilku różnych
36 obiektów do wyświetlania grafiki i pobierania wejścia od użytkownika.
37
38 %package devel
39 Summary:        Header files for Guichan library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libstdc++-devel
44
45 %description devel
46 Header files for Guichan library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki Guichan.
50
51 %package static
52 Summary:        Static version of Guichan library
53 Summary(pl.UTF-8):      Statyczna wersja biblioteki Guichan
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static version of Guichan library.
59
60 %description static -l pl.UTF-8
61 Statyczna wersja biblioteki Guichan.
62
63 %package allegro
64 Summary:        Guichan Allegro interface library
65 Summary(pl.UTF-8):      Biblioteka interfejsu Guichan do Allegro
66 Group:          Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description allegro
70 Guichan Allegro interface library.
71
72 %description allegro -l pl.UTF-8
73 Biblioteka interfejsu Guichan do Allegro.
74
75 %package allegro-devel
76 Summary:        Header files for Guichan Allegro library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan Allegro
78 Group:          Development/Libraries
79 Requires:       %{name}-allegro = %{version}-%{release}
80 Requires:       %{name}-devel = %{version}-%{release}
81 Requires:       allegro-devel
82
83 %description allegro-devel
84 Header files for Guichan Allegro library.
85
86 %description allegro-devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki Guichan Allegro.
88
89 %package allegro-static
90 Summary:        Static Guichan Allegro library
91 Summary(pl.UTF-8):      Statyczna biblioteka Guichan Allegro
92 Group:          Development/Libraries
93 Requires:       %{name}-allegro-devel = %{version}-%{release}
94
95 %description allegro-static
96 Static Guichan Allegro library.
97
98 %description allegro-static -l pl.UTF-8
99 Statyczna biblioteka Guichan Allegro.
100
101 %package opengl
102 Summary:        Guichan OpenGL interface library
103 Summary(pl.UTF-8):      Biblioteka interfejsu Guichan do OpenGL
104 Group:          Libraries
105 Requires:       %{name} = %{version}-%{release}
106
107 %description opengl
108 Guichan OpenGL interface library.
109
110 %description opengl -l pl.UTF-8
111 Biblioteka interfejsu Guichan do OpenGL.
112
113 %package opengl-devel
114 Summary:        Header files for Guichan OpenGL library
115 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan OpenGL
116 Group:          Development/Libraries
117 Requires:       %{name}-opengl = %{version}-%{release}
118 Requires:       %{name}-devel = %{version}-%{release}
119 Requires:       OpenGL-devel
120 # can also use allegro-devel+allegro-addons-devel or -sdl for image loading
121
122 %description opengl-devel
123 Header files for Guichan OpenGL library.
124
125 %description opengl-devel -l pl.UTF-8
126 Pliki nagłówkowe biblioteki Guichan OpenGL.
127
128 %package opengl-static
129 Summary:        Static Guichan OpenGL library
130 Summary(pl.UTF-8):      Statyczna biblioteka Guichan OpenGL
131 Group:          Development/Libraries
132 Requires:       %{name}-opengl-devel = %{version}-%{release}
133
134 %description opengl-static
135 Static Guichan OpenGL library.
136
137 %description opengl-static -l pl.UTF-8
138 Statyczna biblioteka Guichan OpenGL.
139
140 %package sdl
141 Summary:        Guichan SDL interface library
142 Summary(pl.UTF-8):      Biblioteka interfejsu Guichan do SDL
143 Group:          Libraries
144 Requires:       %{name} = %{version}-%{release}
145
146 %description sdl
147 Guichan SDL interface library.
148
149 %description sdl -l pl.UTF-8
150 Biblioteka interfejsu Guichan do SDL.
151
152 %package sdl-devel
153 Summary:        Header files for Guichan SDL library
154 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan SDL
155 Group:          Development/Libraries
156 Requires:       %{name}-sdl = %{version}-%{release}
157 Requires:       %{name}-devel = %{version}-%{release}
158 Requires:       SDL-devel
159
160 %description sdl-devel
161 Header files for Guichan SDL library.
162
163 %description sdl-devel -l pl.UTF-8
164 Pliki nagłówkowe biblioteki Guichan SDL.
165
166 %package sdl-static
167 Summary:        Static Guichan SDL library
168 Summary(pl.UTF-8):      Statyczna biblioteka Guichan SDL
169 Group:          Development/Libraries
170 Requires:       %{name}-sdl-devel = %{version}-%{release}
171
172 %description sdl-static
173 Static Guichan SDL library.
174
175 %description sdl-static -l pl.UTF-8
176 Statyczna biblioteka Guichan SDL.
177
178 %prep
179 %setup -q
180 %patch0 -p1
181
182 %build
183 %{__libtoolize}
184 %{__aclocal}
185 %{__autoconf}
186 %{__autoheader}
187 %{__automake}
188 %configure \
189         %{!?with_allegro:--disable-allegro}
190
191 %{__make}
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195
196 %{__make} install \
197         DESTDIR=$RPM_BUILD_ROOT
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %post   allegro -p /sbin/ldconfig
206 %postun allegro -p /sbin/ldconfig
207
208 %post   opengl -p /sbin/ldconfig
209 %postun opengl -p /sbin/ldconfig
210
211 %post   sdl -p /sbin/ldconfig
212 %postun sdl -p /sbin/ldconfig
213
214 %files
215 %defattr(644,root,root,755)
216 %doc AUTHORS COPYING ChangeLog NEWS README TODO
217 %attr(755,root,root) %{_libdir}/libguichan-0.8.1.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libguichan-0.8.1.so.1
219
220 %files devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libguichan.so
223 %{_libdir}/libguichan.la
224 %{_includedir}/guichan.hpp
225 %dir %{_includedir}/guichan
226 %{_includedir}/guichan/*.hpp
227 %exclude %{_includedir}/guichan/allegro.hpp
228 %exclude %{_includedir}/guichan/opengl.hpp
229 %exclude %{_includedir}/guichan/sdl.hpp
230 %{_includedir}/guichan/widgets
231 %{_pkgconfigdir}/guichan-0.8.pc
232
233 %files static
234 %defattr(644,root,root,755)
235 %{_libdir}/libguichan.a
236
237 %if %{with allegro}
238 %files allegro
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_libdir}/libguichan_allegro-0.8.1.so.*.*.*
241 %attr(755,root,root) %ghost %{_libdir}/libguichan_allegro-0.8.1.so.1
242
243 %files allegro-devel
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/libguichan_allegro.so
246 %{_libdir}/libguichan_allegro.la
247 %{_includedir}/guichan/allegro.hpp
248 %{_includedir}/guichan/allegro
249
250 %files allegro-static
251 %defattr(644,root,root,755)
252 %{_libdir}/libguichan_allegro.a
253 %endif
254
255 %files opengl
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libguichan_opengl-0.8.1.so.*.*.*
258 %attr(755,root,root) %ghost %{_libdir}/libguichan_opengl-0.8.1.so.1
259
260 %files opengl-devel
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_libdir}/libguichan_opengl.so
263 %{_libdir}/libguichan_opengl.la
264 %{_includedir}/guichan/opengl.hpp
265 %{_includedir}/guichan/opengl
266 %{_pkgconfigdir}/guichan_opengl-0.8.pc
267
268 %files opengl-static
269 %defattr(644,root,root,755)
270 %{_libdir}/libguichan_opengl.a
271
272 %files sdl
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_libdir}/libguichan_sdl-0.8.1.so.*.*.*
275 %attr(755,root,root) %ghost %{_libdir}/libguichan_sdl-0.8.1.so.1
276
277 %files sdl-devel
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_libdir}/libguichan_sdl.so
280 %{_libdir}/libguichan_sdl.la
281 %{_includedir}/guichan/sdl.hpp
282 %{_includedir}/guichan/sdl
283 %{_pkgconfigdir}/guichan_sdl-0.8.pc
284
285 %files sdl-static
286 %defattr(644,root,root,755)
287 %{_libdir}/libguichan_sdl.a
This page took 0.1315 seconds and 3 git commands to generate.