]> git.pld-linux.org Git - packages/guichan.git/blob - guichan.spec
e1600d3e2abea86274f48f09bbd7c75f3d19071c
[packages/guichan.git] / guichan.spec
1 #
2 # Conditional build:
3 %bcond_without  allegro     # without allegro support
4 #
5 Summary:        Guichan - small, efficient C++ GUI library designed for games
6 Summary(pl.UTF-8):      Guichan - mała, wydajna biblioteka GUI w C++ przeznaczona do gier
7 Name:           guichan
8 Version:        0.8.2
9 Release:        3
10 License:        BSD
11 Group:          Libraries
12 # NOTE: now sources available at https://gitorious.org/guichan/mainline
13 Source0:        http://guichan.googlecode.com/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  af535d7f387e774e3197cef8023ea105
15 Patch0:         link.patch
16 URL:            http://guichan.sourceforge.net/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  SDL-devel
19 BuildRequires:  SDL_image-devel
20 %{?with_allegro:BuildRequires:      allegro-devel}
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1.4
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Guichan is a small, efficient C++ GUI library designed for games. It
30 comes with a standard set of widgets and can use several different
31 objects for displaying graphics and grabbing user input.
32
33 %description -l pl.UTF-8
34 Guichan to mała, wydajna biblioteka GUI w C++ przeznaczona do gier.
35 Zawiera standardowy zestaw widgetów, może używać kilku różnych
36 obiektów do wyświetlania grafiki i pobierania wejścia od użytkownika.
37
38 %package devel
39 Summary:        Header files for Guichan library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libstdc++-devel
44
45 %description devel
46 Header files for Guichan library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki Guichan.
50
51 %package static
52 Summary:        Static version of Guichan libraries
53 Summary(pl.UTF-8):      Statyczne wersje bibliotek Guichan
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static version of Guichan libraries.
59
60 %description static -l pl.UTF-8
61 Statyczne wersje bibliotek Guichan.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66
67 %build
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 %configure \
74         %{!?with_allegro:--disable-allegro}
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS COPYING ChangeLog NEWS README TODO
93 %attr(755,root,root) %{_libdir}/libguichan*.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libguichan*.so.1
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libguichan*.so
99 %{_libdir}/libguichan*.la
100 %{_includedir}/guichan*
101 %{_pkgconfigdir}/guichan*.pc
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libguichan*.a
This page took 0.060502 seconds and 2 git commands to generate.