]> git.pld-linux.org Git - packages/guichan.git/blob - guichan.spec
987f719b2256b9a08783d00536d92987dbd00ff6
[packages/guichan.git] / guichan.spec
1 # Conditional build:
2 %bcond_without  allegro     # without allegro support
3 #
4 Summary:        Guichan - small, efficient C++ GUI library designed for games
5 Summary(pl.UTF-8):      Guichan - mała, wydajna biblioteka GUI w C++ przeznaczona do gier
6 Name:           guichan
7 Version:        0.8.2
8 Release:        2
9 License:        BSD
10 Group:          Libraries
11 Source0:        http://guichan.googlecode.com/files/%{name}-%{version}.tar.gz
12 # Source0-md5:  af535d7f387e774e3197cef8023ea105
13 Patch0:         link.patch
14 URL:            http://guichan.sourceforge.net/
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  SDL_image-devel
18 %{?with_allegro:BuildRequires:      allegro-devel}
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # use symbold from libguichan.so (fixing would cause link loop)
27 %define         skip_post_check_so      libguichan_.*.so.*
28
29 %description
30 Guichan is a small, efficient C++ GUI library designed for games. It
31 comes with a standard set of widgets and can use several different
32 objects for displaying graphics and grabbing user input.
33
34 %description -l pl.UTF-8
35 Guichan to mała, wydajna biblioteka GUI w C++ przeznaczona do gier.
36 Zawiera standardowy zestaw widgetów, może używać kilku różnych
37 obiektów do wyświetlania grafiki i pobierania wejścia od użytkownika.
38
39 %package devel
40 Summary:        Header files for Guichan library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libstdc++-devel
45
46 %description devel
47 Header files for Guichan library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki Guichan.
51
52 %package static
53 Summary:        Static version of Guichan libraries
54 Summary(pl.UTF-8):      Statyczne wersje bibliotek Guichan
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static version of Guichan libraries.
60
61 %description static -l pl.UTF-8
62 Statyczne wersje bibliotek Guichan.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         %{!?with_allegro:--disable-allegro}
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS COPYING ChangeLog NEWS README TODO
94 %attr(755,root,root) %{_libdir}/libguichan*.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libguichan*.so.1
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libguichan*.so
100 %{_libdir}/libguichan*.la
101 %{_includedir}/guichan*
102 %{_pkgconfigdir}/guichan*.pc
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/libguichan*.a
This page took 0.082422 seconds and 3 git commands to generate.