]> git.pld-linux.org Git - packages/guichan.git/blob - guichan.spec
33a9f59e0f207d05774530b96d39c39d9efbeecb
[packages/guichan.git] / guichan.spec
1 #
2 # Conditional build:
3 %bcond_with     allegro     # with allegro support (doesn't build)
4 #
5 Summary:        Guichan - small, efficient C++ GUI library designed for games
6 Summary(pl.UTF-8):      Guichan - mała, wydajna biblioteka GUI w C++ przeznaczona do gier
7 Name:           guichan
8 Version:        0.6.1
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/guichan/%{name}-%{version}.tar.gz
13 # Source0-md5:  830145f71ad4ce4c91e09808fec68c8a
14 URL:            http://guichan.sourceforge.net/
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  SDL_image-devel
18 %{?with_allegro:BuildRequires:      allegro-devel}
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libstdc++-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Guichan is a small, efficient C++ GUI library designed for games. It
26 comes with a standard set of widgets and can use several different
27 objects for displaying graphics and grabbing user input.
28
29 %description -l pl.UTF-8
30 Guichan to mała, wydajna biblioteka GUI w C++ przeznaczona do gier.
31 Zawiera standardowy zestaw widgetów, może używać kilku różnych
32 obiektów do wyświetlania grafiki i pobierania wejścia od użytkownika.
33
34 %package devel
35 Summary:        Header files for Guichan library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Guichan
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       libstdc++-devel
40
41 %description devel
42 Header files for Guichan library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki Guichan.
46
47 %package static
48 Summary:        Static version of Guichan libraries
49 Summary(pl.UTF-8):      Statyczne wersje bibliotek Guichan
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static version of Guichan libraries.
55
56 %description static -l pl.UTF-8
57 Statyczne wersje bibliotek Guichan.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         %{!?with_allegro:--disable-allegro}
69 %{__make} \
70         CFLAGS="%{rpmcflags}"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS COPYING ChangeLog NEWS README TODO
87 %attr(755,root,root) %{_libdir}/libguichan*.so.*.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libguichan*.so
92 %{_libdir}/libguichan*.la
93 %{_includedir}/guichan*
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libguichan*.a
This page took 0.057295 seconds and 2 git commands to generate.