]> git.pld-linux.org Git - packages/gtkspell3.git/blob - gtkspell3.spec
744642ac2bf264ac47d138c00a50cc0755181d01
[packages/gtkspell3.git] / gtkspell3.spec
1 # TODO
2 # - gtk+2 bindings possible besides gtk+3 as well
3 #
4 # Conditional build:
5 %bcond_without  vala            # do not build Vala API
6
7 Summary:        GTK+ Spell Checker Interface Library
8 Summary(pl.UTF-8):      Biblioteka z interfejsem do narzędzia sprawdzającego pisownię dla GTK+
9 Name:           gtkspell3
10 Version:        3.0.7
11 Release:        2
12 License:        GPL
13 Group:          X11/Libraries
14 Source0:        http://gtkspell.sourceforge.net/download/%{name}-%{version}.tar.gz
15 # Source0-md5:  f15a7c29b71d6ae343c783af3571c8d2
16 URL:            http://gtkspell.sourceforge.net/
17 BuildRequires:  autoconf >= 2.62
18 BuildRequires:  automake
19 BuildRequires:  docbook-dtd42-xml
20 BuildRequires:  enchant-devel >= 0.4.0
21 BuildRequires:  gettext-tools
22 BuildRequires:  gobject-introspection-devel >= 1.30.0
23 BuildRequires:  gtk+3-devel >= 3
24 BuildRequires:  gtk-doc >= 1.14
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  iso-codes
27 BuildRequires:  libtool
28 BuildRequires:  pango-devel >= 1:1.13.3
29 BuildRequires:  pkgconfig
30 %{?with_vala:BuildRequires:     vala >= 2:0.18.0}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 GtkSpell provides MSWord/MacOSX-style highlighting of misspelled words
35 in a GtkTextView widget. Right-clicking a misspelled word pops up a
36 menu of suggested replacements.
37
38 %description -l pl.UTF-8
39 GtkSpell udostępnia podobne do MS Worda lub MacOSX podświetlanie
40 błędnie napisanych słów w widgecie GtkTextView. Kliknięcie prawym
41 przyciskiem na błędne słowo otwiera menu z sugerowanymi poprawkami.
42
43 %package devel
44 Summary:        Header files for GtkSpell API version 3.0
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla gtkspella
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       enchant-devel >= 0.4.0
49 Requires:       gtk+3-devel >= 3
50
51 %description devel
52 Header files for GtkSpell API version 3.0.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla gtkspella.
56
57 %package static
58 Summary:        Static libraries for GtkSpell
59 Summary(pl.UTF-8):      Biblioteki statyczne dla gtkspella
60 Group:          X11/Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static libraries for GtkSpell.
65
66 %description static -l pl.UTF-8
67 Biblioteki statyczne dla gtkspella.
68
69 %package apidocs
70 Summary:        GtkSpell API documentation
71 Summary(pl.UTF-8):      Dokumentacja API gtkspell
72 Group:          Documentation
73 Requires:       gtk-doc-common
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 GtkSpell API documentation.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API gtkspell.
83
84 %package -n vala-%{name}
85 Summary:        GtkSpell API for Vala language
86 Summary(pl.UTF-8):      API GtkSpell dla języka Vala
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.18.0
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description -n vala-%{name}
95 GtkSpell API for Vala language.
96
97 %description -n vala-%{name} -l pl.UTF-8
98 API GtkSpell dla języka Vala.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__gtkdocize}
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-silent-rules \
112         --enable-gtk-doc \
113         --with-html-dir=%{_gtkdocdir}
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         pkgconfigdir=%{_pkgconfigdir}
121
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgtkspell3-3.la
123
124 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/son
125
126 %find_lang %{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog README
137 %attr(755,root,root) %{_libdir}/libgtkspell3-3.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libgtkspell3-3.so.0
139 %{_libdir}/girepository-1.0/GtkSpell-3.0.typelib
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libgtkspell3-3.so
144 %{_includedir}/gtkspell-3.0
145 %{_pkgconfigdir}/gtkspell3-3.0.pc
146 %{_datadir}/gir-1.0/GtkSpell-3.0.gir
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libgtkspell3-3.a
151
152 %files apidocs
153 %defattr(644,root,root,755)
154 %{_gtkdocdir}/gtkspell3
155
156 %if %{with vala}
157 %files -n vala-%{name}
158 %defattr(644,root,root,755)
159 %{_datadir}/vala/vapi/gtkspell3-3.0.deps
160 %{_datadir}/vala/vapi/gtkspell3-3.0.vapi
161 %endif
This page took 0.115918 seconds and 2 git commands to generate.