]> git.pld-linux.org Git - packages/gtksourceview3.git/blob - gtksourceview3.spec
501a40e426c0b9bb48a1ea7da2dd5a43f1f59307
[packages/gtksourceview3.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 %bcond_without  vala    # do not build Vala API
5 #
6 Summary:        Text widget that extends the standard GTK+ 3.x
7 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
8 Name:           gtksourceview3
9 Version:        3.18.0
10 Release:        1
11 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.18/gtksourceview-%{version}.tar.xz
14 # Source0-md5:  8e99579d6a8b2fdae45b557f40df0176
15 URL:            http://www.gnome.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  autoconf-archive >= 2015.09.25
18 BuildRequires:  automake >= 1:1.13
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-tools >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.44.0
22 BuildRequires:  gnome-common >= 2.24.0
23 BuildRequires:  gobject-introspection-devel >= 1.42.0
24 BuildRequires:  gtk+3-devel >= 3.16.0
25 BuildRequires:  gtk-doc >= 1.24
26 BuildRequires:  intltool >= 0.40.0
27 %if %{with glade}
28 BuildRequires:  libgladeui-devel >= 3.9.0
29 %endif
30 BuildRequires:  libtool >= 2:2.2.6
31 BuildRequires:  libxml2-devel >= 1:2.6.31
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  vala
36 BuildRequires:  xz
37 Requires:       glib2 >= 1:2.44.0
38 Requires:       gtk+3 >= 3.16.0
39 Requires:       libxml2 >= 1:2.6.31
40 # sr@Latn vs. sr@latin
41 Conflicts:      glibc-misc < 6:2.7
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
46 widget GtkTextView. It improves GtkTextView by implementing syntax
47 highlighting and other features typical of a source editor.
48
49 %description -l pl.UTF-8
50 GtkSourceView to widget tekstowy rozszerzający standardowy widget
51 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
52 zaimplementowanie podświetlania składni i innych możliwości typowych
53 dla edytora źródeł.
54
55 %package apidocs
56 Summary:        GtkSourceView API documentation
57 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
58 Group:          Documentation
59 Requires:       gtk-doc-common
60
61 %description apidocs
62 GtkSourceView API documentation.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API GtkSourceView.
66
67 %package devel
68 Summary:        Header files for GtkSourceView
69 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       glib2-devel >= 1:2.44.0
73 Requires:       gtk+3-devel >= 3.16.0
74 Requires:       libxml2-devel >= 1:2.6.31
75
76 %description devel
77 Header files for GtkSourceView.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe dla GtkSourceView.
81
82 %package static
83 Summary:        Static GtkSourceView library
84 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
85 Group:          X11/Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static GtkSourceView library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka GtkSourceView.
93
94 %package -n glade3-gtksourceview
95 Summary:        Glade3 catalog entry for GtkSourceView library
96 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Requires:       libgladeui >= 3.9.0
100
101 %description -n glade3-gtksourceview
102 Glade3 catalog entry for GtkSourceView library.
103
104 %description -n glade3-gtksourceview -l pl.UTF-8
105 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
106
107 %package -n vala-gtksourceview
108 Summary:        GtkSourceView API for Vala language
109 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112 Requires:       vala
113
114 %description -n vala-gtksourceview
115 GtkSourceView API for Vala language.
116
117 %description -n vala-gtksourceview -l pl.UTF-8
118 API GtkSourceView dla języka Vala.
119
120 %prep
121 %setup -q -n gtksourceview-%{version}
122
123 # force new version from autoconf-archive (original one uses non-POSIX ${V:N} syntax)
124 %{__rm} m4/ax_compiler_flags_cflags.m4
125
126 %build
127 %{__gtkdocize}
128 %{__intltoolize}
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         %{__enable glade glade-catalog} \
136         --enable-gtk-doc \
137         --enable-providers \
138         --disable-silent-rules \
139         --enable-static \
140         --with-html-dir=%{_gtkdocdir}
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
150
151 %find_lang gtksourceview-3.0
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files -f gtksourceview-3.0.lang
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.1
163 %{_datadir}/gtksourceview-3.0
164 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
165
166 %files apidocs
167 %defattr(644,root,root,755)
168 %{_gtkdocdir}/gtksourceview-3.0
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
173 %{_includedir}/gtksourceview-3.0
174 %{_pkgconfigdir}/gtksourceview-3.0.pc
175 %{_datadir}/gir-1.0/GtkSource-3.0.gir
176
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libgtksourceview-3.0.a
180
181 %if %{with glade}
182 %files -n glade3-gtksourceview
183 %defattr(644,root,root,755)
184 %{_datadir}/glade3/catalogs/gtksourceview.xml
185 %endif
186
187 %if %{with vala}
188 %files -n vala-gtksourceview
189 %defattr(644,root,root,755)
190 %{_datadir}/vala/vapi/gtksourceview-3.0.deps
191 %{_datadir}/vala/vapi/gtksourceview-3.0.vapi
192 %endif
This page took 0.066259 seconds and 2 git commands to generate.