]> git.pld-linux.org Git - packages/gtkmm4.git/blob - gtkmm4.spec
9687d01f16c341c94a63dcfbc7d0abc6e7a1e65b
[packages/gtkmm4.git] / gtkmm4.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 %define         atkmm_ver       2.29.1
6 %define         cairomm_ver     1.15.4
7 %define         glibmm_ver      2.68.0
8 %define         gtk4_ver        4.7.2
9 %define         pangomm_ver     2.50.0
10 Summary:        A C++ interface for the GTK+ (a GUI library for X)
11 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
12 Name:           gtkmm4
13 Version:        4.8.0
14 Release:        1
15 License:        LGPL v2+
16 Group:          X11/Libraries
17 Source0:        https://download.gnome.org/sources/gtkmm/4.8/gtkmm-%{version}.tar.xz
18 # Source0-md5:  9b577203ce37a5cd70e35bf194be5cf4
19 URL:            https://www.gtkmm.org/
20 BuildRequires:  atkmm2.36-devel >= %{atkmm_ver}
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  cairomm1.16-devel >= %{cairomm_ver}
24 BuildRequires:  doxygen >= 1:1.8.9
25 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
26 BuildRequires:  glibmm2.68-devel >= %{glibmm_ver}
27 BuildRequires:  gtk4-devel >= %{gtk4_ver}
28 BuildRequires:  libepoxy-devel >= 1.2
29 BuildRequires:  libsigc++3-devel >= 3.0
30 BuildRequires:  libstdc++-devel >= 6:7
31 BuildRequires:  libtool >= 2:2.0
32 BuildRequires:  mm-common >= 0.9.12
33 BuildRequires:  pangomm2.48-devel >= %{pangomm_ver}
34 BuildRequires:  perl-base >= 1:5.6.0
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpm-build >= 4.6
37 BuildRequires:  rpmbuild(macros) >= 1.752
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 Requires:       atkmm2.36 >= %{atkmm_ver}
41 Requires:       cairomm1.16 >= %{cairomm_ver}
42 Requires:       gdk-pixbuf2 >= 2.36.0
43 Requires:       glibmm2.68 >= %{glibmm_ver}
44 Requires:       gtk4 >= %{gtk4_ver}
45 Requires:       pangomm2.48 >= %{pangomm_ver}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
50 library. The interface provides a convenient interface for C++
51 programmers to create GUIs with GTK+'s flexible object-oriented
52 framework. Features include type safe callbacks, widgets that are
53 extensible using inheritance and over 110 classes that can be freely
54 combined to quickly create complex user interfaces.
55
56 %description -l pl.UTF-8
57 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
58 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
59 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
60
61 %package devel
62 Summary:        gtkmm and gdkmm header files
63 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       atkmm2.36-devel >= %{atkmm_ver}
67 Requires:       cairomm1.16-devel >= %{cairomm_ver}
68 Requires:       gdk-pixbuf2-devel >= 2.36.0
69 Requires:       glibmm2.68-devel >= %{glibmm_ver}
70 Requires:       gtk4-devel >= %{gtk4_ver}
71 Requires:       libstdc++-devel >= 6:7
72 Requires:       pangomm2.48-devel >= %{pangomm_ver}
73
74 %description devel
75 Header files for gtkmm library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki gtkmm.
79
80 %package static
81 Summary:        gtkmm and gdkmm static libraries
82 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 gtkmm and gdkmm static libraries.
88
89 %description static -l pl.UTF-8
90 Biblioteki statyczne gtkmm i gdkmm.
91
92 %package apidocs
93 Summary:        Reference documentation for gtkmm and gdkmm
94 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
95 Group:          Documentation
96 Requires:       devhelp
97 BuildArch:      noarch
98
99 %description apidocs
100 Reference documentation for gtkmm and gdkmm.
101
102 %description apidocs -l pl.UTF-8
103 Szczegółowa dokumentacja gtkmm i gdkmm.
104
105 %prep
106 %setup -q -n gtkmm-%{version}
107
108 # missing in release tarball, not needed for Linux
109 mkdir win32_installer
110 touch win32_installer/filelist.am \
111         win32_installer/gtkmm-installer.nsi.in
112
113 %build
114 mm-common-prepare --copy --force
115 %{__libtoolize}
116 %{__aclocal} -I build
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --enable-maintainer-mode \
122         --disable-silent-rules \
123         %{?with_static_libs:--enable-static}
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README
144 %attr(755,root,root) %{_libdir}/libgtkmm-4.0.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-4.0.so.0
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libgtkmm-4.0.so
150 %{_libdir}/gtkmm-4.0
151 %{_includedir}/gtkmm-4.0
152 %{_pkgconfigdir}/gtkmm-4.0.pc
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libgtkmm-4.0.a
158 %endif
159
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_docdir}/gtkmm-4.0
163 %{_datadir}/devhelp/books/gtkmm-4.0
This page took 0.108247 seconds and 2 git commands to generate.