]> git.pld-linux.org Git - packages/gtkmm4.git/blob - gtkmm4.spec
- updated to 4.10.0
[packages/gtkmm4.git] / gtkmm4.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 %define         cairomm_ver     1.15.4
6 %define         glibmm_ver      2.68.0
7 %define         gtk4_ver        4.10.0
8 %define         pangomm_ver     2.50.0
9 Summary:        A C++ interface for the GTK+ (a GUI library for X)
10 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
11 Name:           gtkmm4
12 Version:        4.10.0
13 Release:        1
14 License:        LGPL v2+
15 Group:          X11/Libraries
16 Source0:        https://download.gnome.org/sources/gtkmm/4.10/gtkmm-%{version}.tar.xz
17 # Source0-md5:  b3c2bd5dff7eb5215f5599c705100e18
18 URL:            https://www.gtkmm.org/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  cairomm1.16-devel >= %{cairomm_ver}
22 BuildRequires:  doxygen >= 1:1.8.9
23 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
24 BuildRequires:  glibmm2.68-devel >= %{glibmm_ver}
25 BuildRequires:  gtk4-devel >= %{gtk4_ver}
26 BuildRequires:  libepoxy-devel >= 1.2
27 BuildRequires:  libsigc++3-devel >= 3.0
28 BuildRequires:  libstdc++-devel >= 6:7
29 BuildRequires:  libtool >= 2:2.0
30 BuildRequires:  mm-common >= 0.9.12
31 BuildRequires:  pangomm2.48-devel >= %{pangomm_ver}
32 BuildRequires:  perl-base >= 1:5.6.0
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpm-build >= 4.6
35 BuildRequires:  rpmbuild(macros) >= 1.752
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 Requires:       cairomm1.16 >= %{cairomm_ver}
39 Requires:       gdk-pixbuf2 >= 2.36.0
40 Requires:       glibmm2.68 >= %{glibmm_ver}
41 Requires:       gtk4 >= %{gtk4_ver}
42 Requires:       pangomm2.48 >= %{pangomm_ver}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
47 library. The interface provides a convenient interface for C++
48 programmers to create GUIs with GTK+'s flexible object-oriented
49 framework. Features include type safe callbacks, widgets that are
50 extensible using inheritance and over 110 classes that can be freely
51 combined to quickly create complex user interfaces.
52
53 %description -l pl.UTF-8
54 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
55 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
56 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
57
58 %package devel
59 Summary:        gtkmm and gdkmm header files
60 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       cairomm1.16-devel >= %{cairomm_ver}
64 Requires:       gdk-pixbuf2-devel >= 2.36.0
65 Requires:       glibmm2.68-devel >= %{glibmm_ver}
66 Requires:       gtk4-devel >= %{gtk4_ver}
67 Requires:       libstdc++-devel >= 6:7
68 Requires:       pangomm2.48-devel >= %{pangomm_ver}
69
70 %description devel
71 Header files for gtkmm library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki gtkmm.
75
76 %package static
77 Summary:        gtkmm and gdkmm static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
79 Group:          X11/Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 gtkmm and gdkmm static libraries.
84
85 %description static -l pl.UTF-8
86 Biblioteki statyczne gtkmm i gdkmm.
87
88 %package apidocs
89 Summary:        Reference documentation for gtkmm and gdkmm
90 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
91 Group:          Documentation
92 Requires:       devhelp
93 BuildArch:      noarch
94
95 %description apidocs
96 Reference documentation for gtkmm and gdkmm.
97
98 %description apidocs -l pl.UTF-8
99 Szczegółowa dokumentacja gtkmm i gdkmm.
100
101 %prep
102 %setup -q -n gtkmm-%{version}
103
104 # missing in release tarball, not needed for Linux
105 mkdir win32_installer
106 touch win32_installer/filelist.am \
107         win32_installer/gtkmm-installer.nsi.in
108
109 %build
110 mm-common-prepare --copy --force
111 %{__libtoolize}
112 %{__aclocal} -I build
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --enable-maintainer-mode \
118         --disable-silent-rules \
119         %{?with_static_libs:--enable-static}
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README.md
140 %attr(755,root,root) %{_libdir}/libgtkmm-4.0.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-4.0.so.0
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libgtkmm-4.0.so
146 %{_libdir}/gtkmm-4.0
147 %{_includedir}/gtkmm-4.0
148 %{_pkgconfigdir}/gtkmm-4.0.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libgtkmm-4.0.a
154 %endif
155
156 %files apidocs
157 %defattr(644,root,root,755)
158 %{_docdir}/gtkmm-4.0
159 %{_datadir}/devhelp/books/gtkmm-4.0
This page took 0.103162 seconds and 3 git commands to generate.