]> git.pld-linux.org Git - packages/gtkmm3.git/blob - gtkmm3.spec
BR: graphviz
[packages/gtkmm3.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         atkmm_ver       2.24.2
6 %define         glibmm_ver      2.54.0
7 %define         gtk3_ver        3.24.0
8 %define         pangomm_ver     2.38.2
9 Summary:        A C++ interface for the GTK+ (a GUI library for X)
10 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
11 Name:           gtkmm3
12 Version:        3.24.7
13 Release:        1
14 License:        LGPL v2+
15 Group:          X11/Libraries
16 Source0:        https://download.gnome.org/sources/gtkmm/3.24/gtkmm-%{version}.tar.xz
17 # Source0-md5:  9576353c26db5e273a074264b68ad6cf
18 URL:            https://www.gtkmm.org/
19 BuildRequires:  atkmm-devel >= %{atkmm_ver}
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  cairomm-devel >= 1.12.0
23 BuildRequires:  doxygen >= 1:1.8.9
24 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
25 BuildRequires:  glibmm-devel >= %{glibmm_ver}
26 BuildRequires:  graphviz
27 BuildRequires:  gtk+3-devel >= %{gtk3_ver}
28 BuildRequires:  libepoxy-devel >= 1.2
29 BuildRequires:  libsigc++-devel
30 BuildRequires:  libstdc++-devel >= 6:4.7
31 BuildRequires:  libtool >= 2:2.0
32 BuildRequires:  mm-common >= 0.9.10
33 BuildRequires:  pangomm-devel >= %{pangomm_ver}
34 BuildRequires:  perl-base >= 1:5.6.0
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpm-build >= 4.6
37 BuildRequires:  rpmbuild(macros) >= 1.752
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 Requires:       atkmm >= %{atkmm_ver}
41 Requires:       cairomm >= 1.12.0
42 Requires:       gdk-pixbuf2 >= 2.36.0
43 Requires:       glibmm >= %{glibmm_ver}
44 Requires:       gtk+3 >= %{gtk3_ver}
45 Requires:       pangomm >= %{pangomm_ver}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
50 library. The interface provides a convenient interface for C++
51 programmers to create GUIs with GTK+'s flexible object-oriented
52 framework. Features include type safe callbacks, widgets that are
53 extensible using inheritance and over 110 classes that can be freely
54 combined to quickly create complex user interfaces.
55
56 %description -l pl.UTF-8
57 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
58 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
59 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
60
61 %package devel
62 Summary:        gtkmm and gdkmm header files
63 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       atkmm-devel >= %{atkmm_ver}
67 Requires:       cairomm-devel >= 1.12.0
68 Requires:       gdk-pixbuf2-devel >= 2.36.0
69 Requires:       glibmm-devel >= %{glibmm_ver}
70 Requires:       gtk+3-devel >= %{gtk3_ver}
71 Requires:       libstdc++-devel >= 6:4.6
72 Requires:       pangomm-devel >= %{pangomm_ver}
73
74 %description devel
75 Header files for gtkmm library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki gtkmm.
79
80 %package static
81 Summary:        gtkmm and gdkmm static libraries
82 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 gtkmm and gdkmm static libraries.
88
89 %description static -l pl.UTF-8
90 Biblioteki statyczne gtkmm i gdkmm.
91
92 %package apidocs
93 Summary:        Reference documentation for gtkmm and gdkmm
94 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
95 Group:          Documentation
96 Requires:       devhelp
97 BuildArch:      noarch
98
99 %description apidocs
100 Reference documentation for gtkmm and gdkmm.
101
102 %description apidocs -l pl.UTF-8
103 Szczegółowa dokumentacja gtkmm i gdkmm.
104
105 %prep
106 %setup -q -n gtkmm-%{version}
107
108 # missing in release tarball, not needed for Linux
109 mkdir win32_installer
110 touch win32_installer/filelist.am \
111         win32_installer/gtkmm-installer.nsi.in
112
113 %build
114 mm-common-prepare --copy --force
115 %{__libtoolize}
116 %{__aclocal} -I build
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --enable-maintainer-mode \
122         --disable-silent-rules \
123         %{?with_static_libs:--enable-static}
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README
144 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
146 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
152 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
153 %{_libdir}/gdkmm-3.0
154 %{_libdir}/gtkmm-3.0
155 %{_includedir}/gdkmm-3.0
156 %{_includedir}/gtkmm-3.0
157 %{_pkgconfigdir}/gdkmm-3.0.pc
158 %{_pkgconfigdir}/gtkmm-3.0.pc
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libgdkmm-3.0.a
164 %{_libdir}/libgtkmm-3.0.a
165 %endif
166
167 %files apidocs
168 %defattr(644,root,root,755)
169 %{_docdir}/gtkmm-3.0
170 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.078463 seconds and 3 git commands to generate.