]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
- icu rebuild
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - GAMEPAD
3 # - BATTERY_STATUS (BR: upower-devel)
4 # - FTL_JIT (BR: llvm, libcxxabi?)
5 #
6 # Conditional build:
7 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
8 %bcond_without  introspection   # disable introspection
9 %bcond_with     seccomp         # seccomp filters (broken as of 2.6.5)
10 %bcond_with     wayland         # Wayland target (broken as of 2.6.[0-5])
11 #
12 # it's not possible to build this with debuginfo on 32bit archs due to
13 # memory constraints during linking
14 %ifarch %{ix86} x32
15 %define         _enable_debug_packages          0
16 %endif
17 Summary:        Port of WebKit embeddable web component to GTK+ 3
18 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
19 Name:           gtk-webkit4
20 Version:        2.8.1
21 Release:        2
22 License:        BSD-like
23 Group:          X11/Libraries
24 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
25 # Source0-md5:  25459ad6646e3cae4b38e7612af9c0bf
26 Patch0:         x32.patch
27 URL:            http://webkitgtk.org/
28 BuildRequires:  /usr/bin/ld.gold
29 BuildRequires:  EGL-devel
30 BuildRequires:  OpenGL-GLX-devel
31 BuildRequires:  at-spi2-core-devel >= 2.6.0
32 BuildRequires:  atk-devel
33 BuildRequires:  bison >= 2.3
34 BuildRequires:  cairo-devel >= 1.10.2
35 BuildRequires:  cmake >= 2.8.8
36 BuildRequires:  enchant-devel >= 0.22
37 BuildRequires:  flex >= 2.5.34
38 BuildRequires:  fontconfig-devel >= 2.8.0
39 BuildRequires:  freetype-devel >= 1:2.4.2
40 BuildRequires:  gcc-c++ >= 6:4.7
41 BuildRequires:  geoclue2-devel >= 2.1.5
42 BuildRequires:  gettext-devel
43 BuildRequires:  glib2-devel >= 1:2.36.0
44 BuildRequires:  glibc-misc
45 BuildRequires:  gnutls-devel >= 3.0.0
46 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
47 BuildRequires:  gperf >= 3.0.1
48 BuildRequires:  gstreamer-devel >= 1.0.3
49 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
50 BuildRequires:  libstdc++-devel >= 6:4.7
51 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
52 BuildRequires:  gtk+3-devel >= 3.12.0
53 BuildRequires:  gtk-doc >= 1.10
54 BuildRequires:  harfbuzz-devel >= 0.9.7
55 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
56 BuildRequires:  libicu-devel >= 4.2.1
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libnotify-devel
59 BuildRequires:  libpng-devel
60 BuildRequires:  libsecret-devel
61 BuildRequires:  libsoup-devel >= 2.42.0
62 BuildRequires:  libstdc++-devel
63 BuildRequires:  libwebp-devel
64 BuildRequires:  libxml2-devel >= 1:2.8.0
65 BuildRequires:  libxslt-devel >= 1.1.7
66 BuildRequires:  pango-devel >= 1:1.32.0
67 BuildRequires:  perl-base >= 1:5.10.0
68 BuildRequires:  pkgconfig
69 BuildRequires:  python >= 1:2.7.0
70 BuildRequires:  rpmbuild(macros) >= 1.699
71 BuildRequires:  ruby >= 1.8.7
72 BuildRequires:  sqlite3-devel >= 3
73 BuildRequires:  tar >= 1:1.22
74 #BuildRequires: udev-glib-devel
75 BuildRequires:  xorg-lib-libXcomposite-devel
76 BuildRequires:  xorg-lib-libXdamage-devel
77 BuildRequires:  xorg-lib-libXrender-devel
78 BuildRequires:  xorg-lib-libXt-devel
79 BuildRequires:  xz
80 BuildRequires:  zlib-devel
81 Requires:       cairo >= 1.10.2
82 Requires:       enchant >= 0.22
83 Requires:       fontconfig-libs >= 2.8.0
84 Requires:       freetype >= 1:2.4.2
85 Requires:       glib2 >= 1:2.36.0
86 Requires:       gstreamer >= 1.0.3
87 Requires:       gstreamer-plugins-base >= 1.0.3
88 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
89 Requires:       gtk+3 >= 3.12.0
90 Requires:       harfbuzz >= 0.9.7
91 Requires:       libsoup >= 2.42.0
92 Requires:       libxml2 >= 1:2.8.0
93 Requires:       libxslt >= 1.1.7
94 Requires:       pango >= 1:1.32.0
95 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 # __once_call, __once_called non-function symbols from libstdc++
99 %define         skip_post_check_so      lib.*gtk-4.0.*
100
101 %description
102 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
103 3.
104
105 %description -l pl.UTF-8
106 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
107
108 %package devel
109 Summary:        Development files for WebKit for GTK+ 3
110 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
111 Group:          X11/Development/Libraries
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       glib2-devel >= 1:2.36.0
114 Requires:       gtk+3-devel >= 3.12.0
115 Requires:       libsoup-devel >= 2.42.0
116 Requires:       libstdc++-devel
117
118 %description devel
119 Development files for WebKit for GTK+ 3.
120
121 %description devel -l pl.UTF-8
122 Pliki programistyczne komponentu WebKit dla GTK+ 3.
123
124 %package apidocs
125 Summary:        WebKit API documentation
126 Summary(pl.UTF-8):      Dokumentacja API WebKita
127 Group:          Documentation
128 Requires:       gtk-doc-common
129 %if "%{_rpmversion}" >= "5"
130 BuildArch:      noarch
131 %endif
132
133 %description apidocs
134 WebKit API documentation.
135
136 %description apidocs -l pl.UTF-8
137 Dokumentacja API WebKita.
138
139 %prep
140 %setup -q -n webkitgtk-%{version}
141 %patch0 -p1
142
143 %build
144 install -d build
145 cd build
146 %cmake .. \
147         -DENABLE_CREDENTIAL_STORAGE=ON \
148         -DENABLE_GEOLOCATION=ON \
149         -DENABLE_GTKDOC=ON \
150         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
151         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
152         %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
153         %{?with_wayland:-DENABLE_WAYLAND_TARGET=ON} \
154 %ifarch x32
155         -DENABLE_JIT=OFF \
156 %endif
157         -DENABLE_VIDEO=ON \
158         -DENABLE_WEB_AUDIO=ON \
159         -DENABLE_WEBGL=ON \
160         -DPORT=GTK \
161         -DSHOULD_INSTALL_JS_SHELL=ON
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} -C build install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
172 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
173 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
174 %endif
175
176 %find_lang WebKit2GTK-4.0
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %files -f WebKit2GTK-4.0.lang
185 %defattr(644,root,root,755)
186 %doc NEWS
187 %attr(755,root,root) %{_bindir}/jsc
188 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
190 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
192 %if %{with introspection}
193 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
194 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
195 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
196 %endif
197 %dir %{_libdir}/webkit2gtk-4.0
198 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitNetworkProcess
199 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess
200 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess2
201 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitWebProcess
202 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
203 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
204
205 %files devel
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
208 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
209 %if %{with introspection}
210 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
211 %{_datadir}/gir-1.0/WebKit2-4.0.gir
212 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
213 %endif
214 %{_includedir}/webkitgtk-4.0
215 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
216 %{_pkgconfigdir}/webkit2gtk-4.0.pc
217 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
218
219 %files apidocs
220 %defattr(644,root,root,755)
221 %{_gtkdocdir}/webkit2gtk-4.0
222 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.129189 seconds and 3 git commands to generate.