]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
Update to 2.8.0
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - GAMEPAD
3 # - BATTERY_STATUS (BR: upower-devel)
4 # - FTL_JIT (BR: llvm, libcxxabi?)
5 #
6 # Conditional build:
7 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
8 %bcond_without  introspection   # disable introspection
9 %bcond_with     seccomp         # seccomp filters (broken as of 2.6.5)
10 %bcond_with     wayland         # Wayland target (broken as of 2.6.[0-5])
11 #
12 Summary:        Port of WebKit embeddable web component to GTK+ 3
13 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
14 Name:           gtk-webkit4
15 Version:        2.8.0
16 Release:        1
17 License:        BSD-like
18 Group:          X11/Libraries
19 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
20 # Source0-md5:  fade95513ecd47b68c8cdaeb1add9cd3
21 Patch0:         x32.patch
22 URL:            http://webkitgtk.org/
23 BuildRequires:  /usr/bin/ld.gold
24 BuildRequires:  EGL-devel
25 BuildRequires:  OpenGL-GLX-devel
26 BuildRequires:  at-spi2-core-devel >= 2.6.0
27 BuildRequires:  atk-devel
28 BuildRequires:  bison >= 2.3
29 BuildRequires:  cairo-devel >= 1.10.2
30 BuildRequires:  cmake >= 2.8.8
31 BuildRequires:  enchant-devel >= 0.22
32 BuildRequires:  flex >= 2.5.34
33 BuildRequires:  fontconfig-devel >= 2.8.0
34 BuildRequires:  freetype-devel >= 1:2.4.2
35 BuildRequires:  gcc-c++ >= 6:4.7
36 BuildRequires:  geoclue2-devel >= 2.1.5
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.36.0
39 BuildRequires:  glibc-misc
40 BuildRequires:  gnutls-devel >= 3.0.0
41 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
42 BuildRequires:  gperf >= 3.0.1
43 BuildRequires:  gstreamer-devel >= 1.0.3
44 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
45 BuildRequires:  libstdc++-devel >= 6:4.7
46 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
47 BuildRequires:  gtk+3-devel >= 3.12.0
48 BuildRequires:  gtk-doc >= 1.10
49 BuildRequires:  harfbuzz-devel >= 0.9.7
50 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
51 BuildRequires:  libicu-devel >= 4.2.1
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libpng-devel
54 BuildRequires:  libsecret-devel
55 BuildRequires:  libsoup-devel >= 2.42.0
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  libwebp-devel
58 BuildRequires:  libxml2-devel >= 1:2.8.0
59 BuildRequires:  libxslt-devel >= 1.1.7
60 BuildRequires:  pango-devel >= 1:1.32.0
61 BuildRequires:  perl-base >= 1:5.10.0
62 BuildRequires:  pkgconfig
63 BuildRequires:  python >= 1:2.6.0
64 BuildRequires:  rpmbuild(macros) >= 1.699
65 BuildRequires:  ruby >= 1.8.7
66 BuildRequires:  sqlite3-devel >= 3
67 BuildRequires:  tar >= 1:1.22
68 #BuildRequires: udev-glib-devel
69 BuildRequires:  xorg-lib-libXcomposite-devel
70 BuildRequires:  xorg-lib-libXdamage-devel
71 BuildRequires:  xorg-lib-libXrender-devel
72 BuildRequires:  xorg-lib-libXt-devel
73 BuildRequires:  xz
74 BuildRequires:  zlib-devel
75 Requires:       cairo >= 1.10.2
76 Requires:       enchant >= 0.22
77 Requires:       fontconfig-libs >= 2.8.0
78 Requires:       freetype >= 1:2.4.2
79 Requires:       glib2 >= 1:2.36.0
80 Requires:       gstreamer >= 1.0.3
81 Requires:       gstreamer-plugins-base >= 1.0.3
82 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
83 Requires:       gtk+3 >= 3.12.0
84 Requires:       harfbuzz >= 0.9.7
85 Requires:       libsoup >= 2.42.0
86 Requires:       libxml2 >= 1:2.8.0
87 Requires:       libxslt >= 1.1.7
88 Requires:       pango >= 1:1.32.0
89 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 # __once_call, __once_called non-function symbols from libstdc++
93 %define         skip_post_check_so      lib.*gtk-4.0.*
94
95 %description
96 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
97 3.
98
99 %description -l pl.UTF-8
100 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
101
102 %package devel
103 Summary:        Development files for WebKit for GTK+ 3
104 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
105 Group:          X11/Development/Libraries
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       glib2-devel >= 1:2.36.0
108 Requires:       gtk+3-devel >= 3.12.0
109 Requires:       libsoup-devel >= 2.42.0
110 Requires:       libstdc++-devel
111
112 %description devel
113 Development files for WebKit for GTK+ 3.
114
115 %description devel -l pl.UTF-8
116 Pliki programistyczne komponentu WebKit dla GTK+ 3.
117
118 %package apidocs
119 Summary:        WebKit API documentation
120 Summary(pl.UTF-8):      Dokumentacja API WebKita
121 Group:          Documentation
122 Requires:       gtk-doc-common
123 %if "%{_rpmversion}" >= "5"
124 BuildArch:      noarch
125 %endif
126
127 %description apidocs
128 WebKit API documentation.
129
130 %description apidocs -l pl.UTF-8
131 Dokumentacja API WebKita.
132
133 %prep
134 %setup -q -n webkitgtk-%{version}
135 %patch0 -p1
136
137 %build
138 install -d build
139 cd build
140 # ld cannot handle so huge shared libs (when building with debug info)
141 %ifarch %{x8664}
142 LDFLAGS="%{rpmldflags} -fuse-ld=gold"
143 %else
144 LDFLAGS="%{rpmldflags} -fuse-ld=bfd -Wl,--no-keep-memory"
145 %endif
146 %cmake .. \
147         -DENABLE_CREDENTIAL_STORAGE=ON \
148         -DENABLE_GEOLOCATION=ON \
149         -DENABLE_GTKDOC=ON \
150         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
151         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
152         %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
153         %{?with_wayland:-DENABLE_WAYLAND_TARGET=ON} \
154 %ifarch x32
155         -DENABLE_JIT=OFF \
156 %endif
157         -DENABLE_VIDEO=ON \
158         -DENABLE_WEB_AUDIO=ON \
159         -DENABLE_WEBGL=ON \
160         -DPORT=GTK \
161         -DSHOULD_INSTALL_JS_SHELL=ON
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} -C build install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
172 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
173 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
174 %endif
175
176 %find_lang WebKit2GTK-4.0
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %files -f WebKit2GTK-4.0.lang
185 %defattr(644,root,root,755)
186 %doc NEWS
187 %attr(755,root,root) %{_bindir}/jsc
188 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
190 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
192 %if %{with introspection}
193 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
194 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
195 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
196 %endif
197 %dir %{_libdir}/webkit2gtk-4.0
198 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitNetworkProcess
199 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess
200 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess2
201 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitWebProcess
202 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
203 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
204
205 %files devel
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
208 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
209 %if %{with introspection}
210 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
211 %{_datadir}/gir-1.0/WebKit2-4.0.gir
212 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
213 %endif
214 %{_includedir}/webkitgtk-4.0
215 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
216 %{_pkgconfigdir}/webkit2gtk-4.0.pc
217 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
218
219 %files apidocs
220 %defattr(644,root,root,755)
221 %{_gtkdocdir}/webkit2gtk-4.0
222 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.072412 seconds and 3 git commands to generate.