]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
d49fc9c56ce49164a74d29a1fee1d166369e945b
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (experimental; BR: openwebrtc)
4 # - JPEGXL? (experimental; BR: libjxl-devel)
5 # - SPEECH_SYNTHESIS? (experimental; BR: flite-devel >= 2.2)
6 # - THUNDER? (BR: Thunder + ThunderClientLibraries)
7 #
8 # Conditional build:
9 %bcond_without  introspection   # GObject introspection
10 %bcond_without  libsoup2        # webkit-4.0 (libsoup2 based) variant
11 %bcond_without  libsoup3        # webkit-4.1 (libsoup3 based) variant (HTTP/2 support)
12 %bcond_without  gtk3            # webkit-4.x (gtk3 based) variants
13 %bcond_without  gtk4            # webkit-6.0 (gtk4/libsoup3 based) variant
14 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
15 %bcond_with     lowmem          # try to reduce build memory usage by adjusting gcc gc
16 %bcond_with     lowmem2         # try to reduce build memory usage by disabling unified build (long)
17 #
18 # it's not possible to build this with debuginfo on 32bit archs due to
19 # memory constraints during linking
20 %ifarch %{ix86} x32
21 %define         _enable_debug_packages          0
22 %endif
23 Summary:        Port of WebKit embeddable web component to GTK+ 3
24 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
25 Name:           gtk-webkit4
26 # NOTE: 2.40.x is stable, 2.41.x devel
27 Version:        2.40.1
28 Release:        1
29 License:        BSD-like
30 Group:          X11/Libraries
31 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
32 # Source0-md5:  20aa14992701802a58bb5e333296a963
33 Patch0:         x32.patch
34 Patch1:         %{name}-icu59.patch
35 Patch2:         parallel-gir.patch
36 Patch3:         %{name}-driver-version-suffix.patch
37 Patch4:         %{name}-gcc13.patch
38 URL:            https://webkitgtk.org/
39 BuildRequires:  /usr/bin/ld.gold
40 BuildRequires:  EGL-devel
41 BuildRequires:  OpenGL-GLX-devel
42 BuildRequires:  OpenGLESv2-devel
43 BuildRequires:  at-spi2-core-devel >= 2.5.3
44 BuildRequires:  atk-devel >= 1:2.16.0
45 BuildRequires:  bubblewrap >= 0.3.1
46 BuildRequires:  cairo-devel >= 1.16.0
47 BuildRequires:  cmake >= 3.20
48 BuildRequires:  docbook-dtd412-xml
49 BuildRequires:  enchant2-devel >= 2
50 BuildRequires:  fontconfig-devel >= 2.13.0
51 BuildRequires:  freetype-devel >= 1:2.9.0
52 BuildRequires:  gettext-devel
53 BuildRequires:  gettext-tools
54 BuildRequires:  gi-docgen
55 BuildRequires:  glib2-devel >= 1:2.70.0
56 BuildRequires:  glibc-misc
57 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
58 BuildRequires:  gperf >= 3.0.1
59 BuildRequires:  gstreamer-devel >= 1.14
60 BuildRequires:  gstreamer-gl-devel >= 1.10.0
61 # codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
62 #BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
63 # app,audio,fft,pbutils,tag,video
64 BuildRequires:  gstreamer-plugins-base-devel >= 1.10.0
65 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.22.0}
66 %{?with_gtk4:BuildRequires:     gtk4-devel >= 4.0}
67 BuildRequires:  gtk-doc >= 1.10
68 BuildRequires:  harfbuzz-devel >= 1.4.2
69 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
70 BuildRequires:  hyphen-devel
71 BuildRequires:  lcms2-devel >= 2
72 BuildRequires:  libavif-devel >= 0.9.0
73 BuildRequires:  libepoxy-devel >= 1.4.0
74 BuildRequires:  libgcrypt-devel >= 1.7.0
75 BuildRequires:  libicu-devel >= 61.2
76 BuildRequires:  libjpeg-devel
77 BuildRequires:  libmanette-devel >= 0.2.4
78 BuildRequires:  libnotify-devel
79 BuildRequires:  libpng-devel
80 BuildRequires:  libseccomp-devel
81 BuildRequires:  libsecret-devel
82 %{?with_libsoup2:BuildRequires: libsoup-devel >= 2.54}
83 %{?with_libsoup3:BuildRequires: libsoup3-devel >= 3.0}
84 # -std=c++2a; WebKitCommon.cmake says gcc 9.3.0 is minimum, but 9.5.0 fails to build
85 BuildRequires:  libstdc++-devel >= 6:10
86 BuildRequires:  libtasn1-devel
87 BuildRequires:  libwebp-devel
88 BuildRequires:  libwpe-devel >= 1.3.0
89 BuildRequires:  libxml2-devel >= 1:2.8.0
90 BuildRequires:  libxslt-devel >= 1.1.7
91 BuildRequires:  openjpeg2-devel >= 2.2.0
92 BuildRequires:  pango-devel >= 1:1.32.0
93 BuildRequires:  perl-base >= 1:5.10.0
94 BuildRequires:  pkgconfig
95 BuildRequires:  python >= 1:2.7.0
96 BuildRequires:  rpm-build >= 4.6
97 BuildRequires:  rpmbuild(macros) >= 1.699
98 BuildRequires:  ruby >= 1:2.5
99 BuildRequires:  ruby-modules >= 1:2.5
100 BuildRequires:  sqlite3-devel >= 3
101 BuildRequires:  systemd-devel
102 BuildRequires:  tar >= 1:1.22
103 BuildRequires:  unifdef
104 %if %{with wayland}
105 BuildRequires:  wayland-devel
106 BuildRequires:  wayland-egl-devel
107 BuildRequires:  wayland-protocols >= 1.12
108 %endif
109 BuildRequires:  wpebackend-fdo-devel >= 1.6.0
110 BuildRequires:  woff2-devel >= 1.0.2
111 BuildRequires:  xdg-dbus-proxy
112 BuildRequires:  xorg-lib-libICE-devel
113 BuildRequires:  xorg-lib-libXcomposite-devel
114 BuildRequires:  xorg-lib-libXdamage-devel
115 BuildRequires:  xorg-lib-libXext-devel
116 BuildRequires:  xorg-lib-libXrender-devel
117 BuildRequires:  xorg-lib-libXt-devel
118 BuildRequires:  xz
119 BuildRequires:  zlib-devel
120 Requires:       at-spi2-core-libs >= 2.5.3
121 Requires:       atk >= 1:2.16.0
122 Requires:       cairo >= 1.16.0
123 Requires:       fontconfig-libs >= 2.13.0
124 Requires:       freetype >= 1:2.9.0
125 Requires:       glib2 >= 1:2.70.0
126 Requires:       gstreamer >= 1.2.3
127 Requires:       gstreamer-plugins-base >= 1.2.3
128 Requires:       gtk+3 >= 3.22.0
129 Requires:       harfbuzz >= 1.4.2
130 Requires:       libgcrypt >= 1.7.0
131 Requires:       libsoup >= 2.54
132 Requires:       libwpe >= 1.3.0
133 Requires:       libxml2 >= 1:2.8.0
134 Requires:       libxslt >= 1.1.7
135 Requires:       openjpeg2 >= 2.2.0
136 Requires:       pango >= 1:1.32.0
137 Requires:       woff2 >= 1.0.2
138 Requires:       wpebackend-fdo >= 1.6.0
139 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
140 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
141 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
142 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
143
144 # __once_call, __once_called non-function symbols from libstdc++
145 %define         skip_post_check_so      lib.*gtk-4.0.*
146
147 %description
148 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
149 3.
150
151 %description -l pl.UTF-8
152 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
153
154 %package devel
155 Summary:        Development files for WebKit for GTK+ 3
156 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
157 Group:          X11/Development/Libraries
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       glib2-devel >= 1:2.70.0
160 Requires:       gtk+3-devel >= 3.22.0
161 Requires:       libsoup-devel >= 2.54
162 Requires:       libstdc++-devel >= 6:8.3
163
164 %description devel
165 Development files for WebKit for GTK+ 3.
166
167 %description devel -l pl.UTF-8
168 Pliki programistyczne komponentu WebKit dla GTK+ 3.
169
170 %package apidocs
171 Summary:        API documentation for WebKit GTK+ 3 port
172 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3
173 Group:          Documentation
174 Requires:       gtk-doc-common
175 BuildArch:      noarch
176
177 %description apidocs
178 API documentation for WebKit GTK+ 3 port.
179
180 %description apidocs -l pl.UTF-8
181 Dokumentacja API portu WebKitu do GTK+ 3.
182
183 %package -n gtk-webkit4.1
184 Summary:        Port of WebKit embeddable web component to GTK+ 3 with HTTP/2 support
185 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3 z obsługą HTTP/2
186 Group:          X11/Libraries
187 Requires:       at-spi2-core-libs >= 2.5.3
188 Requires:       atk >= 1:2.16.0
189 Requires:       cairo >= 1.16.0
190 Requires:       fontconfig-libs >= 2.13.0
191 Requires:       freetype >= 1:2.9.0
192 Requires:       glib2 >= 1:2.70.0
193 Requires:       gstreamer >= 1.2.3
194 Requires:       gstreamer-plugins-base >= 1.2.3
195 Requires:       gtk+3 >= 3.22.0
196 Requires:       harfbuzz >= 1.4.2
197 Requires:       libgcrypt >= 1.7.0
198 Requires:       libsoup3 >= 3.0
199 Requires:       libwpe >= 1.3.0
200 Requires:       libxml2 >= 1:2.8.0
201 Requires:       libxslt >= 1.1.7
202 Requires:       openjpeg2 >= 2.2.0
203 Requires:       pango >= 1:1.32.0
204 Requires:       woff2 >= 1.0.2
205 Requires:       wpebackend-fdo >= 1.6.0
206
207 %description -n gtk-webkit4.1
208 gtk-webkit4.1 is a port of the WebKit embeddable web component to GTK+
209 3 with HTTP/2 (libsoup 3) support.
210
211 %description -n gtk-webkit4.1 -l pl.UTF-8
212 gtk-webkit4.1 to port osadzalnego komponentu WWW WebKit do GTK+ 3 z
213 obsługą HTTP/2 (libsoup 3).
214
215 %package -n gtk-webkit4.1-devel
216 Summary:        Development files for WebKit for GTK+ 3 with HTTP/2 support
217 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2
218 Group:          X11/Development/Libraries
219 Requires:       gtk-webkit4.1 = %{version}-%{release}
220 Requires:       glib2-devel >= 1:2.70.0
221 Requires:       gtk+3-devel >= 3.22.0
222 Requires:       libsoup3-devel >= 3.0
223 Requires:       libstdc++-devel >= 6:8.3
224
225 %description -n gtk-webkit4.1-devel
226 Development files for WebKit for GTK+ 3 with HTTP/2 support.
227
228 %description -n gtk-webkit4.1-devel -l pl.UTF-8
229 Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2.
230
231 %package -n gtk-webkit4.1-apidocs
232 Summary:        API documentation for WebKit GTK+ 3 port with HTTP/2 support
233 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2
234 Group:          Documentation
235 Requires:       gtk-doc-common
236 BuildArch:      noarch
237
238 %description -n gtk-webkit4.1-apidocs
239 API documentation for WebKit GTK+ 3 port with HTTP/2 support.
240
241 %description -n gtk-webkit4.1-apidocs -l pl.UTF-8
242 Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2.
243
244 %package -n gtk-webkit6
245 Summary:        Port of WebKit embeddable web component to GTK 4
246 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK 4
247 Group:          X11/Libraries
248 Requires:       at-spi2-core-libs >= 2.5.3
249 Requires:       atk >= 1:2.16.0
250 Requires:       cairo >= 1.16.0
251 Requires:       fontconfig-libs >= 2.13.0
252 Requires:       freetype >= 1:2.9.0
253 Requires:       glib2 >= 1:2.70.0
254 Requires:       gstreamer >= 1.2.3
255 Requires:       gstreamer-plugins-base >= 1.2.3
256 Requires:       gtk4 >= 4.0
257 Requires:       harfbuzz >= 1.4.2
258 Requires:       libgcrypt >= 1.7.0
259 Requires:       libsoup3 >= 3.0
260 Requires:       libwpe >= 1.3.0
261 Requires:       libxml2 >= 1:2.8.0
262 Requires:       libxslt >= 1.1.7
263 Requires:       openjpeg2 >= 2.2.0
264 Requires:       pango >= 1:1.32.0
265 Requires:       woff2 >= 1.0.2
266 Requires:       wpebackend-fdo >= 1.6.0
267
268 %description -n gtk-webkit6
269 gtk-webkit6 is a port of the WebKit embeddable web component to GTK 4.
270
271 %description -n gtk-webkit6 -l pl.UTF-8
272 gtk-webkit6 to port osadzalnego komponentu WWW WebKit do GTK+ 4.
273
274 %package -n gtk-webkit6-devel
275 Summary:        Development files for WebKit for GTK 4
276 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK 4
277 Group:          X11/Development/Libraries
278 Requires:       gtk-webkit6 = %{version}-%{release}
279 Requires:       glib2-devel >= 1:2.70.0
280 Requires:       gtk4-devel >= 4.0
281 Requires:       libsoup3-devel >= 3.0
282 Requires:       libstdc++-devel >= 6:8.3
283
284 %description -n gtk-webkit6-devel
285 Development files for WebKit for GTK 4.
286
287 %description -n gtk-webkit6-devel -l pl.UTF-8
288 Pliki programistyczne komponentu WebKit dla GTK 4.
289
290 %package -n gtk-webkit6-apidocs
291 Summary:        API documentation for WebKit GTK 4 port
292 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK 4
293 Group:          Documentation
294 Requires:       gtk-doc-common
295 BuildArch:      noarch
296
297 %description -n gtk-webkit6-apidocs
298 API documentation for WebKit GTK 4 port.
299
300 %description -n gtk-webkit6-apidocs -l pl.UTF-8
301 Dokumentacja API portu WebKitu do GTK 4.
302
303 %prep
304 %setup -q -n webkitgtk-%{version}
305 %patch0 -p1
306 %patch1 -p1
307 %patch2 -p1
308 %patch3 -p1
309 %patch4 -p1
310
311 %build
312 %if %{with lowmem}
313 CXXFLAGS="%{rpmcxxflags} --param ggc-min-expand=20 --param ggc-min-heapsize=65536"
314 %endif
315 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
316 %cmake -B build-${kind} \
317         -DENABLE_GEOLOCATION=ON \
318         -DENABLE_GTKDOC=ON \
319         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
320         %{?with_lowmem2:-DENABLE_UNIFIED_BUILDS=OFF} \
321         -DENABLE_VIDEO=ON \
322         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
323         -DENABLE_WEB_AUDIO=ON \
324         -DENABLE_WEBGL=ON \
325 %ifarch x32
326         -DENABLE_C_LOOP=ON \
327         -DENABLE_JIT=OFF \
328         -DENABLE_SAMPLING_PROFILER=OFF \
329 %endif
330 %ifarch %{ix86} %{x8664} x32
331         -DHAVE_SSE2_EXTENSIONS=ON \
332 %endif
333         -DPORT=GTK \
334         -DSHOULD_INSTALL_JS_SHELL=ON \
335         $([ "$kind" = "gtk4" ] && echo -DUSE_GTK4=ON) \
336         $([ "$kind" = "soup2" ] && echo -DUSE_SOUP2=ON)
337
338 %{__make} -C build-${kind}
339 done
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343
344 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
345 %{__make} -C build-${kind} install \
346         DESTDIR=$RPM_BUILD_ROOT
347 done
348
349 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
350 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
351 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
352 %endif
353
354 %{?with_gtk3:%{?with_libsoup2:%find_lang WebKitGTK-4.0}}
355 %{?with_gtk3:%{?with_libsoup3:%find_lang WebKitGTK-4.1}}
356 %{?with_gtk4:%find_lang WebKitGTK-6.0}
357
358 %clean
359 rm -rf $RPM_BUILD_ROOT
360
361 %post   -p /sbin/ldconfig
362 %postun -p /sbin/ldconfig
363
364 %post   -n gtk-webkit4.1 -p /sbin/ldconfig
365 %postun -n gtk-webkit4.1 -p /sbin/ldconfig
366
367 %post   -n gtk-webkit6 -p /sbin/ldconfig
368 %postun -n gtk-webkit6 -p /sbin/ldconfig
369
370 %if %{with gtk3} && %{with libsoup2}
371 %files -f WebKitGTK-4.0.lang
372 %defattr(644,root,root,755)
373 %doc NEWS
374 %attr(755,root,root) %{_bindir}/WebKitWebDriver-4.0
375 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
376 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
377 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
378 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
379 %if %{with introspection}
380 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
381 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
382 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
383 %endif
384 %if "%{_libexecdir}" != "%{_libdir}"
385 %dir %{_libexecdir}/webkit2gtk-4.0
386 %endif
387 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/MiniBrowser
388 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
389 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
390 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
391 %dir %{_libdir}/webkit2gtk-4.0
392 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
393 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
394
395 %files devel
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
398 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
399 %if %{with introspection}
400 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
401 %{_datadir}/gir-1.0/WebKit2-4.0.gir
402 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
403 %endif
404 %{_includedir}/webkitgtk-4.0
405 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
406 %{_pkgconfigdir}/webkit2gtk-4.0.pc
407 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
408
409 %files apidocs
410 %defattr(644,root,root,755)
411 %{_gtkdocdir}/javascriptcoregtk-4.0
412 %{_gtkdocdir}/webkit2gtk-4.0
413 %{_gtkdocdir}/webkit2gtk-web-extension-4.0
414 %endif
415
416 %if %{with gtk3} && %{with libsoup3}
417 %files -n gtk-webkit4.1 -f WebKitGTK-4.1.lang
418 %defattr(644,root,root,755)
419 %doc NEWS
420 %attr(755,root,root) %{_bindir}/WebKitWebDriver-4.1
421 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.1.so.0
423 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.1.so.0
425 %if %{with introspection}
426 %{_libdir}/girepository-1.0/JavaScriptCore-4.1.typelib
427 %{_libdir}/girepository-1.0/WebKit2-4.1.typelib
428 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.1.typelib
429 %endif
430 %if "%{_libexecdir}" != "%{_libdir}"
431 %dir %{_libexecdir}/webkit2gtk-4.1
432 %endif
433 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/MiniBrowser
434 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitNetworkProcess
435 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitWebProcess
436 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/jsc
437 %dir %{_libdir}/webkit2gtk-4.1
438 %dir %{_libdir}/webkit2gtk-4.1/injected-bundle
439 %attr(755,root,root) %{_libdir}/webkit2gtk-4.1/injected-bundle/libwebkit2gtkinjectedbundle.so
440
441 %files -n gtk-webkit4.1-devel
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so
444 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so
445 %if %{with introspection}
446 %{_datadir}/gir-1.0/JavaScriptCore-4.1.gir
447 %{_datadir}/gir-1.0/WebKit2-4.1.gir
448 %{_datadir}/gir-1.0/WebKit2WebExtension-4.1.gir
449 %endif
450 %{_includedir}/webkitgtk-4.1
451 %{_pkgconfigdir}/javascriptcoregtk-4.1.pc
452 %{_pkgconfigdir}/webkit2gtk-4.1.pc
453 %{_pkgconfigdir}/webkit2gtk-web-extension-4.1.pc
454
455 %files -n gtk-webkit4.1-apidocs
456 %defattr(644,root,root,755)
457 %{_gtkdocdir}/javascriptcoregtk-4.1
458 %{_gtkdocdir}/webkit2gtk-4.1
459 %{_gtkdocdir}/webkit2gtk-web-extension-4.1
460 %endif
461
462 %if %{with gtk4}
463 %files -n gtk-webkit6 -f WebKitGTK-6.0.lang
464 %defattr(644,root,root,755)
465 %doc NEWS
466 %attr(755,root,root) %{_bindir}/WebKitWebDriver-6.0
467 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-6.0.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-6.0.so.1
469 %attr(755,root,root) %{_libdir}/libwebkitgtk-6.0.so.*.*.*
470 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-6.0.so.4
471 %if %{with introspection}
472 %{_libdir}/girepository-1.0/JavaScriptCore-6.0.typelib
473 %{_libdir}/girepository-1.0/WebKit-6.0.typelib
474 %{_libdir}/girepository-1.0/WebKitWebProcessExtension-6.0.typelib
475 %endif
476 %if "%{_libexecdir}" != "%{_libdir}"
477 %dir %{_libexecdir}/webkitgtk-6.0
478 %endif
479 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/MiniBrowser
480 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/WebKitNetworkProcess
481 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/WebKitWebProcess
482 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/jsc
483 %dir %{_libdir}/webkitgtk-6.0
484 %dir %{_libdir}/webkitgtk-6.0/injected-bundle
485 %attr(755,root,root) %{_libdir}/webkitgtk-6.0/injected-bundle/libwebkitgtkinjectedbundle.so
486
487 %files -n gtk-webkit6-devel
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/libwebkitgtk-6.0.so
490 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-6.0.so
491 %if %{with introspection}
492 %{_datadir}/gir-1.0/JavaScriptCore-6.0.gir
493 %{_datadir}/gir-1.0/WebKit-6.0.gir
494 %{_datadir}/gir-1.0/WebKitWebProcessExtension-6.0.gir
495 %endif
496 %{_includedir}/webkitgtk-6.0
497 %{_pkgconfigdir}/javascriptcoregtk-6.0.pc
498 %{_pkgconfigdir}/webkitgtk-6.0.pc
499 %{_pkgconfigdir}/webkitgtk-web-process-extension-6.0.pc
500
501 %files -n gtk-webkit6-apidocs
502 %defattr(644,root,root,755)
503 %{_gtkdocdir}/javascriptcoregtk-6.0
504 %{_gtkdocdir}/webkitgtk-6.0
505 %{_gtkdocdir}/webkitgtk-web-process-extension-6.0
506 %endif
This page took 0.086483 seconds and 2 git commands to generate.