]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
4bc259f3cdeda76bcbe75e2650dd4812b117f194
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
4 # - GAMEPAD? (BR: libmanette-devel >= 0.2.4)
5 #
6 # Conditional build:
7 %bcond_without  introspection   # disable introspection
8 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
9 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
10 #
11 # it's not possible to build this with debuginfo on 32bit archs due to
12 # memory constraints during linking
13 %ifarch %{ix86} x32
14 %define         _enable_debug_packages          0
15 %endif
16 Summary:        Port of WebKit embeddable web component to GTK+ 3
17 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
18 Name:           gtk-webkit4
19 # NOTE: 2.30.x is stable, 2.31.x devel
20 Version:        2.30.0
21 Release:        1
22 License:        BSD-like
23 Group:          X11/Libraries
24 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
25 # Source0-md5:  71428fefd33f40583465649baf05ceb5
26 Patch0:         x32.patch
27 Patch1:         %{name}-icu59.patch
28 Patch2:         %{name}-gir.patch
29 URL:            https://webkitgtk.org/
30 BuildRequires:  /usr/bin/ld.gold
31 BuildRequires:  EGL-devel
32 BuildRequires:  OpenGL-GLX-devel
33 BuildRequires:  OpenGLESv2-devel
34 BuildRequires:  at-spi2-core-devel >= 2.5.3
35 BuildRequires:  atk-devel >= 1:2.16.0
36 BuildRequires:  bubblewrap >= 0.3.1
37 BuildRequires:  cairo-devel >= 1.16.0
38 BuildRequires:  cmake >= 3.10
39 BuildRequires:  docbook-dtd412-xml
40 BuildRequires:  enchant2-devel >= 2
41 BuildRequires:  fontconfig-devel >= 2.13.0
42 BuildRequires:  freetype-devel >= 1:2.9.0
43 BuildRequires:  gcc-c++ >= 6:7.3.0
44 BuildRequires:  gettext-devel
45 BuildRequires:  glib2-devel >= 1:2.44
46 BuildRequires:  glibc-misc
47 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
48 BuildRequires:  gperf >= 3.0.1
49 BuildRequires:  gstreamer-devel >= 1.14
50 BuildRequires:  gstreamer-gl-devel >= 1.10.0
51 # codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
52 #BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
53 # app,audio,fft,pbutils,tag,video
54 BuildRequires:  gstreamer-plugins-base-devel >= 1.10.0
55 BuildRequires:  gtk+3-devel >= 3.22.0
56 BuildRequires:  gtk-doc >= 1.10
57 BuildRequires:  harfbuzz-devel >= 1.4.2
58 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
59 BuildRequires:  hyphen-devel
60 BuildRequires:  libgcrypt-devel >= 1.7.0
61 BuildRequires:  libicu-devel >= 60.2
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libnotify-devel
64 BuildRequires:  libpng-devel
65 BuildRequires:  libsecret-devel
66 BuildRequires:  libsoup-devel >= 2.54
67 BuildRequires:  libstdc++-devel >= 6:7.3.0
68 BuildRequires:  libtasn1-devel
69 BuildRequires:  libwebp-devel
70 BuildRequires:  libwpe-devel >= 1.3.0
71 BuildRequires:  libxml2-devel >= 1:2.8.0
72 BuildRequires:  libxslt-devel >= 1.1.7
73 BuildRequires:  openjpeg2-devel >= 2.2.0
74 BuildRequires:  pango-devel >= 1:1.32.0
75 BuildRequires:  perl-base >= 1:5.10.0
76 BuildRequires:  pkgconfig
77 %if %{with cairogl}
78 BuildRequires:  pkgconfig(cairo-egl) >= 1.10.2
79 BuildRequires:  pkgconfig(cairo-gl) >= 1.10.2
80 BuildRequires:  pkgconfig(cairo-glx) >= 1.10.2
81 %endif
82 BuildRequires:  python >= 1:2.7.0
83 BuildRequires:  rpmbuild(macros) >= 1.699
84 BuildRequires:  ruby >= 1:1.9
85 BuildRequires:  ruby-modules >= 1:1.9
86 BuildRequires:  sqlite3-devel >= 3
87 BuildRequires:  tar >= 1:1.22
88 %if %{with wayland}
89 BuildRequires:  wayland-devel
90 BuildRequires:  wayland-egl-devel
91 BuildRequires:  wayland-protocols >= 1.12
92 %endif
93 BuildRequires:  wpebackend-fdo-devel >= 1.4.0
94 BuildRequires:  woff2-devel >= 1.0.2
95 BuildRequires:  xdg-dbus-proxy
96 BuildRequires:  xorg-lib-libICE-devel
97 BuildRequires:  xorg-lib-libXcomposite-devel
98 BuildRequires:  xorg-lib-libXdamage-devel
99 BuildRequires:  xorg-lib-libXext-devel
100 BuildRequires:  xorg-lib-libXrender-devel
101 BuildRequires:  xorg-lib-libXt-devel
102 BuildRequires:  xz
103 BuildRequires:  zlib-devel
104 Requires:       at-spi2-core-libs >= 2.5.3
105 Requires:       atk >= 1:2.16.0
106 Requires:       cairo >= 1.16.0
107 Requires:       fontconfig-libs >= 2.13.0
108 Requires:       freetype >= 1:2.9.0
109 Requires:       glib2 >= 1:2.44
110 Requires:       gstreamer >= 1.2.3
111 Requires:       gstreamer-plugins-base >= 1.2.3
112 Requires:       gtk+3 >= 3.22.0
113 Requires:       harfbuzz >= 1.4.2
114 Requires:       libgcrypt >= 1.7.0
115 Requires:       libsoup >= 2.54
116 Requires:       libxml2 >= 1:2.8.0
117 Requires:       libxslt >= 1.1.7
118 Requires:       openjpeg2 >= 2.2.0
119 Requires:       pango >= 1:1.32.0
120 Requires:       woff2 >= 1.0.2
121 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
122 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
123 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 # __once_call, __once_called non-function symbols from libstdc++
127 %define         skip_post_check_so      lib.*gtk-4.0.*
128
129 %description
130 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
131 3.
132
133 %description -l pl.UTF-8
134 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
135
136 %package devel
137 Summary:        Development files for WebKit for GTK+ 3
138 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
139 Group:          X11/Development/Libraries
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       glib2-devel >= 1:2.44
142 Requires:       gtk+3-devel >= 3.22.0
143 Requires:       libsoup-devel >= 2.54
144 Requires:       libstdc++-devel >= 6:7.3.0
145
146 %description devel
147 Development files for WebKit for GTK+ 3.
148
149 %description devel -l pl.UTF-8
150 Pliki programistyczne komponentu WebKit dla GTK+ 3.
151
152 %package apidocs
153 Summary:        WebKit API documentation
154 Summary(pl.UTF-8):      Dokumentacja API WebKita
155 Group:          Documentation
156 Requires:       gtk-doc-common
157 BuildArch:      noarch
158
159 %description apidocs
160 WebKit API documentation.
161
162 %description apidocs -l pl.UTF-8
163 Dokumentacja API WebKita.
164
165 %prep
166 %setup -q -n webkitgtk-%{version}
167 %patch0 -p1
168 %patch1 -p1
169 %patch2 -p1
170
171 %build
172 install -d build
173 cd build
174 %cmake .. \
175         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
176         -DENABLE_GEOLOCATION=ON \
177         -DENABLE_GTKDOC=ON \
178         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
179         -DENABLE_NETSCAPE_PLUGIN_API=ON \
180         -DENABLE_VIDEO=ON \
181         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
182         -DENABLE_WEB_AUDIO=ON \
183         -DENABLE_WEBGL=ON \
184 %ifarch x32
185         -DENABLE_C_LOOP=ON \
186         -DENABLE_JIT=OFF \
187         -DENABLE_SAMPLING_PROFILER=OFF \
188 %endif
189 %ifarch %{ix86} %{x8664} x32
190         -DHAVE_SSE2_EXTENSIONS=ON \
191 %endif
192         -DPORT=GTK \
193         -DSHOULD_INSTALL_JS_SHELL=ON
194
195 %{__make}
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199
200 %{__make} -C build install \
201         DESTDIR=$RPM_BUILD_ROOT
202
203 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
204 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
205 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
206 %endif
207
208 %find_lang WebKit2GTK-4.0
209
210 %clean
211 rm -rf $RPM_BUILD_ROOT
212
213 %post   -p /sbin/ldconfig
214 %postun -p /sbin/ldconfig
215
216 %files -f WebKit2GTK-4.0.lang
217 %defattr(644,root,root,755)
218 %doc NEWS
219 %attr(755,root,root) %{_bindir}/WebKitWebDriver
220 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
221 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
222 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
223 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
224 %if %{with introspection}
225 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
226 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
227 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
228 %endif
229 %if "%{_libexecdir}" != "%{_libdir}"
230 %dir %{_libexecdir}/webkit2gtk-4.0
231 %endif
232 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
233 #%attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitPluginProcess
234 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
235 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
236 %dir %{_libdir}/webkit2gtk-4.0
237 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
238 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
239
240 %files devel
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
243 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
244 %if %{with introspection}
245 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
246 %{_datadir}/gir-1.0/WebKit2-4.0.gir
247 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
248 %endif
249 %{_includedir}/webkitgtk-4.0
250 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
251 %{_pkgconfigdir}/webkit2gtk-4.0.pc
252 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
253
254 %files apidocs
255 %defattr(644,root,root,755)
256 %{_gtkdocdir}/jsc-glib-4.0
257 %{_gtkdocdir}/webkit2gtk-4.0
258 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.092658 seconds and 2 git commands to generate.