]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
0b6b6013a4aad4fc475df734f9a973b856f1465c
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - BATTERY_STATUS (BR: upower-devel)
3 # - FTL_JIT on !x86_64?
4 # - MEDIA_STREAM (BR: openwebrtc)
5 #
6 # Conditional build:
7 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
8 %bcond_without  introspection   # disable introspection
9 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
10 %bcond_with     seccomp         # seccomp filters (broken as of 2.6.5)
11 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
12 #
13 # it's not possible to build this with debuginfo on 32bit archs due to
14 # memory constraints during linking
15 %ifarch %{ix86} x32
16 %define         _enable_debug_packages          0
17 %endif
18 Summary:        Port of WebKit embeddable web component to GTK+ 3
19 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
20 Name:           gtk-webkit4
21 Version:        2.14.5
22 Release:        2
23 License:        BSD-like
24 Group:          X11/Libraries
25 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
26 # Source0-md5:  7fe3cb2699e64f969b285823c5ae2516
27 Patch0:         x32.patch
28 URL:            https://webkitgtk.org/
29 BuildRequires:  /usr/bin/ld.gold
30 BuildRequires:  EGL-devel
31 BuildRequires:  OpenGL-GLX-devel
32 BuildRequires:  OpenGLESv2-devel
33 BuildRequires:  at-spi2-core-devel >= 2.6.0
34 BuildRequires:  atk-devel
35 BuildRequires:  bison >= 2.3
36 BuildRequires:  cairo-devel >= 1.10.2
37 BuildRequires:  cmake >= 2.8.12
38 BuildRequires:  docbook-dtd412-xml
39 BuildRequires:  enchant-devel >= 0.22
40 BuildRequires:  flex >= 2.5.34
41 BuildRequires:  fontconfig-devel >= 2.8.0
42 BuildRequires:  freetype-devel >= 1:2.4.2
43 BuildRequires:  gcc-c++ >= 6:4.9
44 BuildRequires:  geoclue2-devel >= 2.1.5
45 BuildRequires:  gettext-devel
46 BuildRequires:  glib2-devel >= 1:2.36.0
47 BuildRequires:  glibc-misc
48 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
49 BuildRequires:  gperf >= 3.0.1
50 BuildRequires:  gstreamer-devel >= 1.0.3
51 BuildRequires:  gstreamer-plugins-bad-devel >= 1.6.0
52 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
53 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
54 BuildRequires:  gtk+3-devel >= 3.12.0
55 BuildRequires:  gtk-doc >= 1.10
56 BuildRequires:  harfbuzz-devel >= 0.9.7
57 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
58 BuildRequires:  hyphen-devel
59 BuildRequires:  libicu-devel >= 4.2.1
60 BuildRequires:  libjpeg-devel
61 BuildRequires:  libnotify-devel
62 BuildRequires:  libpng-devel
63 BuildRequires:  libsecret-devel
64 BuildRequires:  libsoup-devel >= 2.42.0
65 BuildRequires:  libstdc++-devel >= 6:4.9
66 BuildRequires:  libwebp-devel
67 BuildRequires:  libxml2-devel >= 1:2.8.0
68 BuildRequires:  libxslt-devel >= 1.1.7
69 BuildRequires:  pango-devel >= 1:1.32.0
70 BuildRequires:  perl-base >= 1:5.10.0
71 BuildRequires:  pkgconfig
72 %if %{with cairogl}
73 BuildRequires:  pkgconfig(cairo-egl)
74 BuildRequires:  pkgconfig(cairo-gl)
75 BuildRequires:  pkgconfig(cairo-glx)
76 %endif
77 BuildRequires:  python >= 1:2.7.0
78 BuildRequires:  rpmbuild(macros) >= 1.699
79 BuildRequires:  ruby >= 1:1.9
80 BuildRequires:  ruby-modules >= 1:1.9
81 BuildRequires:  sqlite3-devel >= 3
82 BuildRequires:  tar >= 1:1.22
83 BuildRequires:  xorg-lib-libXcomposite-devel
84 BuildRequires:  xorg-lib-libXdamage-devel
85 BuildRequires:  xorg-lib-libXrender-devel
86 BuildRequires:  xorg-lib-libXt-devel
87 BuildRequires:  xz
88 BuildRequires:  zlib-devel
89 Requires:       cairo >= 1.10.2
90 Requires:       enchant >= 0.22
91 Requires:       fontconfig-libs >= 2.8.0
92 Requires:       freetype >= 1:2.4.2
93 Requires:       glib2 >= 1:2.36.0
94 Requires:       gstreamer >= 1.0.3
95 Requires:       gstreamer-plugins-base >= 1.0.3
96 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
97 Requires:       gtk+3 >= 3.12.0
98 Requires:       harfbuzz >= 0.9.7
99 Requires:       libsoup >= 2.42.0
100 Requires:       libxml2 >= 1:2.8.0
101 Requires:       libxslt >= 1.1.7
102 Requires:       pango >= 1:1.32.0
103 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
104 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
105 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 # __once_call, __once_called non-function symbols from libstdc++
109 %define         skip_post_check_so      lib.*gtk-4.0.*
110
111 %description
112 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
113 3.
114
115 %description -l pl.UTF-8
116 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
117
118 %package devel
119 Summary:        Development files for WebKit for GTK+ 3
120 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
121 Group:          X11/Development/Libraries
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       glib2-devel >= 1:2.36.0
124 Requires:       gtk+3-devel >= 3.12.0
125 Requires:       libsoup-devel >= 2.42.0
126 Requires:       libstdc++-devel >= 6:4.9
127
128 %description devel
129 Development files for WebKit for GTK+ 3.
130
131 %description devel -l pl.UTF-8
132 Pliki programistyczne komponentu WebKit dla GTK+ 3.
133
134 %package apidocs
135 Summary:        WebKit API documentation
136 Summary(pl.UTF-8):      Dokumentacja API WebKita
137 Group:          Documentation
138 Requires:       gtk-doc-common
139 %if "%{_rpmversion}" >= "5"
140 BuildArch:      noarch
141 %endif
142
143 %description apidocs
144 WebKit API documentation.
145
146 %description apidocs -l pl.UTF-8
147 Dokumentacja API WebKita.
148
149 %prep
150 %setup -q -n webkitgtk-%{version}
151 %patch0 -p1
152
153 %build
154 install -d build
155 cd build
156 %cmake .. \
157         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
158         -DENABLE_CREDENTIAL_STORAGE=ON \
159         -DENABLE_GEOLOCATION=ON \
160         -DENABLE_GTKDOC=ON \
161         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
162         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
163         %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
164         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
165 %ifarch x32
166         -DENABLE_JIT=OFF \
167 %endif
168         -DENABLE_VIDEO=ON \
169         -DENABLE_WEB_AUDIO=ON \
170         -DENABLE_WEBGL=ON \
171         -DPORT=GTK \
172         -DSHOULD_INSTALL_JS_SHELL=ON
173
174 %{__make}
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178
179 %{__make} -C build install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
183 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
184 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
185 %endif
186
187 %find_lang WebKit2GTK-4.0
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post   -p /sbin/ldconfig
193 %postun -p /sbin/ldconfig
194
195 %files -f WebKit2GTK-4.0.lang
196 %defattr(644,root,root,755)
197 %doc NEWS
198 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
200 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
202 %if %{with introspection}
203 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
204 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
205 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
206 %endif
207 %dir %{_libdir}/webkit2gtk-4.0
208 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitDatabaseProcess
209 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitNetworkProcess
210 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess
211 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess2
212 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitWebProcess
213 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/jsc
214 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
215 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
220 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
221 %if %{with introspection}
222 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
223 %{_datadir}/gir-1.0/WebKit2-4.0.gir
224 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
225 %endif
226 %{_includedir}/webkitgtk-4.0
227 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
228 %{_pkgconfigdir}/webkit2gtk-4.0.pc
229 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
230
231 %files apidocs
232 %defattr(644,root,root,755)
233 %{_gtkdocdir}/webkit2gtk-4.0
234 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.125631 seconds and 2 git commands to generate.