]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- release 2 (by relup.sh)
[packages/gtk-webkit.git] / gtk-webkit.spec
1 # TODO: optflags
2 #
3 # Conditional build:
4 %bcond_without  introspection   # disable introspection
5 #
6 Summary:        Port of WebKit embeddable web component to GTK+
7 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
8 Name:           gtk-webkit
9 Version:        1.8.2
10 Release:        2
11 License:        BSD-like
12 Group:          X11/Libraries
13 Source0:        http://webkitgtk.org/releases/webkit-%{version}.tar.xz
14 # Source0-md5:  f7bd0bd4f323039f15e19c82a9a8313c
15 Patch0:         %{name}-am.patch
16 Patch1:         %{name}-bison2.6.patch
17 URL:            http://webkitgtk.org/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  OpenGL-GLX-devel
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 BuildRequires:  bison >= 1.875
23 BuildRequires:  cairo-devel >= 1.10
24 BuildRequires:  cairo-gobject-devel >= 1.10
25 BuildRequires:  enchant-devel >= 0.22
26 BuildRequires:  flex >= 2.5.33
27 BuildRequires:  fontconfig-devel >= 2.4.0
28 BuildRequires:  freetype-devel >= 1:2.1.8
29 BuildRequires:  geoclue-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  glib2-devel >= 1:2.32.0
32 BuildRequires:  glibc-misc
33 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.5}
34 BuildRequires:  gperf
35 BuildRequires:  gstreamer-devel >= 0.10
36 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
37 BuildRequires:  gtk+2-devel >= 2:2.20.0
38 BuildRequires:  gtk-doc >= 1.10
39 BuildRequires:  libicu-devel >= 4.2.1
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libsoup-devel >= 2.38
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 2:1.5
45 BuildRequires:  libxml2-devel >= 1:2.6.30
46 BuildRequires:  libxslt-devel >= 1.1.7
47 BuildRequires:  pango-devel >= 1:1.21
48 BuildRequires:  pkgconfig
49 BuildRequires:  sqlite3-devel >= 3
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xorg-lib-libXrender-devel
52 BuildRequires:  xorg-lib-libXt-devel
53 BuildRequires:  xz
54 BuildRequires:  zlib-devel
55 Requires:       cairo >= 1.10
56 Requires:       enchant >= 0.22
57 Requires:       glib2 >= 1:2.32.0
58 Requires:       gstreamer-plugins-base >= 0.10.30
59 Requires:       gtk+2 >= 2:2.20.0
60 Requires:       libsoup >= 2.38
61 Requires:       libxml2 >= 1:2.6.30
62 Requires:       libxslt >= 1.1.7
63 Requires:       pango >= 1:1.21
64 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 webkit is a port of the WebKit embeddable web component to GTK+.
69
70 %description -l pl.UTF-8
71 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
72
73 %package devel
74 Summary:        Development files for WebKit
75 Summary(pl.UTF-8):      Pliki programistyczne WebKit
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       cairo-devel >= 1.10
79 Requires:       enchant-devel >= 0.22
80 Requires:       fontconfig-devel >= 2.4.0
81 Requires:       freetype-devel >= 1:2.1.8
82 Requires:       geoclue-devel
83 Requires:       glib2-devel >= 1:2.32.0
84 Requires:       gstreamer-devel >= 0.10
85 Requires:       gstreamer-plugins-base-devel >= 0.10.30
86 Requires:       gtk+2-devel >= 2:2.20.0
87 Requires:       libicu-devel >= 4.2.1
88 Requires:       libjpeg-devel
89 Requires:       libpng-devel
90 Requires:       libsoup-devel >= 2.38
91 Requires:       libstdc++-devel
92 Requires:       libxml2-devel >= 1:2.6.30
93 Requires:       libxslt-devel >= 1.1.7
94 Requires:       pango-devel >= 1:1.21
95 Requires:       sqlite3-devel >= 3
96 Requires:       xorg-lib-libXt-devel
97
98 %description devel
99 Development files for WebKit.
100
101 %description devel -l pl.UTF-8
102 Pliki programistyczne WebKit.
103
104 %prep
105 %setup -q -n webkit-%{version}
106 %patch0 -p1
107 %patch1 -p2
108
109 %build
110 %{__gtkdocize}
111 %{__libtoolize}
112 %{__aclocal} -I Source/autotools
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-silent-rules \
118         --enable-geolocation \
119         --enable-gtk-doc \
120         --enable-icon-database \
121         --enable-introspection%{!?with_introspection:=no} \
122         --enable-video \
123         --with-font-backend=freetype \
124         --with-gtk=2.0 \
125         --with-html-dir=%{_gtkdocdir}
126
127 %{__make} -j1
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 # obsoleted by pkg-config
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
137 # packaged in gtk-webkit3
138 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/webkitgtk
139
140 %find_lang webkit-2.0
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f webkit-2.0.lang
149 %defattr(644,root,root,755)
150 %doc ChangeLog NEWS 
151 %attr(755,root,root) %{_bindir}/jsc-1
152 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
154 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
156 %if %{with introspection}
157 %{_libdir}/girepository-1.0/JSCore-1.0.typelib
158 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
159 %endif
160 %dir %{_datadir}/webkitgtk-1.0
161 %{_datadir}/webkitgtk-1.0/images
162 %{_datadir}/webkitgtk-1.0/resources
163 %{_datadir}/webkitgtk-1.0/webinspector
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
168 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
169 %if %{with introspection}
170 %{_datadir}/gir-1.0/JSCore-1.0.gir
171 %{_datadir}/gir-1.0/WebKit-1.0.gir
172 %endif
173 %{_includedir}/webkitgtk-1.0
174 %{_pkgconfigdir}/javascriptcoregtk-1.0.pc
175 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.108776 seconds and 3 git commands to generate.