]> git.pld-linux.org Git - packages/gtk-layer-shell.git/blob - gtk-layer-shell.spec
up to 0.8.0
[packages/gtk-layer-shell.git] / gtk-layer-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  vala    # Vala API
5
6 Summary:        Library to create components for Wayland using the Layer Shell
7 Summary(pl.UTF-8):      Biblioteka do tworzenia komponentów Waylanda przy użyciu protokołu Layer Shell
8 Name:           gtk-layer-shell
9 Version:        0.8.0
10 Release:        1
11 License:        LGPL v3+, MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/wmww/gtk-layer-shell/releases
14 Source0:        https://github.com/wmww/gtk-layer-shell/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  64a5a6a0128ec20d441c01be1d112687
16 URL:            https://github.com/wmww/gtk-layer-shell
17 BuildRequires:  gcc >= 6:4.7
18 BuildRequires:  gtk+3-devel >= 3.22.0
19 %{?with_apidocs:BuildRequires:  gtk-doc}
20 BuildRequires:  meson >= 0.45.1
21 BuildRequires:  ninja >= 1.5
22 BuildRequires:  pkgconfig
23 BuildRequires:  python3 >= 1:3
24 BuildRequires:  rpm-build >= 4.6
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  wayland-devel >= 1.10.0
27 BuildRequires:  wayland-protocols >= 1.16
28 %{?with_vala:BuildRequires:     vala}
29 Requires:       gtk+3 >= 3.22.0
30 Requires:       wayland >= 1.10.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A library to write GTK applications that use Layer Shell. Layer Shell
35 is a Wayland protocol for desktop shell components, such as panels,
36 notifications and wallpapers. You can use it to anchor your windows to
37 a corner or edge of the output, or stretch them across the entire
38 output. This library only makes sense on Wayland compositors that
39 support Layer Shell, and will not work on X11. It supports all Layer
40 Shell features including popups and popovers (GTK popups Just Work
41 (TM)).
42
43 %description -l pl.UTF-8
44 Biblioteka do tworzenia aplikacji GTK, wykorzystujących protokół Layer
45 Shell. Jest to protokół Wayland dla komponentów powłok graficznych,
46 takich jak panele, powiadomienia i tapety. Można go używać do
47 zakotwiczania okien w roku lub przy brzegu wyjścia, albo rozciągania
48 ich na całe wyjście. Biblioteka ma sens tylko dla zarządców składania
49 Wayland obsługujących protokół Layer Shell, nie będzie działać na X11.
50 Obsługuje wszystkie możliwości protokołu Layer Shell, w tym
51 wyskakujące okna.
52
53 %package devel
54 Summary:        Header files for gtk-layer-shell library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gtk-layer-shell
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       gtk+3-devel >= 3.22.0
59 Requires:       wayland-devel >= 1.10.0
60
61 %description devel
62 Header files for gtk-layer-shell library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki gtk-layer-shell.
66
67 %package static
68 Summary:        Static gtk-layer-shell library
69 Summary(pl.UTF-8):      Biblioteka statyczna gtk-layer-shell
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static gtk-layer-shell library.
75
76 %description static -l pl.UTF-8
77 Biblioteka statyczna gtk-layer-shell.
78
79 %package apidocs
80 Summary:        API documentation for gtk-layer-shell library
81 Summary(pl.UTF-8):      Dokumentacja API biblioteki gtk-layer-shell
82 Group:          Documentation
83 BuildArch:      noarch
84
85 %description apidocs
86 API documentation for gtk-layer-shell library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki gtk-layer-shell.
90
91 %package -n vala-gtk-layer-shell
92 Summary:        gtk-layer-shell API for Vala language
93 Summary(pl.UTF-8):      API gtk-layer-shell dla języka Vala
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Requires:       vala
97 BuildArch:      noarch
98
99 %description -n vala-gtk-layer-shell
100 gtk-layer-shell API for Vala language.
101
102 %description -n vala-gtk-layer-shell -l pl.UTF-8
103 API gtk-layer-shell dla języka Vala.
104
105 %prep
106 %setup -q
107
108 %build
109 %meson build \
110         %{?with_apidocs:-Ddocs=true} \
111         -Dvapi=%{__true_false vala}
112
113 %ninja_build -C build
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %ninja_install -C build
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc CHANGELOG.md LICENSE_MIT.txt README.md compatibility.md
129 %attr(755,root,root) %{_libdir}/libgtk-layer-shell.so.*.*.*
130 %ghost %{_libdir}/libgtk-layer-shell.so.0
131 %{_libdir}/girepository-1.0/GtkLayerShell-0.1.typelib
132
133 %files devel
134 %defattr(644,root,root,755)
135 %{_libdir}/libgtk-layer-shell.so
136 %dir %{_includedir}/gtk-layer-shell
137 %{_includedir}/gtk-layer-shell/gtk-layer-shell.h
138 %{_pkgconfigdir}/gtk-layer-shell-0.pc
139 %{_datadir}/gir-1.0/GtkLayerShell-0.1.gir
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libgtk-layer-shell.a
144
145 %if %{with apidocs}
146 %files apidocs
147 %defattr(644,root,root,755)
148 %{_gtkdocdir}/gtk-layer-shell
149 %endif
150
151 %if %{with vala}
152 %files -n vala-gtk-layer-shell
153 %defattr(644,root,root,755)  
154 %{_datadir}/vala/vapi/gtk-layer-shell-0.deps
155 %{_datadir}/vala/vapi/gtk-layer-shell-0.vapi
156 %endif
This page took 0.085921 seconds and 3 git commands to generate.