]> git.pld-linux.org Git - packages/gtk-layer-shell.git/blob - gtk-layer-shell.spec
021635baa3126e965e6c27f0fc15e52c5aabab1d
[packages/gtk-layer-shell.git] / gtk-layer-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 Summary:        Library to create components for Wayland using the Layer Shell
6 Summary(pl.UTF-8):      Biblioteka do tworzenia komponentów Waylanda przy użyciu protokołu Layer Shell
7 Name:           gtk-layer-shell
8 Version:        0.7.0
9 Release:        1
10 License:        LGPL v3+, MIT
11 Group:          Libraries
12 #Source0Download: https://github.com/wmww/gtk-layer-shell/releases
13 Source0:        https://github.com/wmww/gtk-layer-shell/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  d6edf452c8b2e74f44bd6a1057581356
15 URL:            https://github.com/wmww/gtk-layer-shell
16 BuildRequires:  gcc >= 6:4.7
17 BuildRequires:  gtk+3-devel >= 3.22.0
18 %{?with_apidocs:BuildRequires:  gtk-doc}
19 BuildRequires:  meson >= 0.45.1
20 BuildRequires:  ninja >= 1.5
21 BuildRequires:  pkgconfig
22 BuildRequires:  python3 >= 1:3
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  rpmbuild(macros) >= 1.736
25 BuildRequires:  wayland-devel >= 1.10.0
26 BuildRequires:  wayland-protocols >= 1.16
27 Requires:       gtk+3 >= 3.22.0
28 Requires:       wayland >= 1.10.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A library to write GTK applications that use Layer Shell. Layer Shell
33 is a Wayland protocol for desktop shell components, such as panels,
34 notifications and wallpapers. You can use it to anchor your windows to
35 a corner or edge of the output, or stretch them across the entire
36 output. This library only makes sense on Wayland compositors that
37 support Layer Shell, and will not work on X11. It supports all Layer
38 Shell features including popups and popovers (GTK popups Just Work
39 (TM)).
40
41 %description -l pl.UTF-8
42 Biblioteka do tworzenia aplikacji GTK, wykorzystujących protokół Layer
43 Shell. Jest to protokół Wayland dla komponentów powłok graficznych,
44 takich jak panele, powiadomienia i tapety. Można go używać do
45 zakotwiczania okien w roku lub przy brzegu wyjścia, albo rozciągania
46 ich na całe wyjście. Biblioteka ma sens tylko dla zarządców składania
47 Wayland obsługujących protokół Layer Shell, nie będzie działać na X11.
48 Obsługuje wszystkie możliwości protokołu Layer Shell, w tym
49 wyskakujące okna.
50
51 %package devel
52 Summary:        Header files for gtk-layer-shell library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gtk-layer-shell
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       gtk+3-devel >= 3.22.0
57 Requires:       wayland-devel >= 1.10.0
58
59 %description devel
60 Header files for gtk-layer-shell library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki gtk-layer-shell.
64
65 %package static
66 Summary:        Static gtk-layer-shell library
67 Summary(pl.UTF-8):      Biblioteka statyczna gtk-layer-shell
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static gtk-layer-shell library.
73
74 %description static -l pl.UTF-8
75 Biblioteka statyczna gtk-layer-shell.
76
77 %package apidocs
78 Summary:        API documentation for gtk-layer-shell library
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki gtk-layer-shell
80 Group:          Documentation
81 BuildArch:      noarch
82
83 %description apidocs
84 API documentation for gtk-layer-shell library.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki gtk-layer-shell.
88
89 %prep
90 %setup -q
91
92 %build
93 %meson build \
94         %{?with_apidocs:-Ddocs=true}
95
96 %ninja_build -C build
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %ninja_install -C build
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CHANGELOG.md LICENSE_MIT.txt README.md compatibility.md
112 %attr(755,root,root) %{_libdir}/libgtk-layer-shell.so.*.*.*
113 %ghost %{_libdir}/libgtk-layer-shell.so.0
114 %{_libdir}/girepository-1.0/GtkLayerShell-0.1.typelib
115
116 %files devel
117 %defattr(644,root,root,755)
118 %{_libdir}/libgtk-layer-shell.so
119 %dir %{_includedir}/gtk-layer-shell
120 %{_includedir}/gtk-layer-shell/gtk-layer-shell.h
121 %{_pkgconfigdir}/gtk-layer-shell-0.pc
122 %{_datadir}/gir-1.0/GtkLayerShell-0.1.gir
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libgtk-layer-shell.a
127
128 %if %{with apidocs}
129 %files apidocs
130 %defattr(644,root,root,755)
131 %{_gtkdocdir}/gtk-layer-shell
132 %endif
This page took 0.052048 seconds and 2 git commands to generate.