]> git.pld-linux.org Git - packages/gtatool.git/blob - gtatool.spec
- release 20 (by relup.sh)
[packages/gtatool.git] / gtatool.spec
1 # TODO: pmd (BR: proprietary libpmdaccess2)
2 # libequalizer (pkgconfig(Equalizer) >= 1.0.0) for multi-display OpenGL support
3 # libgls (pkgconfig(gls) >= 1.0.0) for stereoscopic-3D OpenGL support
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # do not build and package API docs
7 %bcond_without  qt              # Qt-based GUI
8 %bcond_without  muparser        # compute component module (based on MuParser)
9 %bcond_without  dcmtk           # DCMTK conv module
10 %bcond_without  ffmpeg          # FFmpeg conv module
11 %bcond_without  gdal            # GDAL conv module
12 %bcond_without  jpeg            # JPEG conv module (based on libjpeg)
13 %bcond_without  magick          # Magick conv module (based on ImageMagick's libMagick++)
14 %bcond_without  matio           # MAT conv module (MATLAB import/export, based on [lib]matio)
15 %bcond_without  netcdf          # NetCDF conv module
16 %bcond_without  netpbm          # NetPBM conv module
17 %bcond_without  openexr         # EXR conv module (based on OpenEXR)
18 %bcond_without  pcl             # PCD conv module (based on PCL's libpcl_io)
19 %bcond_without  pfs             # PFS conv module
20 %bcond_without  sndfile         # sndfile conv module
21 %bcond_without  teem            # teem (nrrd) conv module
22 #
23 Summary:        Tools to manipulate Generic Tagged Array (GTA) files
24 Summary(pl.UTF-8):      Narzędzia do obróbki plików GTA (ogólnych tablic etykietowanych)
25 Name:           gtatool
26 Version:        2.0.1
27 Release:        20
28 License:        GPL v3+
29 Group:          Applications/File
30 Source0:        http://download.savannah.gnu.org/releases/gta/%{name}-%{version}.tar.xz
31 # Source0-md5:  1133c5687bd14d321eefffab6b495d74
32 Patch0:         ffmpeg2.patch
33 Patch1:         %{name}-getopt.patch
34 Patch2:         %{name}-bashcomp.patch
35 Patch3:         pfstools2.patch
36 Patch4:         ffmpeg3.patch
37 Patch5:         imagemagick7.patch
38 Patch6:         ffmpeg4.patch
39 URL:            http://gta.nongnu.org/gtatool.html
40 %{?with_magick:BuildRequires:   ImageMagick-c++-devel}
41 %{?with_openexr:BuildRequires:  OpenEXR-devel}
42 %{?with_qt:BuildRequires:       OpenGL-devel}
43 %{?with_qt:BuildRequires:       QtGui-devel >= 4.8}
44 %{?with_qt:BuildRequires:       QtOpenGL-devel >= 4.8}
45 BuildRequires:  autoconf >= 2.65
46 BuildRequires:  automake >= 1:1.11.1
47 %{?with_dcmtk:BuildRequires:    dcmtk-devel}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 # libavformat >= 52.110.0 libavdevice libswscale
50 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
51 %{?with_gdal:BuildRequires:     gdal-devel}
52 %{?with_qt:BuildRequires:       glew-devel >= 1.6.0}
53 BuildRequires:  libgta-devel >= 0.9.4
54 %{?with_jpeg:BuildRequires:     libjpeg-devel}
55 %{?with_sndfile:BuildRequires:  libsndfile-devel}
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  libtool >= 2:2.2.6
58 %{?with_matio:BuildRequires:    matio-devel >= 1.5.0}
59 %{?with_muparser:BuildRequires: muparser-devel}
60 %{?with_netcdf:BuildRequires:   netcdf-devel}
61 %{?with_netpbm:BuildRequires:   netpbm-devel}
62 %{?with_pcl:BuildRequires:      pcl-devel >= 1.7}
63 %{?with_pfs:BuildRequires:      pfstools-devel >= 2.0}
64 BuildRequires:  pkgconfig
65 %{?with_qt:BuildRequires:       qt4-build >= 4.8}
66 BuildRequires:  rpmbuild(macros) >= 1.673
67 BuildRequires:  tar >= 1:1.22
68 %{?with_teem:BuildRequires:     teem-devel}
69 BuildRequires:  xz
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Gtatool manipulates Generic Tagged Array (GTA) files.
74
75 It provides a set of commands that manipulate GTAs on various levels,
76 and it can import from and export to many other file formats.
77
78 %description -l pl.UTF-8
79 gtatool pracuje na plikach GTA (Generic Tagged Array - ogólnych
80 tablicach etykietowanych).
81
82 Pakiet zawiera zestaw poleceń obrabiających GTA na różnych poziomach,
83 potrafiących importować i eksportować do wielu innych formatów plików.
84
85 %package component-compute
86 Summary:        gtatool module to compute array element components
87 Summary(pl.UTF-8):      Moduł gtatool do obliczania składowych elementów tablicy
88 Group:          Applications/File
89 Requires:       %{name} = %{version}-%{release}
90
91 %description component-compute
92 gtatool module to compute array element components.
93
94 %description component-compute -l pl.UTF-8
95 Moduł gtatool do obliczania składowych elementów tablicy.
96
97 %package conv-dcmtk
98 Summary:        gtatool module to convert from DICOM format
99 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatu DICOM
100 Group:          Applications/File
101 Requires:       %{name} = %{version}-%{release}
102
103 %description conv-dcmtk
104 gtatool module to convert from DICOM format.
105
106 %description conv-dcmtk -l pl.UTF-8
107 Moduł gtatool do konwersji z formatu DICOM.
108
109 %package conv-exr
110 Summary:        gtatool module to convert from/to EXR format
111 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu EXR
112 Group:          Applications/File
113 Requires:       %{name} = %{version}-%{release}
114
115 %description conv-exr
116 gtatool module to convert from/to EXR format.
117
118 %description conv-exr -l pl.UTF-8
119 Moduł gtatool do konwersji z/do formatu EXR.
120
121 %package conv-ffmpeg
122 Summary:        gtatool module to convert from FFmpeg formats
123 Summary(pl.UTF-8):      Moduł gtatool do konwersji z formatów FFmpeg
124 Group:          Applications/File
125 Requires:       %{name} = %{version}-%{release}
126
127 %description conv-ffmpeg
128 gtatool module to convert from FFmpeg formats.
129
130 %description conv-ffmpeg -l pl.UTF-8
131 Moduł gtatool do konwersji z formatów FFmpeg.
132
133 %package conv-gdal
134 Summary:        gtatool module to convert from/to GDAL supported formats
135 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL
136 Group:          Applications/File
137 Requires:       %{name} = %{version}-%{release}
138
139 %description conv-gdal
140 gtatool module to convert from/to GDAL supported formats.
141
142 %description conv-gdal -l pl.UTF-8
143 Moduł gtatool do konwersji z/do formatów obsługiwanych przez GDAL.
144
145 %package conv-jpeg
146 Summary:        gtatool module to convert from/to JPEG formats
147 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu JPEG
148 Group:          Applications/File
149 Requires:       %{name} = %{version}-%{release}
150
151 %description conv-jpeg
152 gtatool module to convert from/to JPEG formats.
153
154 %description conv-jpeg -l pl.UTF-8
155 Moduł gtatool do konwersji z/do formatu JPEG.
156
157 %package conv-magick
158 Summary:        gtatool module to convert from/to ImageMagick supported formats
159 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez ImageMagick
160 Group:          Applications/File
161 Requires:       %{name} = %{version}-%{release}
162
163 %description conv-magick
164 gtatool module to convert from/to ImageMagick supported formats.
165
166 %description conv-magick -l pl.UTF-8
167 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
168 ImageMagick.
169
170 %package conv-mat
171 Summary:        gtatool module to convert from/to MAT format
172 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu MAT
173 Group:          Applications/File
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       matio >= 1.5.0
176
177 %description conv-mat
178 gtatool module to convert from/to MAT (Matlab) format.
179
180 %description conv-mat -l pl.UTF-8
181 Moduł gtatool do konwersji z/do formatu MAT (z programu Matlab).
182
183 %package conv-netcdf
184 Summary:        gtatool module to convert from/to NetCDF format
185 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu NetCDF
186 Group:          Applications/File
187 Requires:       %{name} = %{version}-%{release}
188
189 %description conv-netcdf
190 gtatool module to convert from/to NetCDF format.
191
192 %description conv-netcdf -l pl.UTF-8
193 Moduł gtatool do konwersji z/do formatu NetCDF.
194
195 %package conv-netpbm
196 Summary:        gtatool module to convert from/to NetPBM supported formats
197 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM
198 Group:          Applications/File
199 Requires:       %{name} = %{version}-%{release}
200
201 %description conv-netpbm
202 gtatool module to convert from/to NetPBM supported formats.
203
204 %description conv-netpbm -l pl.UTF-8
205 Moduł gtatool do konwersji z/do formatów obsługiwanych przez NetPBM.
206
207 %package conv-pcd
208 Summary:        gtatool module to convert from/to PCD format
209 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PCD
210 Group:          Applications/File
211 Requires:       %{name} = %{version}-%{release}
212
213 %description conv-pcd
214 gtatool module to convert from/to PCD format.
215
216 %description conv-pcd -l pl.UTF-8
217 Moduł gtatool do konwersji z/do formatu PCD.
218
219 %package conv-pfs
220 Summary:        gtatool module to convert from/to PFS format
221 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu PFS
222 Group:          Applications/File
223 Requires:       %{name} = %{version}-%{release}
224
225 %description conv-pfs
226 gtatool module to convert from/to PFS format.
227
228 %description conv-pfs -l pl.UTF-8
229 Moduł gtatool do konwersji z/do formatu PFS.
230
231 %package conv-sndfile
232 Summary:        gtatool module to convert from/to libsndfile supported formats
233 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatów obsługiwanych przez libsndfile
234 Group:          Applications/File
235 Requires:       %{name} = %{version}-%{release}
236
237 %description conv-sndfile
238 gtatool module to convert from/to libsndfile supported formats.
239
240 %description conv-sndfile -l pl.UTF-8
241 Moduł gtatool do konwersji z/do formatów obsługiwanych przez
242 libsndfile.
243
244 %package conv-teem
245 Summary:        gtatool module to convert from/to Teem (NRRD) format
246 Summary(pl.UTF-8):      Moduł gtatool do konwersji z/do formatu Teem (NRRD)
247 Group:          Applications/File
248 Requires:       %{name} = %{version}-%{release}
249
250 %description conv-teem
251 gtatool module to convert from/to Teem (NRRD) format.
252
253 %description conv-teem -l pl.UTF-8
254 Moduł gtatool do konwersji z/do formatu Teem (NRRD).
255
256 %package gui
257 Summary:        Qt-based GUI module for gtatool
258 Summary(pl.UTF-8):      Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia gtatool
259 Group:          X11/Applications
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       QtGui >= 4.8
262
263 %description gui
264 Qt-based GUI module for gtatool.
265
266 %description gui -l pl.UTF-8
267 Moduł graficznego interfejsu użytkownika opartego na Qt dla narzędzia
268 gtatool.
269
270 %package -n bash-completion-gtatool
271 Summary:        Bash completion for gtatool command
272 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów programu gtatool
273 Group:          Applications/Shells
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       bash-completion >= 2
276 %if "%{_rpmversion}" >= "5"
277 BuildArch:      noarch
278 %endif
279
280 %description -n bash-completion-gtatool
281 Bash completion for gtatool command.
282
283 %description -n bash-completion-gtatool -l pl.UTF-8
284 Bashowe uzupełnianie parametrów programu gtatool.
285
286 %prep
287 %setup -q
288 %patch0 -p1
289 %patch1 -p1
290 %patch2 -p1
291 %patch3 -p1
292 %patch4 -p1
293 %patch5 -p1
294 %patch6 -p1
295
296 %build
297 %{__libtoolize}
298 %{__aclocal} -I m4
299 %{__autoconf}
300 %{__autoheader}
301 %{__automake}
302 %if %{with netpbm}
303 export CFLAGS="%{rpmcflags} -I/usr/include/netpbm"
304 export CXXFLAGS="%{rpmcxxflags} -I/usr/include/netpbm"
305 %endif
306 %configure \
307         BASHCOMPLETIONDIR=%{bash_compdir} \
308         --disable-silent-rules \
309         --with-bashcompletion \
310         %{!?with_dcmtk:--without-dcmtk} \
311         %{!?with_ffmpeg:--without-ffmpeg} \
312         %{!?with_gdal:--without-gdal} \
313         %{!?with_jpeg:--without-jpeg} \
314         %{?with_magick:--with-magick-flavor=ImageMagick} \
315         %{!?with_magick:--without-magick} \
316         %{!?with_matio:--without-matio} \
317         %{!?with_muparser:--without-muparser} \
318         %{!?with_netcdf:--without-netcdf} \
319         %{!?with_netpbm:--without-netpbm} \
320         %{!?with_openexr:--without-openexr} \
321         %{!?with_pcl:--without-pcd} \
322         %{!?with_pfs:--without-pfs} \
323         %{!?with_qt:--without-qt} \
324         %{!?with_sndfile:--without-sndfile} \
325         %{!?with_teem:--without-teem}
326 %{__make}
327
328 %install
329 rm -rf $RPM_BUILD_ROOT
330
331 %{__make} install \
332         DESTDIR=$RPM_BUILD_ROOT
333
334 %clean
335 rm -rf $RPM_BUILD_ROOT
336
337 %post   -p /sbin/postshell
338 -/usr/sbin/fix-info-dir -c %{_infodir}
339
340 %postun -p /sbin/postshell
341 -/usr/sbin/fix-info-dir -c %{_infodir}
342
343 %files
344 %defattr(644,root,root,755)
345 %doc AUTHORS ChangeLog NEWS README
346 %attr(755,root,root) %{_bindir}/gta
347 %dir %{_libdir}/gtatool
348 %attr(755,root,root) %{_libdir}/gtatool/conv-csv.so
349 %attr(755,root,root) %{_libdir}/gtatool/conv-datraw.so
350 %attr(755,root,root) %{_libdir}/gtatool/conv-ply.so
351 %attr(755,root,root) %{_libdir}/gtatool/conv-pvm.so
352 %attr(755,root,root) %{_libdir}/gtatool/conv-rat.so
353 %attr(755,root,root) %{_libdir}/gtatool/conv-raw.so
354 %{_mandir}/man1/gta.1*
355 %{_infodir}/gta.info*
356
357 %if %{with muparser}
358 %files component-compute
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_libdir}/gtatool/component-compute.so
361 %endif
362
363 %if %{with dcmtk}
364 %files conv-dcmtk
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_libdir}/gtatool/conv-dcmtk.so
367 %endif
368
369 %if %{with openexr}
370 %files conv-exr
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/gtatool/conv-exr.so
373 %endif
374
375 %if %{with ffmpeg}
376 %files conv-ffmpeg
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_libdir}/gtatool/conv-ffmpeg.so
379 %endif
380
381 %if %{with gdal}
382 %files conv-gdal
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_libdir}/gtatool/conv-gdal.so
385 %endif
386
387 %if %{with jpeg}
388 %files conv-jpeg
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/gtatool/conv-jpeg.so
391 %endif
392
393 %if %{with magick}
394 %files conv-magick
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/gtatool/conv-magick.so
397 %endif
398
399 %if %{with matio}
400 %files conv-mat
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/gtatool/conv-mat.so
403 %endif
404
405 %if %{with netcdf}
406 %files conv-netcdf
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_libdir}/gtatool/conv-netcdf.so
409 %endif
410
411 %if %{with netpbm}
412 %files conv-netpbm
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/gtatool/conv-netpbm.so
415 %endif
416
417 %if %{with pcl}
418 %files conv-pcd
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_libdir}/gtatool/conv-pcd.so
421 %endif
422
423 %if %{with pfs}
424 %files conv-pfs
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/gtatool/conv-pfs.so
427 %endif
428
429 %if %{with sndfile}
430 %files conv-sndfile
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/gtatool/conv-sndfile.so
433 %endif
434
435 %if %{with teem}
436 %files conv-teem
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/gtatool/conv-teem.so
439 %endif
440
441 %if %{with qt}
442 %files gui
443 %defattr(644,root,root,755)
444 %attr(755,root,root) %{_libdir}/gtatool/gui.so
445 %attr(755,root,root) %{_libdir}/gtatool/view.so
446 %{_desktopdir}/gta_gui.desktop
447 %{_iconsdir}/hicolor/*/apps/gta.png
448 %{_iconsdir}/hicolor/scalable/apps/gta.svg
449 %endif
450
451 %files -n bash-completion-gtatool
452 %defattr(644,root,root,755)
453 %{bash_compdir}/gta
This page took 0.092138 seconds and 3 git commands to generate.