]> git.pld-linux.org Git - packages/gstreamer0.10-plugins-gl.git/blob - gstreamer0.10-plugins-gl.spec
- BRs for noarch subpackage and gstreamer macros always included
[packages/gstreamer0.10-plugins-gl.git] / gstreamer0.10-plugins-gl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 #
5 %define         gstname gst-plugins-gl
6 %define         gst_major_ver   0.10
7 %define         gst_req_ver     0.10.35
8 %define         gstpb_req_ver   0.10.35
9
10 Summary:        GStreamer Streaming-media framework plug-in for OpenGL
11 Summary(pl.UTF-8):      Wtyczka OpenGL do środowiska strumieni multimedialnych GStreamer
12 Name:           gstreamer0.10-plugins-gl
13 Version:        0.10.3
14 Release:        7
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-gl/%{gstname}-%{version}.tar.bz2
18 # Source0-md5:  ac70ede13f79978d56eaed8abaa3c938
19 Patch0:         gstreamer-common-gtkdoc.patch
20 URL:            https://gstreamer.freedesktop.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  autoconf >= 2.60
23 BuildRequires:  automake >= 1:1.10
24 %{?with_apidocs:BuildRequires:  docbook-dtd412-xml}
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glew-devel >= 1.4.0
27 BuildRequires:  glib2-devel >= 1:2.6
28 BuildRequires:  gstreamer0.10-devel >= %{gst_req_ver}
29 BuildRequires:  gstreamer0.10-plugins-base-devel >= %{gstpb_req_ver}
30 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel >= 1.0
33 BuildRequires:  libprojectM-devel >= 2.0.1
34 BuildRequires:  libtool >= 2:1.5
35 BuildRequires:  libvisual-devel >= 0.4.0
36 BuildRequires:  pkgconfig
37 BuildRequires:  python >= 2.1
38 BuildRequires:  rpm-build >= 4.6
39 BuildRequires:  rpmbuild(macros) >= 1.745
40 Requires:       gstreamer0.10 >= %{gst_req_ver}
41 Requires:       gstreamer0.10-plugins-base >= %{gstpb_req_ver}
42 Requires:       libprojectM >= 2.0.1
43 Requires:       libvisual >= 0.4.0
44 Obsoletes:      gstreamer-imagesink-gl < 1
45 Obsoletes:      gstreamer-plugins-gl < 1
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 This module contains integration library and plug-in for using OpenGL
50 within GStreamer pipelines.
51
52 %description -l pl.UTF-8
53 Ten moduł zawiera bibliotekę i wtyczkę pozwalające na używanie
54 OpenGL-a w potokach GStreamera.
55
56 %package devel
57 Summary:        Include files for GStreamer streaming-media framework OpenGL API
58 Summary(pl.UTF-8):      Pliki nagłówkowe API OpenGL dla środowiska strumieni multimedialnych GStreamer
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       OpenGL-GLU-devel
62 Requires:       glew-devel >= 1.4.0
63 Requires:       gstreamer0.10-devel >= %{gst_req_ver}
64 Requires:       gstreamer0.10-plugins-base-devel >= %{gstpb_req_ver}
65 Obsoletes:      gstreamer-plugins-gl-devel < 1
66
67 %description devel
68 Include files for GStreamer streaming-media framework OpenGL API.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe API OpenGL dla środowiska strumieni multimedialnych
72 GStreamer.
73
74 %package apidocs
75 Summary:        GStreamer streaming-media framework OpenGL API documentation
76 Summary(pl.UTF-8):      Dokumentacja API OpenGL dla środowiska strumieni multimedialnych GStreamer
77 Group:          Documentation
78 Requires:       gtk-doc-common
79 Obsoletes:      gstreamer-plugins-gl-apidocs < 1
80 BuildArch:      noarch
81
82 %description apidocs
83 GStreamer streaming-media framework OpenGL API documentation.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API OpenGL dla środowiska strumieni multimedialnych
87 GStreamer.
88
89 %prep
90 %setup -q -n %{gstname}-%{version}
91 cd common
92 %patch0 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I m4 -I common/m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --disable-examples \
102         --disable-silent-rules \
103         --disable-static \
104         --enable-gtk-doc%{!?with_apidocs:=no} \
105         --with-html-dir=%{_gtkdocdir}
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README RELEASE TODO
126 %attr(755,root,root) %{_libdir}/libgstgl-%{gst_major_ver}.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libgstgl-%{gst_major_ver}.so.1
128 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstopengl.so
129 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibvisualgl.so
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libgstgl-%{gst_major_ver}.so
134 %{_includedir}/gstreamer-%{gst_major_ver}/gst/gl
135 %{_pkgconfigdir}/gstreamer-gl-%{gst_major_ver}.pc
136
137 %if %{with apidocs}
138 %files apidocs
139 %defattr(644,root,root,755)
140 %{_gtkdocdir}/gst-plugins-gl-libs-%{gst_major_ver}
141 %{_gtkdocdir}/gst-plugins-gl-plugins-%{gst_major_ver}
142 %endif
This page took 0.084941 seconds and 3 git commands to generate.