]> git.pld-linux.org Git - packages/gstreamer0.10-plugins-gl.git/blob - gstreamer0.10-plugins-gl.spec
205fbbe05058b859777e93ea7b461c8616936945
[packages/gstreamer0.10-plugins-gl.git] / gstreamer0.10-plugins-gl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 #
5 %define         gstname gst-plugins-gl
6 %define         gst_major_ver   0.10
7 %define         gst_req_ver     0.10.35
8 %define         gstpb_req_ver   0.10.35
9
10 Summary:        GStreamer Streaming-media framework plug-in for OpenGL
11 Summary(pl.UTF-8):      Wtyczka OpenGL do środowiska strumieni multimedialnych GStreamer
12 Name:           gstreamer0.10-plugins-gl
13 Version:        0.10.3
14 Release:        7
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-gl/%{gstname}-%{version}.tar.bz2
18 # Source0-md5:  ac70ede13f79978d56eaed8abaa3c938
19 Patch0:         gstreamer-common-gtkdoc.patch
20 URL:            https://gstreamer.freedesktop.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  autoconf >= 2.60
23 BuildRequires:  automake >= 1:1.10
24 %{?with_apidocs:BuildRequires:  docbook-dtd412-xml}
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glew-devel >= 1.4.0
27 BuildRequires:  glib2-devel >= 1:2.6
28 BuildRequires:  gstreamer0.10-devel >= %{gst_req_ver}
29 BuildRequires:  gstreamer0.10-plugins-base-devel >= %{gstpb_req_ver}
30 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel >= 1.0
33 BuildRequires:  libprojectM-devel >= 2.0.1
34 BuildRequires:  libtool >= 2:1.5
35 BuildRequires:  libvisual-devel >= 0.4.0
36 BuildRequires:  pkgconfig
37 BuildRequires:  python >= 2.1
38 BuildRequires:  rpmbuild(macros) >= 1.470
39 Requires:       gstreamer0.10 >= %{gst_req_ver}
40 Requires:       gstreamer0.10-plugins-base >= %{gstpb_req_ver}
41 Requires:       libprojectM >= 2.0.1
42 Requires:       libvisual >= 0.4.0
43 Obsoletes:      gstreamer-imagesink-gl < 1
44 Obsoletes:      gstreamer-plugins-gl < 1
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 This module contains integration library and plug-in for using OpenGL
49 within GStreamer pipelines.
50
51 %description -l pl.UTF-8
52 Ten moduł zawiera bibliotekę i wtyczkę pozwalające na używanie
53 OpenGL-a w potokach GStreamera.
54
55 %package devel
56 Summary:        Include files for GStreamer streaming-media framework OpenGL API
57 Summary(pl.UTF-8):      Pliki nagłówkowe API OpenGL dla środowiska strumieni multimedialnych GStreamer
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       OpenGL-GLU-devel
61 Requires:       glew-devel >= 1.4.0
62 Requires:       gstreamer0.10-devel >= %{gst_req_ver}
63 Requires:       gstreamer0.10-plugins-base-devel >= %{gstpb_req_ver}
64 Obsoletes:      gstreamer-plugins-gl-devel < 1
65
66 %description devel
67 Include files for GStreamer streaming-media framework OpenGL API.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe API OpenGL dla środowiska strumieni multimedialnych
71 GStreamer.
72
73 %package apidocs
74 Summary:        GStreamer streaming-media framework OpenGL API documentation
75 Summary(pl.UTF-8):      Dokumentacja API OpenGL dla środowiska strumieni multimedialnych GStreamer
76 Group:          Documentation
77 Requires:       gtk-doc-common
78 Obsoletes:      gstreamer-plugins-gl-apidocs < 1
79 BuildArch:      noarch
80
81 %description apidocs
82 GStreamer streaming-media framework OpenGL API documentation.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API OpenGL dla środowiska strumieni multimedialnych
86 GStreamer.
87
88 %prep
89 %setup -q -n %{gstname}-%{version}
90 cd common
91 %patch0 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4 -I common/m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --disable-examples \
101         --disable-silent-rules \
102         --disable-static \
103         --enable-gtk-doc%{!?with_apidocs:=no} \
104         --with-html-dir=%{_gtkdocdir}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog NEWS README RELEASE TODO
124 %attr(755,root,root) %{_libdir}/libgstgl-%{gst_major_ver}.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libgstgl-%{gst_major_ver}.so.1
126 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstopengl.so
127 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibvisualgl.so
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libgstgl-%{gst_major_ver}.so
132 %{_includedir}/gstreamer-%{gst_major_ver}/gst/gl
133 %{_pkgconfigdir}/gstreamer-gl-%{gst_major_ver}.pc
134
135 %if %{with apidocs}
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_gtkdocdir}/gst-plugins-gl-libs-%{gst_major_ver}
139 %{_gtkdocdir}/gst-plugins-gl-plugins-%{gst_major_ver}
140 %endif
This page took 0.064066 seconds and 2 git commands to generate.