]> git.pld-linux.org Git - packages/gstreamer0.10-ffmpeg.git/blob - gstreamer0.10-ffmpeg.spec
- updated URL, macros for gstreamer macros always included
[packages/gstreamer0.10-ffmpeg.git] / gstreamer0.10-ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  vdpau           # build FFmpeg without VDPAU support
4 %bcond_with     system_ffmpeg   # system FFmpeg (note: upstream does not accept bugs with system ffmpeg)
5
6 %define         gstname gst-ffmpeg
7 %define         gst_major_ver   0.10
8 %define         gst_req_ver     0.10.31
9
10 Summary:        GStreamer Streaming-media framework plug-in using FFmpeg
11 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca FFmpeg
12 Name:           gstreamer0.10-ffmpeg
13 Version:        0.10.13
14 Release:        1
15 # the ffmpeg plugin is LGPL, the postproc plugin is GPL
16 License:        GPL v2+ and LGPL v2+
17 Group:          Libraries
18 Source0:        https://gstreamer.freedesktop.org/src/gst-ffmpeg/%{gstname}-%{version}.tar.bz2
19 # Source0-md5:  7f5beacaf1312db2db30a026b36888c4
20 Patch0:         gst-ffmpeg-format_string.patch
21 Patch1:         gst-ffmpeg-gcc4.7-x86_64.patch
22 URL:            http://gstreamer.net/
23 BuildRequires:  autoconf >= 2.60
24 BuildRequires:  automake >= 1:1.10
25 BuildRequires:  bzip2-devel
26 BuildRequires:  gstreamer0.10-devel >= %{gst_req_ver}
27 BuildRequires:  gtk-doc >= 1.3
28 BuildRequires:  gstreamer0.10-plugins-base-devel >= %{gst_req_ver}
29 BuildRequires:  libtool
30 BuildRequires:  orc-devel >= 0.4.6
31 BuildRequires:  pkgconfig
32 BuildRequires:  python >= 2.1
33 BuildRequires:  rpmbuild(macros) >= 1.745
34 %if %{with system_ffmpeg}
35 # libavformat,libavcodec,libavutil,libpostproc,libswscale needed
36 BuildRequires:  ffmpeg-devel >= 0.7
37 %else
38 # TODO: fill the rest of ffmpeg dependencies used here
39 %if %{with vdpau}
40 BuildRequires:  libvdpau-devel
41 BuildRequires:  xorg-lib-libXvMC-devel
42 %endif
43 %endif
44 Requires:       gstreamer0.10-plugins-base >= %{gst_req_ver}
45 Requires:       orc >= 0.4.6
46 Obsoletes:      gstreamer-ffmpeg < 0.11
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GStreamer is a streaming-media framework, based on graphs of filters
51 which operate on media data. Applications using this library can do
52 anything from real-time sound processing to playing videos, and just
53 about anything else media-related. Its plugin-based architecture means
54 that new data types or processing capabilities can be added simply by
55 installing new plug-ins.
56
57 This plugin contains the FFmpeg codecs, containing codecs for most
58 popular multimedia formats.
59
60 %description -l pl.UTF-8
61 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
62 grafie filtrów operujących na danych medialnych. Aplikacje używające
63 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
64 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
65 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
66 nowych typów danych lub możliwości obróbki.
67
68 Wtyczka ta zawiera kodeki FFmpeg, potrafiące zdekodować
69 najpopularniejsze formaty multimedialne.
70
71 %prep
72 %setup -q -n %{gstname}-%{version}
73 %patch0 -p1
74 %patch1 -p1
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I common/m4
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82
83 %configure \
84         CPPFLAGS="%{rpmcppflags}" \
85         %{?with_system_ffmpeg:--with-system-ffmpeg} \
86         %{?with_vdpau:--with-ffmpeg-extra-configure="--enable-vdpau"} \
87         --disable-silent-rules \
88         --disable-static
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog NEWS README TODO
105 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstffmpeg.so
106 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstffmpegscale.so
107 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstpostproc.so
This page took 0.060809 seconds and 4 git commands to generate.