]> git.pld-linux.org Git - packages/gstreamer0.10-ffmpeg.git/blob - gstreamer0.10-ffmpeg.spec
31ab59dddf53b99300d350012fa8ebcd6e38a57f
[packages/gstreamer0.10-ffmpeg.git] / gstreamer0.10-ffmpeg.spec
1 #
2 # Conditional build:
3 %bcond_without  vdpau           # build FFmpeg without VDPAU support
4 %bcond_without  system_ffmpeg   # system FFmpeg (note: upstream does not accept bugs with system ffmpeg)
5
6 %define         gstname gst-ffmpeg
7 %define         gst_major_ver   0.10
8 %define         gst_req_ver     0.10.31
9
10 %include        /usr/lib/rpm/macros.gstreamer
11 Summary:        GStreamer Streaming-media framework plug-in using FFmpeg
12 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca FFmpeg
13 Name:           gstreamer0.10-ffmpeg
14 Version:        0.10.13
15 Release:        1
16 # the ffmpeg plugin is LGPL, the postproc plugin is GPL
17 License:        GPL v2+ and LGPL v2+
18 Group:          Libraries
19 Source0:        http://gstreamer.freedesktop.org/src/gst-ffmpeg/%{gstname}-%{version}.tar.bz2
20 # Source0-md5:  7f5beacaf1312db2db30a026b36888c4
21 URL:            http://gstreamer.net/
22 BuildRequires:  autoconf >= 2.60
23 BuildRequires:  automake >= 1:1.10
24 BuildRequires:  bzip2-devel
25 BuildRequires:  gstreamer0.10-devel >= %{gst_req_ver}
26 BuildRequires:  gtk-doc >= 1.3
27 BuildRequires:  gstreamer0.10-plugins-base-devel >= %{gst_req_ver}
28 BuildRequires:  libtool
29 BuildRequires:  orc-devel >= 0.4.6
30 BuildRequires:  pkgconfig
31 BuildRequires:  python >= 2.1
32 BuildRequires:  rpmbuild(macros) >= 1.470
33 %if %{with system_ffmpeg}
34 # libavformat,libavcodec,libavutil,libpostproc,libswscale needed
35 BuildRequires:  ffmpeg-devel >= 0.7
36 %else
37 # TODO: fill the rest of ffmpeg dependencies used here
38 %if %{with vdpau}
39 BuildRequires:  libvdpau-devel
40 BuildRequires:  xorg-lib-libXvMC-devel
41 %endif
42 %endif
43 Requires:       gstreamer0.10-plugins-base >= %{gst_req_ver}
44 Requires:       orc >= 0.4.6
45 Obsoletes:      gstreamer-ffmpeg < 0.11
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 GStreamer is a streaming-media framework, based on graphs of filters
50 which operate on media data. Applications using this library can do
51 anything from real-time sound processing to playing videos, and just
52 about anything else media-related. Its plugin-based architecture means
53 that new data types or processing capabilities can be added simply by
54 installing new plug-ins.
55
56 This plugin contains the FFmpeg codecs, containing codecs for most
57 popular multimedia formats.
58
59 %description -l pl.UTF-8
60 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
61 grafie filtrów operujących na danych medialnych. Aplikacje używające
62 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
63 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
64 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
65 nowych typów danych lub możliwości obróbki.
66
67 Wtyczka ta zawiera kodeki FFmpeg, potrafiące zdekodować
68 najpopularniejsze formaty multimedialne.
69
70 %prep
71 %setup -q -n %{gstname}-%{version}
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I common/m4
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79
80 %configure \
81         CPPFLAGS="%{rpmcppflags}" \
82         %{?with_system_ffmpeg:--with-system-ffmpeg} \
83         %{?with_vdpau:--with-ffmpeg-extra-configure="--enable-vdpau"} \
84         --disable-silent-rules \
85         --disable-static
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog NEWS README TODO
102 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstffmpeg.so
103 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstffmpegscale.so
104 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstpostproc.so
This page took 0.031652 seconds and 2 git commands to generate.