]> git.pld-linux.org Git - packages/gstreamer-devtools.git/blob - gstreamer-validate.spec
- updated to 1.6.0
[packages/gstreamer-devtools.git] / gstreamer-validate.spec
1 %define         gst_ver         1.0.0
2 %define         gstpb_ver       1.0.0
3 Summary:        GstValidate - suite of tools to run GStreamer integration tests
4 Summary(pl.UTF-8):      GstValidate - zestaw narzędzi do uruchamiania testów integracyjnych GStreamera
5 Name:           gstreamer-validate
6 Version:        1.6.0
7 Release:        1
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://gstreamer.freedesktop.org/src/gst-validate/gst-validate-%{version}.tar.xz
11 # Source0-md5:  39ccc35814b1aa1c6b200e42e0eda94b
12 URL:            http://gstreamer.net/
13 BuildRequires:  autoconf >= 2.62
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  cairo-devel
16 BuildRequires:  gettext-devel >= 0.17
17 BuildRequires:  glib2-devel >= 1:2.36.0
18 BuildRequires:  gobject-introspection-devel >= 0.6.3
19 BuildRequires:  gstreamer-devel >= %{gst_ver}
20 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
21 BuildRequires:  gtk+3-devel >= 3.0
22 BuildRequires:  gtk-doc >= 1.3
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  pkgconfig >= 1:0.9.0
25 BuildRequires:  python >= 1:2.7.0
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       glib2 >= 1:2.36.0
29 Requires:       gstreamer >= %{gst_ver}
30 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
31 Requires:       python-modules >= 1:2.7
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The goal of GstValidate is to be able to detect when elements are not
36 behaving as expected and report it to the user so he knows how things
37 are supposed to work inside a GstPipeline. In the end, fixing issues
38 found by the tool will ensure that all elements behave all together in
39 the expected way.
40
41 %description -l pl.UTF-8
42 Celem GstValidate jest umożliwienie wykrycia sytuacji, kiedy elementy
43 nie zachowują się w sposób oczekiwany i zgłaszanie tego faktu
44 użytkownikowi tak, aby wiedział, jak powinny działać elementy wewnątrz
45 GstPipeline. W efekcie, poprawienie problemów wykrytych przez to
46 narzędzie zapewni, że wszystkie elementy razem będą się zachowywały w
47 sposób zgodny z oczekiwaniami.
48
49 %package devel
50 Summary:        Header files for GstValidate library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GstValidate
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.36.0
55 Requires:       gstreamer-devel >= %{gst_ver}
56 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
57
58 %description devel
59 Header files for GstValidate library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki GstValidate.
63
64 %package apidocs
65 Summary:        API documentation for GstValidate library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki GstValidate
67 Group:          Documentation
68 %if "%{_rpmversion}" >= "5"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 API documentation for GstValidate library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki GstValidate.
77
78 %prep
79 %setup -q -n gst-validate-%{version}
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4 -I common/m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 # disable sphinx for now: docs/launcher/conf.py is missing
88 %configure \
89         --enable-gtk-doc \
90         --disable-silent-rules \
91         --disable-sphinx-doc \
92         --disable-static \
93         --with-html-dir=%{_gtkdocdir}
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # obsoleted by pkg-config
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
105 # modules loaded through glib
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/validate/libgstvalidate*.la
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog NEWS README
117 %attr(755,root,root) %{_bindir}/gst-validate-1.0
118 %attr(755,root,root) %{_bindir}/gst-validate-images-check-1.0
119 %attr(755,root,root) %{_bindir}/gst-validate-launcher
120 %attr(755,root,root) %{_bindir}/gst-validate-media-check-1.0
121 %attr(755,root,root) %{_bindir}/gst-validate-transcoding-1.0
122 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-1.0.so.0
124 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-default-overrides-1.0.so.0
126 %attr(755,root,root) %{_libdir}/libgstvalidate_preload-1.0.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate_preload-1.0.so.0
128 %attr(755,root,root) %{_libdir}/libgstvalidatevideo-1.0.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libgstvalidatevideo-1.0.so.0
130 %{_libdir}/girepository-1.0/GstValidate-1.0.typelib
131 %dir %{_libdir}/gstreamer-1.0/validate
132 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatefaultinjection.so
133 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategapplication.so
134 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategtk.so
135 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatessim.so
136 %{_libdir}/gst-validate-launcher
137 %dir %{_datadir}/gstreamer-1.0
138 %{_datadir}/gstreamer-1.0/validate
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so
143 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so
144 %attr(755,root,root) %{_libdir}/libgstvalidate_preload-1.0.so
145 %attr(755,root,root) %{_libdir}/libgstvalidatevideo-1.0.so
146 %{_includedir}/gstreamer-1.0/gst/validate
147 %{_includedir}/gstreamer-1.0/lib/validate
148 %{_pkgconfigdir}/gst-validate-1.0.pc
149 %{_datadir}/gir-1.0/GstValidate-1.0.gir
150
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/gst-validate-1.0
154 %{_gtkdocdir}/gst-validate-plugins-1.0
This page took 0.149574 seconds and 4 git commands to generate.