]> git.pld-linux.org Git - packages/gstreamer-devtools.git/blob - gstreamer-validate.spec
- unconditional noarch subpackages
[packages/gstreamer-devtools.git] / gstreamer-validate.spec
1 %define         gst_ver         1.16.2
2 %define         gstpb_ver       1.16.2
3 Summary:        GstValidate - suite of tools to run GStreamer integration tests
4 Summary(pl.UTF-8):      GstValidate - zestaw narzędzi do uruchamiania testów integracyjnych GStreamera
5 Name:           gstreamer-validate
6 Version:        1.16.2
7 Release:        1
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        https://gstreamer.freedesktop.org/src/gst-validate/gst-validate-%{version}.tar.xz
11 # Source0-md5:  688f42c52d62e8c5e506df911553fb2c
12 URL:            https://gstreamer.freedesktop.org/
13 BuildRequires:  autoconf >= 2.62
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  cairo-devel
16 BuildRequires:  gettext-devel >= 0.17
17 BuildRequires:  glib2-devel >= 1:2.36.0
18 BuildRequires:  gobject-introspection-devel >= 0.6.3
19 BuildRequires:  gstreamer-devel >= %{gst_ver}
20 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
21 BuildRequires:  gstreamer-rtsp-server-devel >= %{gst_ver}
22 BuildRequires:  gtk+3-devel >= 3.0
23 BuildRequires:  gtk-doc >= 1.3
24 BuildRequires:  json-glib-devel >= 1.0
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  pkgconfig >= 1:0.9.0
27 BuildRequires:  python3 >= 1:3.4
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       glib2 >= 1:2.36.0
32 Requires:       gstreamer >= %{gst_ver}
33 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
34 Requires:       gstreamer-rtsp-server >= %{gst_ver}
35 Requires:       json-glib >= 1.0
36 Requires:       python3-modules >= 1:3.4
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The goal of GstValidate is to be able to detect when elements are not
41 behaving as expected and report it to the user so he knows how things
42 are supposed to work inside a GstPipeline. In the end, fixing issues
43 found by the tool will ensure that all elements behave all together in
44 the expected way.
45
46 %description -l pl.UTF-8
47 Celem GstValidate jest umożliwienie wykrycia sytuacji, kiedy elementy
48 nie zachowują się w sposób oczekiwany i zgłaszanie tego faktu
49 użytkownikowi tak, aby wiedział, jak powinny działać elementy wewnątrz
50 GstPipeline. W efekcie, poprawienie problemów wykrytych przez to
51 narzędzie zapewni, że wszystkie elementy razem będą się zachowywały w
52 sposób zgodny z oczekiwaniami.
53
54 %package devel
55 Summary:        Header files for GstValidate library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GstValidate
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.36.0
60 Requires:       gstreamer-devel >= %{gst_ver}
61 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
62
63 %description devel
64 Header files for GstValidate library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki GstValidate.
68
69 %package apidocs
70 Summary:        API documentation for GstValidate library
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki GstValidate
72 Group:          Documentation
73 BuildArch:      noarch
74
75 %description apidocs
76 API documentation for GstValidate library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki GstValidate.
80
81 %prep
82 %setup -q -n gst-validate-%{version}
83
84 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' tools/gst-validate-launcher.in
85
86 %build
87 %{__libtoolize}
88 %{__aclocal} -I m4 -I common/m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 # disable sphinx for now: docs/launcher/conf.py is missing
93 %configure \
94         PYTHON=%{__python3} \
95         --enable-gtk-doc \
96         --disable-silent-rules \
97         --disable-sphinx-doc \
98         --disable-static \
99         --with-html-dir=%{_gtkdocdir}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # obsoleted by pkg-config
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
111 # modules loaded through glib
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstvalidatetracer.la \
113         $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/validate/libgstvalidate*.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog NEWS README
124 %attr(755,root,root) %{_bindir}/gst-validate-1.0
125 %attr(755,root,root) %{_bindir}/gst-validate-images-check-1.0
126 %attr(755,root,root) %{_bindir}/gst-validate-launcher
127 %attr(755,root,root) %{_bindir}/gst-validate-media-check-1.0
128 %attr(755,root,root) %{_bindir}/gst-validate-rtsp-server-1.0
129 %attr(755,root,root) %{_bindir}/gst-validate-transcoding-1.0
130 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-1.0.so.0
132 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-default-overrides-1.0.so.0
134 %attr(755,root,root) %{_libdir}/libgstvalidatevideo-1.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgstvalidatevideo-1.0.so.0
136 %{_libdir}/girepository-1.0/GstValidate-1.0.typelib
137 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstvalidatetracer.so
138 %dir %{_libdir}/gstreamer-1.0/validate
139 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatefaultinjection.so
140 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategapplication.so
141 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategtk.so
142 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidateflow.so
143 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatessim.so
144 %{_libdir}/gst-validate-launcher
145 %dir %{_datadir}/gstreamer-1.0
146 %{_datadir}/gstreamer-1.0/validate
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so
151 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so
152 %attr(755,root,root) %{_libdir}/libgstvalidatevideo-1.0.so
153 %{_includedir}/gstreamer-1.0/gst/validate
154 %dir %{_includedir}/gstreamer-1.0/lib
155 %{_includedir}/gstreamer-1.0/lib/validate
156 %{_pkgconfigdir}/gst-validate-1.0.pc
157 %{_datadir}/gir-1.0/GstValidate-1.0.gir
158
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/gst-validate-1.0
162 %{_gtkdocdir}/gst-validate-plugins-1.0
This page took 0.090606 seconds and 3 git commands to generate.