]> git.pld-linux.org Git - packages/gstreamer-devtools.git/blob - gstreamer-validate.spec
- new
[packages/gstreamer-devtools.git] / gstreamer-validate.spec
1 %define         gst_ver         1.0.0
2 %define         gstpb_ver       1.0.0
3 Summary:        GstValidate - suite of tools to run GStreamer integration tests
4 Summary(pl.UTF-8):      GstValidate - zestaw narzędzi do uruchamiania testów integracyjnych GStreamera
5 Name:           gstreamer-validate
6 Version:        1.3.90
7 Release:        1
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://gstreamer.freedesktop.org/src/gst-validate/gst-validate-%{version}.tar.xz
11 # Source0-md5:  e1b1524794e7886a7c164dff5a244b7c
12 URL:            http://gstreamer.net/
13 BuildRequires:  autoconf >= 2.62
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  gettext-devel >= 0.17
16 BuildRequires:  glib2-devel >= 1:2.36.0
17 BuildRequires:  gobject-introspection-devel >= 0.6.3
18 BuildRequires:  gstreamer-devel >= %{gst_ver}
19 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
20 BuildRequires:  gtk-doc >= 1.3
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python >= 1:2.7.0
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       glib2 >= 1:2.36.0
27 Requires:       gstreamer >= %{gst_ver}
28 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
29 Requires:       python-modules >= 1:2.7
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The goal of GstValidate is to be able to detect when elements are not
34 behaving as expected and report it to the user so he knows how things
35 are supposed to work inside a GstPipeline. In the end, fixing issues
36 found by the tool will ensure that all elements behave all together in
37 the expected way.
38
39 %description -l pl.UTF-8
40 Celem GstValidate jest umożliwienie wykrycia sytuacji, kiedy elementy
41 nie zachowują się w sposób oczekiwany i zgłaszanie tego faktu
42 użytkownikowi tak, aby wiedział, jak powinny działać elementy wewnątrz
43 GstPipeline. W efekcie, poprawienie problemów wykrytych przez to
44 narzędzie zapewni, że wszystkie elementy razem będą się zachowywały w
45 sposób zgodny z oczekiwaniami.
46
47 %package devel
48 Summary:        Header files for GstValidate library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GstValidate
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       glib2-devel >= 1:2.36.0
53 Requires:       gstreamer-devel >= %{gst_ver}
54 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
55
56 %description devel
57 Header files for GstValidate library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki GstValidate.
61
62 %package apidocs
63 Summary:        API documentation for GstValidate library
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki GstValidate
65 Group:          Documentation
66 %if "%{_rpmversion}" >= "5"
67 BuildArch:      noarch
68 %endif
69
70 %description apidocs
71 API documentation for GstValidate library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki GstValidate.
75
76 %prep
77 %setup -q -n gst-validate-%{version}
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4 -I common/m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 # disable sphinx for now: docs/launcher/conf.py is missing
86 %configure \
87         --enable-gtk-doc \
88         --disable-silent-rules \
89         --disable-sphinx-doc \
90         --disable-static \
91         --with-html-dir=%{_gtkdocdir}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # obsoleted by pkg-config
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog NEWS README
113 %attr(755,root,root) %{_bindir}/gst-validate-1.0
114 %attr(755,root,root) %{_bindir}/gst-validate-launcher
115 %attr(755,root,root) %{_bindir}/gst-validate-media-check-1.0
116 %attr(755,root,root) %{_bindir}/gst-validate-transcoding-1.0
117 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-1.0.so.0
119 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-default-overrides-1.0.so.0
121 %{_libdir}/girepository-1.0/GstValidate-1.0.typelib
122 %{_libdir}/gst-validate-launcher
123 %dir %{_datadir}/gstreamer-1.0
124 %{_datadir}/gstreamer-1.0/validate-scenario
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so
129 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so
130 %{_includedir}/gstreamer-1.0/gst/validate
131 %{_pkgconfigdir}/gst-validate-1.0.pc
132 %{_datadir}/gir-1.0/GstValidate-1.0.gir
133
134 %files apidocs
135 %defattr(644,root,root,755)
136 %{_gtkdocdir}/gst-validate-1.0
This page took 0.065509 seconds and 3 git commands to generate.