]> git.pld-linux.org Git - packages/gstreamer0.10-plugins-ugly.git/blob - gstreamer-plugins-ugly.spec
- tabs in preamble
[packages/gstreamer0.10-plugins-ugly.git] / gstreamer-plugins-ugly.spec
1 #
2 # Conditional build:
3 %bcond_without  sid             # don't build sid plugin
4 %bcond_with     amr             # AMR-NB plugin
5 #
6 %define         gstname         gst-plugins-ugly
7 %define         gst_major_ver   0.10
8 %define         gst_req_ver     0.10.9
9 #
10 Summary:        Ugly GStreamer Streaming-media framework plugins
11 Summary(pl.UTF-8):      Brzydkie wtyczki do środowiska obróbki strumieni GStreamer
12 Name:           gstreamer-plugins-ugly
13 Version:        0.10.5
14 Release:        1
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-ugly/%{gstname}-%{version}.tar.bz2
18 # Source0-md5:  2e6bf35ebcb2ab508b43ef3aaee878ad
19 Patch0:         %{name}-bashish.patch
20 URL:            http://gstreamer.freedesktop.org/
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake >= 1.5
23 BuildRequires:  glib2-devel >= 1:2.12.1
24 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
25 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
26 BuildRequires:  gtk-doc >= 1.7
27 BuildRequires:  liboil-devel >= 0.3.9
28 BuildRequires:  libtool >= 1.4
29 BuildRequires:  pkgconfig >= 1:0.9.0
30 BuildRequires:  python >= 2.1
31 BuildRequires:  python-PyXML
32 ##
33 ## plugins
34 ##
35 BuildRequires:  a52dec-libs-devel
36 %{?with_amr:BuildRequires:      amrnb-devel}
37 BuildRequires:  lame-libs-devel
38 BuildRequires:  libdvdread-devel
39 BuildRequires:  libid3tag-devel >= 0.15
40 BuildRequires:  libmad-devel >= 0.15
41 %{?with_sid:BuildRequires:      libsidplay-devel >= 1.36.57}
42 BuildRequires:  mpeg2dec-devel >= 0.4.0
43 BuildRequires:  rpmbuild(macros) >= 1.98
44 Requires:       gstreamer >= %{gst_req_ver}
45 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
46 Obsoletes:      gstreamer-asf
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
50
51 %description
52 GStreamer is a streaming-media framework, based on graphs of filters
53 which operate on media data. Applications using this library can do
54 anything from real-time sound processing to playing videos, and just
55 about anything else media-related. Its plugin-based architecture means
56 that new data types or processing capabilities can be added simply by
57 installing new plugins.
58
59 %description -l pl.UTF-8
60 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
61 grafie filtrów operujących na danych medialnych. Aplikacje używające
62 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
63 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
64 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
65 nowych typów danych lub możliwości obróbki.
66
67 ##
68 ## Plugins
69 ##
70
71 %package -n gstreamer-a52dec
72 Summary:        GStreamer VOB decoder plugin
73 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca VOB
74 Group:          Libraries
75
76 %description -n gstreamer-a52dec
77 Plugin for decoding of VOB files.
78
79 %description -n gstreamer-a52dec -l pl.UTF-8
80 Wtyczka dekodująca pliki VOB.
81
82 %package -n gstreamer-amrnb
83 Summary:        GStreamer AMR-NB decoder plugin
84 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca pliki AMR-NB
85 Group:          Libraries
86
87 %description -n gstreamer-amrnb
88 Plugin for decoding of AMR-NB files.
89
90 %description -n gstreamer-amrnb -l pl.UTF-8
91 Wtyczka dekodująca pliki AMR-NB.
92
93 %package -n gstreamer-dvdread
94 Summary:        GStreamer plugin for DVD playback
95 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca DVD
96 Group:          Libraries
97 # for NLS (when non-empty *.mo appear)
98 #Requires:      %{name} = %{version}-%{release}
99 Requires:       gstreamer >= %{gst_req_ver}
100 Obsoletes:      gstreamer-libdvdread
101
102 %description -n gstreamer-dvdread
103 GStreamer plugin for DVD playback.
104
105 %description -n gstreamer-dvdread -l pl.UTF-8
106 Wtyczka odtwarzająca DVD do GStreamera.
107
108 %package -n gstreamer-lame
109 Summary:        GStreamer plugin encoding MP3 songs
110 Summary(pl.UTF-8):      Wtyczka do GStreamera kodująca pliki MP3
111 Group:          Libraries
112
113 %description -n gstreamer-lame
114 Plugin for encoding MP3 with lame.
115
116 %description -n gstreamer-lame -l pl.UTF-8
117 Wtyczka do GStreamera kodująca pliki MP3 przy użyciu lame.
118
119 %package -n gstreamer-mad
120 Summary:        GStreamer plugin using MAD for MP3 decoding
121 Summary(pl.UTF-8):      Wtyczka do GStreamera używająca MAD do dekodowania MP3
122 Group:          Libraries
123
124 %description -n gstreamer-mad
125 Plugin for playback of MP3 songs using the very good MAD library.
126
127 %description -n gstreamer-mad -l pl.UTF-8
128 Wtyczka do odtwarzania plików MP3 przy użyciu bardzo dobrej biblioteki
129 MAD.
130
131 %package -n gstreamer-mpeg
132 Summary:        GStreamer plugins for MPEG video playback and encoding
133 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca i kodująca obraz MPEG
134 Group:          Libraries
135
136 %description -n gstreamer-mpeg
137 Plugins for playing and encoding MPEG video.
138
139 %description -n gstreamer-mpeg -l pl.UTF-8
140 Wtyczki do odtwarzania i kodowania obrazu MPEG.
141
142 %package -n gstreamer-sid
143 Summary:        GStreamer Sid C64 music plugin
144 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca muzykę Sid C64
145 Group:          Libraries
146
147 %description -n gstreamer-sid
148 Plugin for playback of C64 SID format music files.
149
150 %description -n gstreamer-sid -l pl.UTF-8
151 Wtyczka do odtwarzania plików z muzyką w formacie C64 SID.
152
153 %prep
154 %setup -q -n %{gstname}-%{version}
155 %patch0 -p1
156
157 %build
158 %{__libtoolize}
159 %{__aclocal} -I m4 -I common/m4
160 %{__autoconf}
161 %{__autoheader}
162 %{__automake}
163 %configure \
164         %{!?with_amr:--disable-amrnb} \
165         %{!?with_sid:--disable-sidplay} \
166         --disable-static \
167         --enable-gtk-doc \
168         --with-html-dir=%{_gtkdocdir}
169
170 %{__make}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT
177
178 # We don't need plugins' *.la files
179 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
180
181 #%find_lang %{gstname}-%{gst_major_ver}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %files
187 # -f %{gstname}-%{gst_major_ver}.lang
188 %defattr(644,root,root,755)
189 %doc AUTHORS ChangeLog NEWS README RELEASE
190 %attr(755,root,root) %{gstlibdir}/libgstasf.so
191 %attr(755,root,root) %{gstlibdir}/libgstdvdlpcmdec.so
192 %attr(755,root,root) %{gstlibdir}/libgstdvdsub.so
193 %attr(755,root,root) %{gstlibdir}/libgstiec958.so
194 %attr(755,root,root) %{gstlibdir}/libgstrmdemux.so
195 %{_gtkdocdir}/gst-plugins-ugly-plugins-*
196
197 ##
198 ## Plugins
199 ##
200
201 %files -n gstreamer-a52dec
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{gstlibdir}/libgsta52dec.so
204
205 %if %{with amr}
206 %files -n gstreamer-amrnb
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{gstlibdir}/libgstamrnb.so
209 %endif
210
211 %files -n gstreamer-dvdread
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{gstlibdir}/libgstdvdread.so
214
215 %files -n gstreamer-lame
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{gstlibdir}/libgstlame.so
218
219 %files -n gstreamer-mad
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{gstlibdir}/libgstmad.so
222
223 %files -n gstreamer-mpeg
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{gstlibdir}/libgstmpeg2dec.so
226 %attr(755,root,root) %{gstlibdir}/libgstmpegaudioparse.so
227 %attr(755,root,root) %{gstlibdir}/libgstmpegstream.so
228
229 %if %{with sid}
230 %files -n gstreamer-sid
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{gstlibdir}/libgstsid.so
233 %endif
This page took 0.040168 seconds and 3 git commands to generate.