]> git.pld-linux.org Git - packages/gstreamer0.10-plugins-ugly.git/blob - gstreamer-plugins-ugly.spec
39e0df47a42bb3cedb2e7ab94dc11af95f4d0402
[packages/gstreamer0.10-plugins-ugly.git] / gstreamer-plugins-ugly.spec
1 #
2 # Conditional build:
3 %bcond_without  sid             # don't build sid plugin
4 #
5 %define         gstname         gst-plugins-ugly
6 %define         gst_major_ver   0.10
7 %define         gst_req_ver     0.10.1
8 #
9 Summary:        Ugly GStreamer Streaming-media framework plugins
10 Summary(pl):    Brzydkie wtyczki do ¶rodowiska obróbki strumieni GStreamer
11 Name:           gstreamer-plugins-ugly
12 Version:        0.10.1
13 Release:        0.1
14 License:        LGPL
15 Group:          Libraries
16 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-ugly/%{gstname}-%{version}.tar.bz2
17 # Source0-md5:  f2b16c8e15816cf3ee9a1ca540491fe9
18 Patch0:         %{name}-bashish.patch
19 URL:            http://gstreamer.freedesktop.org/
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake >= 1.5
22 BuildRequires:  glib2-devel >= 1:2.6.0
23 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
24 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
25 BuildRequires:  gtk-doc >= 1.3
26 BuildRequires:  liboil-devel >= 0.3.0
27 BuildRequires:  libtool >= 1.4
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 ##
30 ## plugins
31 ##
32 BuildRequires:  a52dec-libs-devel
33 BuildRequires:  amrnb-devel
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  libid3tag-devel >= 0.15
36 BuildRequires:  libmad-devel >= 0.15
37 %{?with_sid:BuildRequires:      libsidplay-devel >= 1.36.57}
38 BuildRequires:  mpeg2dec-devel >= 0.4.0
39 BuildRequires:  rpmbuild(macros) >= 1.98
40 Requires:       gstreamer >= %{gst_req_ver}
41 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
45
46 %description
47 GStreamer is a streaming-media framework, based on graphs of filters
48 which operate on media data. Applications using this library can do
49 anything from real-time sound processing to playing videos, and just
50 about anything else media-related. Its plugin-based architecture means
51 that new data types or processing capabilities can be added simply by
52 installing new plugins.
53
54 %description -l pl
55 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
56 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
57 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
58 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
59 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
60 nowych typów danych lub mo¿liwo¶ci obróbki.
61
62 ##
63 ## Plugins
64 ##
65
66 %package -n gstreamer-a52dec
67 Summary:        GStreamer VOB decoder plugin
68 Summary(pl):    Wtyczka do GStreamera dekoduj±ca VOB
69 Group:          Libraries
70
71 %description -n gstreamer-a52dec
72 Plugin for decoding of VOB files.
73
74 %description -n gstreamer-a52dec -l pl
75 Wtyczka dekoduj±ca pliki VOB.
76
77 %package -n gstreamer-amrnb
78 Summary:        GStreamer AMR-NB decoder plugin
79 Summary(pl):    Wtyczka do GStreamera dekoduj±ca pliki AMR-NB
80 Group:          Libraries
81
82 %description -n gstreamer-amrnb
83 Plugin for decoding of AMR-NB files.
84
85 %description -n gstreamer-amrnb -l pl
86 Wtyczka dekoduj±ca pliki AMR-NB.
87
88 %package -n gstreamer-lame
89 Summary:        GStreamer plugin encoding MP3 songs
90 Summary(pl):    Wtyczka do GStreamera koduj±ca pliki MP3
91 Group:          Libraries
92
93 %description -n gstreamer-lame
94 Plugin for encoding MP3 with lame.
95
96 %description -n gstreamer-lame -l pl
97 Wtyczka do GStreamera koduj±ca pliki MP3 przy u¿yciu lame.
98
99 %package -n gstreamer-mad
100 Summary:        GStreamer plugin using MAD for MP3 decoding
101 Summary(pl):    Wtyczka do GStreamera u¿ywaj±ca MAD do dekodowania MP3
102 Group:          Libraries
103
104 %description -n gstreamer-mad
105 Plugin for playback of MP3 songs using the very good MAD library.
106
107 %description -n gstreamer-mad -l pl
108 Wtyczka do odtwarzania plików MP3 przy u¿yciu bardzo dobrej biblioteki
109 MAD.
110
111 %package -n gstreamer-mpeg
112 Summary:        GStreamer plugins for MPEG video playback and encoding
113 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca i koduj±ca obraz MPEG
114 Group:          Libraries
115
116 %description -n gstreamer-mpeg
117 Plugins for playing and encoding MPEG video.
118
119 %description -n gstreamer-mpeg -l pl
120 Wtyczki do odtwarzania i kodowania obrazu MPEG.
121
122 %package -n gstreamer-sid
123 Summary:        GStreamer Sid C64 music plugin
124 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca muzykê Sid C64
125 Group:          Libraries
126
127 %description -n gstreamer-sid
128 Plugin for playback of C64 SID format music files.
129
130 %description -n gstreamer-sid -l pl
131 Wtyczka do odtwarzania plików z muzyk± w formacie C64 SID.
132
133 %prep
134 %setup -q -n %{gstname}-%{version}
135 %patch0 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal} -I m4 -I common/m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         %{!?with_sid:--disable-sidplay} \
145         --disable-static \
146         --enable-gtk-doc \
147         --with-html-dir=%{_gtkdocdir}
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 # We don't need plugins' *.la files
158 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog NEWS README RELEASE
166 %attr(755,root,root) %{gstlibdir}/libgstdvdlpcmdec.so
167 %attr(755,root,root) %{gstlibdir}/libgstiec958.so
168 %attr(755,root,root) %{gstlibdir}/libgstrmdemux.so
169 %{_gtkdocdir}/gst-plugins-ugly-plugins-*
170
171 ##
172 ## Plugins
173 ##
174
175 %files -n gstreamer-a52dec
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{gstlibdir}/libgsta52dec.so
178
179 %files -n gstreamer-amrnb
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{gstlibdir}/libgstamrnb.so
182
183 %files -n gstreamer-lame
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{gstlibdir}/libgstlame.so
186
187 %files -n gstreamer-mad
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{gstlibdir}/libgstmad.so
190
191 %files -n gstreamer-mpeg
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{gstlibdir}/libgstmpeg2dec.so
194 %attr(755,root,root) %{gstlibdir}/libgstmpegaudioparse.so
195 %attr(755,root,root) %{gstlibdir}/libgstmpegstream.so
196
197 %if %{with sid}
198 %files -n gstreamer-sid
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{gstlibdir}/libgstsid.so
201 %endif
This page took 0.033443 seconds and 2 git commands to generate.