]> git.pld-linux.org Git - packages/gstreamer-plugins-base.git/blob - gstreamer-plugins-base.spec
- added pc patch (write libexecdir consistent with actually used path, passed from...
[packages/gstreamer-plugins-base.git] / gstreamer-plugins-base.spec
1 # TODO: install_plugins_helper
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # hotdoc based API documentation (requires opengl library enabled)
5 %bcond_without  libvisual       # libvisual plugin
6 %bcond_without  opengl          # OpenGL support (gstgl library and opengl plugin)
7 %bcond_without  tremor          # ivorbisdec plugin (Tremor integer Ogg Vorbis decoder)
8
9 %define         gstname         gst-plugins-base
10 %define         gstmver         1.0
11 %define         gst_ver         1.20.0
12
13 Summary:        GStreamer Streaming-media framework base plugins
14 Summary(pl.UTF-8):      Podstawowe wtyczki do środowiska obróbki strumieni GStreamer
15 Name:           gstreamer-plugins-base
16 Version:        1.20.1
17 Release:        1
18 License:        LGPL v2+
19 Group:          Libraries
20 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-base/%{gstname}-%{version}.tar.xz
21 # Source0-md5:  a9d1a391bee0033f9801f9f3fce7aa1a
22 Patch0:         %{name}-pc.patch
23 URL:            https://gstreamer.freedesktop.org/
24 %{?with_apidocs:BuildRequires:  docbook-dtd412-xml}
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.56.0
27 %if %(locale -a | grep -q '^C.UTF-8$'; echo $?)
28 BuildRequires:  glibc-localedb-all
29 %endif
30 BuildRequires:  glibc-misc
31 BuildRequires:  gobject-introspection-devel >= 1.31.1
32 BuildRequires:  gstreamer-devel >= %{gst_ver}
33 BuildRequires:  gtk+3-devel >= 3.10
34 %{?with_apidocs:BuildRequires:  hotdoc >= 0.11.0}
35 BuildRequires:  iso-codes
36 BuildRequires:  libxml2-devel >= 2.0
37 BuildRequires:  meson >= 0.59
38 BuildRequires:  ninja >= 1.5
39 BuildRequires:  orc-devel >= 0.4.24
40 BuildRequires:  pkgconfig >= 1:0.9.0
41 BuildRequires:  python >= 2.1
42 BuildRequires:  rpm-build >= 4.6
43 BuildRequires:  rpmbuild(macros) >= 1.736
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xz
47 BuildRequires:  zlib-devel
48 ##
49 ## plugins
50 ##
51 BuildRequires:  alsa-lib-devel >= 1.0.11
52 BuildRequires:  cdparanoia-III-devel >= 2:10.2
53 BuildRequires:  libogg-devel >= 2:1.0
54 BuildRequires:  libtheora-devel >= 1.1
55 %{?with_libvisual:BuildRequires:        libvisual-devel >= 0.4.0}
56 BuildRequires:  libvorbis-devel >= 1:1.3.1
57 BuildRequires:  opus-devel >= 0.9.4
58 BuildRequires:  pango-devel >= 1:1.22.0
59 %{?with_tremor:BuildRequires:   tremor-devel}
60 BuildRequires:  udev-glib-devel >= 1:143
61 BuildRequires:  xorg-lib-libX11-devel
62 BuildRequires:  xorg-lib-libXext-devel
63 BuildRequires:  xorg-lib-libXv-devel
64 %if %{with opengl}
65 BuildRequires:  EGL-devel
66 BuildRequires:  Mesa-libgbm-devel
67 BuildRequires:  OpenGL-GLX-devel
68 BuildRequires:  OpenGLESv2-devel
69 # examples only: clutter clutter-glx clutter-x11
70 #BuildRequires: SDL-devel >= 1.2.0 clutter-devel >= 1.8 xorg-lib-libXcomposite-devel
71 BuildRequires:  graphene-devel >= 1.4.0
72 BuildRequires:  libdrm-devel >= 2.4.55
73 BuildRequires:  libpng-devel >= 1.0
74 BuildRequires:  libjpeg-devel
75 BuildRequires:  udev-glib-devel >= 1:147
76 # wayland-client >= 1.11, wayland-cursor >= 1.0
77 BuildRequires:  wayland-devel >= 1.11
78 BuildRequires:  wayland-egl-devel >= 1.0
79 BuildRequires:  wayland-protocols >= 1.15
80 %endif
81 # old GIR format
82 BuildConflicts: gstreamer-plugins-base-devel < 0.10.30
83 Requires:       glib2 >= 1:2.56.0
84 Requires:       gstreamer >= %{gst_ver}
85 Requires:       orc >= 0.4.24
86 Suggests:       iso-codes
87 # here go all the obsoleted gstreamer plugins
88 Obsoletes:      gstreamer-SDL < 0.10
89 Obsoletes:      gstreamer-artsd < 0.10
90 Obsoletes:      gstreamer-audio-effects < 0.10
91 Obsoletes:      gstreamer-audiofile < 0.10
92 Obsoletes:      gstreamer-audiosink-esd < 1.0
93 Obsoletes:      gstreamer-avi < 0.10
94 Obsoletes:      gstreamer-cdplayer < 0.10
95 Obsoletes:      gstreamer-colorspace < 0.10
96 Obsoletes:      gstreamer-daala < 1.16
97 Obsoletes:      gstreamer-divx < 1.0
98 Obsoletes:      gstreamer-festival < 0.10
99 Obsoletes:      gstreamer-hal < 1.0
100 Obsoletes:      gstreamer-interfaces < 0.10
101 Obsoletes:      gstreamer-interleave < 0.10
102 Obsoletes:      gstreamer-kio < 0.10
103 Obsoletes:      gstreamer-libdvdnav < 0.10
104 Obsoletes:      gstreamer-libfame < 0.10
105 Obsoletes:      gstreamer-media-info < 0.10
106 Obsoletes:      gstreamer-mikmod < 0.10
107 Obsoletes:      gstreamer-mimic < 1.12
108 Obsoletes:      gstreamer-misc < 0.8-1
109 Obsoletes:      gstreamer-musicbrainz < 1.0
110 Obsoletes:      gstreamer-mythtv < 1.0
111 Obsoletes:      gstreamer-oneton < 0.10
112 Obsoletes:      gstreamer-play < 0.10
113 Obsoletes:      gstreamer-plugins < 0.10
114 Obsoletes:      gstreamer-qcam < 0.10
115 Obsoletes:      gstreamer-sdl < 1.0
116 Obsoletes:      gstreamer-snapshot < 0.10
117 Obsoletes:      gstreamer-swfdec < 1.2
118 Obsoletes:      gstreamer-tcp < 0.10
119 Obsoletes:      gstreamer-timidity < 1.0
120 Obsoletes:      gstreamer-tuner < 0.10
121 Obsoletes:      gstreamer-v4l < 0.10
122 Obsoletes:      gstreamer-vbidec < 0.10
123 Obsoletes:      gstreamer-video4linux < 1.0
124 Obsoletes:      gstreamer-videosink-xv < 0.10
125 Obsoletes:      gstreamer-videotest < 0.10
126 Obsoletes:      gstreamer-xine < 0.10
127 Obsoletes:      gstreamer-xoverlay < 0.10
128 Obsoletes:      gstreamer-xvid < 1.0
129 Obsoletes:      gstreamer-yuv4mjpeg < 0.10
130 Obsoletes:      gtk-loaders-gstreamer < 0.10
131 # compositor plugin used to be in -plugins-bad 1.14.x
132 Conflicts:      gstreamer-plugins-bad < 1.16
133 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
134
135 %define         gstlibdir       %{_libdir}/gstreamer-%{gstmver}
136 %define         gstincludedir   %{_includedir}/gstreamer-%{gstmver}
137
138 %description
139 GStreamer is a streaming-media framework, based on graphs of filters
140 which operate on media data. Applications using this library can do
141 anything from real-time sound processing to playing videos, and just
142 about anything else media-related. Its plugin-based architecture means
143 that new data types or processing capabilities can be added simply by
144 installing new plugins.
145
146 %description -l pl.UTF-8
147 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
148 grafie filtrów operujących na danych medialnych. Aplikacje używające
149 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
150 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
151 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
152 nowych typów danych lub możliwości obróbki.
153
154 %package devel
155 Summary:        Include files for GStreamer streaming-media framework plugins
156 Summary(pl.UTF-8):      Pliki nagłówkowe do wtyczek środowiska obróbki strumieni GStreamer
157 Group:          Development/Libraries
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       glib2-devel >= 1:2.56.0
160 Requires:       gstreamer-devel >= %{gst_ver}
161 Requires:       orc-devel >= 0.4.24
162 Obsoletes:      gstreamer-interfaces-devel < 0.10
163 Obsoletes:      gstreamer-media-info-devel < 0.10
164 Obsoletes:      gstreamer-mixer-devel < 0.10
165 Obsoletes:      gstreamer-navigation-devel < 0.10
166 Obsoletes:      gstreamer-play-devel < 0.10
167 Obsoletes:      gstreamer-plugins-devel < 0.10
168 Obsoletes:      gstreamer-tuner-devel < 0.10
169 Obsoletes:      gstreamer-xoverlay-devel < 0.10
170 # gst/video/gstvideoaggregator.h existed in -plugins-bad 1.14.x
171 Conflicts:      gstreamer-plugins-bad-devel < 1.16
172
173 %description devel
174 Include files for GStreamer streaming-media framework plugins.
175
176 %description devel -l pl.UTF-8
177 Pliki nagłówkowe do wtyczek środowiska obróbki strumieni GStreamer.
178
179 %package apidocs
180 Summary:        GStreamer streaming-media framework plugins API documentation
181 Summary(pl.UTF-8):      Dokumentacja API wtyczek środowiska obróbki strumieni GStreamer
182 Group:          Documentation
183 Requires:       gstreamer-apidocs >= 1.18
184 Obsoletes:      gstreamer-plugins-gl-apidocs < 1.0
185 BuildArch:      noarch
186
187 %description apidocs
188 GStreamer streaming-media framework plugins API documentation.
189
190 %description apidocs -l pl.UTF-8
191 Dokumentacja API wtyczek środowiska obróbki strumieni GStreamer.
192
193 %package -n gstreamer-gl-libs
194 Summary:        GStreamer OpenGL plugins library
195 Summary(pl.UTF-8):      Biblioteka wtyczek OpenGL dla GStreamera
196 Group:          Libraries
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       graphene >= 1.4.0
199 Requires:       libdrm >= 2.4.55
200 Requires:       libpng >= 1.0
201 Requires:       udev-glib >= 1:147
202 Requires:       wayland >= 1.11
203 Conflicts:      gstreamer-plugins-bad < 1.14
204 Obsoletes:      gstreamer-imagesink-gl < 1.0
205 Obsoletes:      gstreamer-opengl < 1.14
206 Obsoletes:      gstreamer-plugins-gl < 1.0
207
208 %description -n gstreamer-gl-libs
209 OpenGL plugins library for GStreamer streaming media framework,
210 together with actual OpenGL plugin.
211
212 %description -n gstreamer-gl-libs -l pl.UTF-8
213 Biblioteka wtyczek OpenGL dla szkieletu strumieni multimedialnych
214 GStreamer wraz z właściwą wtyczką OpenGL.
215
216 %package -n gstreamer-gl-devel
217 Summary:        Header files for GStreamer OpenGL library
218 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GStreamera OpenGL
219 Group:          Development/Libraries
220 Requires:       %{name}-devel = %{version}-%{release}
221 Requires:       EGL-devel
222 Requires:       Mesa-libgbm-devel
223 Requires:       OpenGL-GLX-devel
224 Requires:       OpenGLESv2-devel
225 Requires:       gstreamer-gl-libs = %{version}-%{release}
226 Requires:       udev-glib-devel >= 1:147
227 Requires:       wayland-devel >= 1.11
228 Requires:       wayland-egl-devel >= 1.0
229 Requires:       xorg-lib-libX11-devel
230 Conflicts:      gstreamer-plugins-bad-devel < 1.14
231 Obsoletes:      gstreamer-plugins-gl-devel < 1.0
232
233 %description -n gstreamer-gl-devel
234 Header files for GStreamer OpenGL library.
235
236 %description -n gstreamer-gl-devel -l pl.UTF-8
237 Pliki nagłówkowe biblioteki GStreamera OpenGL.
238
239 ##
240 ## Plugins
241 ##
242
243 %package -n gstreamer-audiosink-alsa
244 Summary:        GStreamer plugins for the ALSA sound architecture
245 Summary(pl.UTF-8):      Wtyczki GStreamera do obsługi architektury ALSA
246 Group:          Libraries
247 Requires:       %{name} = %{version}-%{release}
248 Provides:       gstreamer-audiosink = %{version}
249 Obsoletes:      gstreamer-alsa < 0.10
250 Obsoletes:      gstreamer-audiosink-alsaspdif < 0.10.21
251
252 %description -n gstreamer-audiosink-alsa
253 Input and output plugin for the ALSA soundcard driver architecture.
254
255 %description -n gstreamer-audiosink-alsa -l pl.UTF-8
256 Wtyczka wejścia i wyjścia ze sterowników dźwiękowych architektury ALSA
257 do GStreamera.
258
259 %package -n gstreamer-audio-effects-base
260 Summary:        GStreamer base audio effects plugins
261 Summary(pl.UTF-8):      Podstawowe wtyczki efektów dźwiękowych do GStreamera
262 Group:          Libraries
263 Requires:       %{name} = %{version}-%{release}
264 Obsoletes:      gstreamer-audio-effects < 0.10
265
266 %description -n gstreamer-audio-effects-base
267 GStreamer base audio effects plugins.
268
269 %description -n gstreamer-audio-effects-base -l pl.UTF-8
270 Podstawowe wtyczki efektów dźwiękowych do GStreamera.
271
272 %package -n gstreamer-cdparanoia
273 Summary:        GStreamer plugin for CD audio input using CDParanoia IV
274 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu CDParanoia IV
275 Group:          Libraries
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       cdparanoia-III-libs >= 2:10.2
278
279 %description -n gstreamer-cdparanoia
280 Plugin for ripping audio tracks using cdparanoia under GStreamer.
281
282 %description -n gstreamer-cdparanoia -l pl.UTF-8
283 Wtyczka do ripowania ścieżek dźwiękowych pod GStreamerem za pomocą
284 cdparanoia.
285
286 %package -n gstreamer-ivorbisdec
287 Summary:        GStreamer plugin for decoding Ogg Vorbis audio files using Tremor
288 Summary(pl.UTF-8):      Wtyczka GStreamera dekodująca pliki dźwiękowe Ogg Vorbis (przy użyciu Tremora)
289 Group:          Libraries
290 Requires:       %{name} = %{version}-%{release}
291
292 %description -n gstreamer-ivorbisdec
293 Plugin for playing Ogg Vorbis audio files using Tremor.
294
295 %description -n gstreamer-ivorbisdec -l pl.UTF-8
296 Wtyczka do odtwarzania plików dźwiękowych Ogg Vorbis przy użyciu
297 Tremora.
298
299 %package -n gstreamer-libvisual
300 Summary:        GStreamer libvisual plugin
301 Summary(pl.UTF-8):      Wtyczka libvisual do GStreamera
302 Group:          Libraries
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       libvisual >= 0.4.0
305
306 %description -n gstreamer-libvisual
307 GStreamer libvisual plugin.
308
309 %description -n gstreamer-libvisual -l pl.UTF-8
310 Wtyczka libvisual do GStreamera.
311
312 %package -n gstreamer-opus
313 Summary:        GStreamer OPUS plugins
314 Summary(pl.UTF-8):      Wtyczki OPUS do GStreamera
315 Group:          Libraries
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       opus >= 0.9.4
318
319 %description -n gstreamer-opus
320 This package contains GStreamer plugins encoding/decoding OPUS codec
321 streams.
322
323 %description -n gstreamer-opus -l pl.UTF-8
324 Ten pakiet zawiera wtyczki do GStreamera obsługujące strumienie kodeka
325 OPUS.
326
327 %package -n gstreamer-pango
328 Summary:        GStreamer pango plugins
329 Summary(pl.UTF-8):      Wtyczki pango do GStreamera
330 Group:          Libraries
331 Requires:       %{name} = %{version}-%{release}
332 Requires:       pango >= 1:1.22.0
333
334 %description -n gstreamer-pango
335 This package contains textoverlay and timeoverlay GStreamer plugins.
336
337 %description -n gstreamer-pango -l pl.UTF-8
338 Ten pakiet zawiera wtyczki textoverlay i timeoverlay do GStreamera.
339
340 %package -n gstreamer-theora
341 Summary:        GStreamer Ogg Theora plugin
342 Summary(pl.UTF-8):      Wtyczka Ogg Theora do GStreamera
343 Group:          Libraries
344 Requires:       %{name} = %{version}-%{release}
345 Requires:       libtheora >= 1.1
346
347 %description -n gstreamer-theora
348 GStreamer Ogg Theora plugin.
349
350 %description -n gstreamer-theora -l pl.UTF-8
351 Wtyczka Ogg Theora do GStreamera.
352
353 %package -n gstreamer-video4linux
354 Summary:        GStreamer plugin for Video 4 Linux source
355 Summary(pl.UTF-8):      Wtyczka GStreamera dla źródła Video 4 Linux
356 Group:          Libraries
357 Requires:       %{name} = %{version}-%{release}
358 Requires:       udev-glib >= 1:143
359
360 %description -n gstreamer-video4linux
361 GStreamer plugin for Video 4 Linux source.
362
363 %description -n gstreamer-video4linux -l pl.UTF-8
364 Wtyczka GStreamera dla źródła Video 4 Linux.
365
366 %package -n gstreamer-vorbis
367 Summary:        GStreamer plugin for encoding and decoding Ogg Vorbis audio files
368 Summary(pl.UTF-8):      Wtyczki do GStreamera kodujące i dekodujące pliki dźwiękowe Ogg Vorbis
369 Group:          Libraries
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       libvorbis >= 1:1.3.1
372
373 %description -n gstreamer-vorbis
374 Plugins for creating and playing Ogg Vorbis audio files.
375
376 %description -n gstreamer-vorbis -l pl.UTF-8
377 Wtyczki do tworzenia i odtwarzania plików dźwiękowych Ogg Vorbis.
378
379 %package -n gstreamer-imagesink-x
380 Summary:        GStreamer XFree86/X.org output plugin
381 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu XFree86/X.org dla GStreamera
382 Group:          Libraries
383 Requires:       %{name} = %{version}-%{release}
384 Provides:       gstreamer-videosink = %{version}
385
386 %description -n gstreamer-imagesink-x
387 Standard XFree86/X.org image sink.
388
389 %description -n gstreamer-imagesink-x -l pl.UTF-8
390 Standardowa wtyczka wyjścia obrazu XFree86/X.org dla GStreamera.
391
392 %package -n gstreamer-imagesink-xv
393 Summary:        GStreamer Xvideo output plugin
394 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Xvideo dla GStreamera
395 Group:          Libraries
396 Requires:       %{name} = %{version}-%{release}
397 Provides:       gstreamer-videosink = %{version}
398
399 %description -n gstreamer-imagesink-xv
400 XFree86/X.org image sink via Xvideo extension.
401
402 %description -n gstreamer-imagesink-xv -l pl.UTF-8
403 Wtyczka wyjścia obrazu Xvideo dla GStreamera.
404
405 %prep
406 %setup -q -n %{gstname}-%{version}
407 %patch0 -p1
408
409 %build
410 %meson build \
411         --default-library=shared \
412         %{!?with_apidocs:-Ddoc=disabled} \
413         -Dexamples=disabled \
414         %{!?with_opengl:-Dgl=disabled} \
415         %{!?with_libvisual:-Dlibvisual=disabled} \
416         %{!?with_tremor:-Dtremor=disabled}
417
418 %ninja_build -C build
419
420 %if %{with apidocs}
421 cd build/docs
422 for config in *-doc.json ; do
423         LC_ALL=C.UTF-8 hotdoc run --conf-file "$config"
424 done
425 %endif
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429
430 %ninja_install -C build
431
432 %if %{with apidocs}
433 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
434 cp -pr build/docs/*-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
435 %endif
436
437 %find_lang %{gstname}-%{gstmver}
438
439 %clean
440 rm -rf $RPM_BUILD_ROOT
441
442 %post   -p /sbin/ldconfig
443 %postun -p /sbin/ldconfig
444
445 %post   -n gstreamer-gl-libs -p /sbin/ldconfig
446 %postun -n gstreamer-gl-libs -p /sbin/ldconfig
447
448 %files -f %{gstname}-%{gstmver}.lang
449 %defattr(644,root,root,755)
450 %doc AUTHORS ChangeLog NEWS README.md RELEASE
451 %attr(755,root,root) %{_bindir}/gst-device-monitor-%{gstmver}
452 %attr(755,root,root) %{_bindir}/gst-discoverer-%{gstmver}
453 %attr(755,root,root) %{_bindir}/gst-play-%{gstmver}
454 %attr(755,root,root) %{_libdir}/libgstallocators-%{gstmver}.so.*.*.*
455 %attr(755,root,root) %ghost %{_libdir}/libgstallocators-%{gstmver}.so.0
456 %attr(755,root,root) %{_libdir}/libgstapp-%{gstmver}.so.*.*.*
457 %attr(755,root,root) %ghost %{_libdir}/libgstapp-%{gstmver}.so.0
458 %attr(755,root,root) %{_libdir}/libgstaudio-%{gstmver}.so.*.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libgstaudio-%{gstmver}.so.0
460 %attr(755,root,root) %{_libdir}/libgstfft-%{gstmver}.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libgstfft-%{gstmver}.so.0
462 %attr(755,root,root) %{_libdir}/libgstpbutils-%{gstmver}.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libgstpbutils-%{gstmver}.so.0
464 %attr(755,root,root) %{_libdir}/libgstriff-%{gstmver}.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libgstriff-%{gstmver}.so.0
466 %attr(755,root,root) %{_libdir}/libgstrtp-%{gstmver}.so.*.*.*
467 %attr(755,root,root) %ghost %{_libdir}/libgstrtp-%{gstmver}.so.0
468 %attr(755,root,root) %{_libdir}/libgstrtsp-%{gstmver}.so.*.*.*
469 %attr(755,root,root) %ghost %{_libdir}/libgstrtsp-%{gstmver}.so.0
470 %attr(755,root,root) %{_libdir}/libgstsdp-%{gstmver}.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libgstsdp-%{gstmver}.so.0
472 %attr(755,root,root) %{_libdir}/libgsttag-%{gstmver}.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/libgsttag-%{gstmver}.so.0
474 %attr(755,root,root) %{_libdir}/libgstvideo-%{gstmver}.so.*.*.*
475 %attr(755,root,root) %ghost %{_libdir}/libgstvideo-%{gstmver}.so.0
476 %{_mandir}/man1/gst-device-monitor-%{gstmver}.1*
477 %{_mandir}/man1/gst-discoverer-%{gstmver}.1*
478 %{_mandir}/man1/gst-play-%{gstmver}.1*
479 # plugins with no external dependencies
480 %attr(755,root,root) %{gstlibdir}/libgstapp.so
481 %attr(755,root,root) %{gstlibdir}/libgstaudioconvert.so
482 %attr(755,root,root) %{gstlibdir}/libgstaudiomixer.so
483 %attr(755,root,root) %{gstlibdir}/libgstaudiorate.so
484 %attr(755,root,root) %{gstlibdir}/libgstaudiotestsrc.so
485 %attr(755,root,root) %{gstlibdir}/libgstcompositor.so
486 %attr(755,root,root) %{gstlibdir}/libgstencoding.so
487 %attr(755,root,root) %{gstlibdir}/libgstgio.so
488 %attr(755,root,root) %{gstlibdir}/libgstoverlaycomposition.so
489 %attr(755,root,root) %{gstlibdir}/libgstpbtypes.so
490 %attr(755,root,root) %{gstlibdir}/libgstplayback.so
491 %attr(755,root,root) %{gstlibdir}/libgstrawparse.so
492 %attr(755,root,root) %{gstlibdir}/libgstsubparse.so
493 %attr(755,root,root) %{gstlibdir}/libgsttcp.so
494 %attr(755,root,root) %{gstlibdir}/libgsttypefindfunctions.so
495 %attr(755,root,root) %{gstlibdir}/libgstvideoconvert.so
496 %attr(755,root,root) %{gstlibdir}/libgstvideorate.so
497 %attr(755,root,root) %{gstlibdir}/libgstvideoscale.so
498 %attr(755,root,root) %{gstlibdir}/libgstvideotestsrc.so
499 %{_libdir}/girepository-1.0/GstAllocators-%{gstmver}.typelib
500 %{_libdir}/girepository-1.0/GstApp-%{gstmver}.typelib
501 %{_libdir}/girepository-1.0/GstAudio-%{gstmver}.typelib
502 %{_libdir}/girepository-1.0/GstPbutils-%{gstmver}.typelib
503 %{_libdir}/girepository-1.0/GstRtp-%{gstmver}.typelib
504 %{_libdir}/girepository-1.0/GstRtsp-%{gstmver}.typelib
505 %{_libdir}/girepository-1.0/GstSdp-%{gstmver}.typelib
506 %{_libdir}/girepository-1.0/GstTag-%{gstmver}.typelib
507 %{_libdir}/girepository-1.0/GstVideo-%{gstmver}.typelib
508 %{_datadir}/gst-plugins-base
509
510 %files devel
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_libdir}/libgstallocators-%{gstmver}.so
513 %attr(755,root,root) %{_libdir}/libgstapp-%{gstmver}.so
514 %attr(755,root,root) %{_libdir}/libgstaudio-%{gstmver}.so
515 %attr(755,root,root) %{_libdir}/libgstfft-%{gstmver}.so
516 %attr(755,root,root) %{_libdir}/libgstpbutils-%{gstmver}.so
517 %attr(755,root,root) %{_libdir}/libgstriff-%{gstmver}.so
518 %attr(755,root,root) %{_libdir}/libgstrtp-%{gstmver}.so
519 %attr(755,root,root) %{_libdir}/libgstrtsp-%{gstmver}.so
520 %attr(755,root,root) %{_libdir}/libgstsdp-%{gstmver}.so
521 %attr(755,root,root) %{_libdir}/libgsttag-%{gstmver}.so
522 %attr(755,root,root) %{_libdir}/libgstvideo-%{gstmver}.so
523 %{gstincludedir}/gst/allocators
524 %{gstincludedir}/gst/app
525 %{gstincludedir}/gst/audio
526 %{gstincludedir}/gst/fft
527 %{gstincludedir}/gst/pbutils
528 %{gstincludedir}/gst/riff
529 %{gstincludedir}/gst/rtp
530 %{gstincludedir}/gst/rtsp
531 %{gstincludedir}/gst/sdp
532 %{gstincludedir}/gst/tag
533 %{gstincludedir}/gst/video
534 %{_pkgconfigdir}/gstreamer-allocators-%{gstmver}.pc
535 %{_pkgconfigdir}/gstreamer-app-%{gstmver}.pc
536 %{_pkgconfigdir}/gstreamer-audio-%{gstmver}.pc
537 %{_pkgconfigdir}/gstreamer-fft-%{gstmver}.pc
538 %{_pkgconfigdir}/gstreamer-pbutils-%{gstmver}.pc
539 %{_pkgconfigdir}/gstreamer-plugins-base-%{gstmver}.pc
540 %{_pkgconfigdir}/gstreamer-riff-%{gstmver}.pc
541 %{_pkgconfigdir}/gstreamer-rtp-%{gstmver}.pc
542 %{_pkgconfigdir}/gstreamer-rtsp-%{gstmver}.pc
543 %{_pkgconfigdir}/gstreamer-sdp-%{gstmver}.pc
544 %{_pkgconfigdir}/gstreamer-tag-%{gstmver}.pc
545 %{_pkgconfigdir}/gstreamer-video-%{gstmver}.pc
546 %{_datadir}/gir-1.0/GstAllocators-%{gstmver}.gir
547 %{_datadir}/gir-1.0/GstApp-%{gstmver}.gir
548 %{_datadir}/gir-1.0/GstAudio-%{gstmver}.gir
549 %{_datadir}/gir-1.0/GstPbutils-%{gstmver}.gir
550 %{_datadir}/gir-1.0/GstRtp-%{gstmver}.gir
551 %{_datadir}/gir-1.0/GstRtsp-%{gstmver}.gir
552 %{_datadir}/gir-1.0/GstSdp-%{gstmver}.gir
553 %{_datadir}/gir-1.0/GstTag-%{gstmver}.gir
554 %{_datadir}/gir-1.0/GstVideo-%{gstmver}.gir
555
556 %if %{with apidocs}
557 %files apidocs
558 %defattr(644,root,root,755)
559 %{_docdir}/gstreamer-%{gstmver}/adder-doc
560 %{_docdir}/gstreamer-%{gstmver}/allocators-doc
561 %{_docdir}/gstreamer-%{gstmver}/alsa-doc
562 %{_docdir}/gstreamer-%{gstmver}/app-doc
563 %{_docdir}/gstreamer-%{gstmver}/applib-doc
564 %{_docdir}/gstreamer-%{gstmver}/audio-doc
565 %{_docdir}/gstreamer-%{gstmver}/audioconvert-doc
566 %{_docdir}/gstreamer-%{gstmver}/audiomixer-doc
567 %{_docdir}/gstreamer-%{gstmver}/audiorate-doc
568 %{_docdir}/gstreamer-%{gstmver}/audioresample-doc
569 %{_docdir}/gstreamer-%{gstmver}/audiotestsrc-doc
570 %{_docdir}/gstreamer-%{gstmver}/cdparanoia-doc
571 %{_docdir}/gstreamer-%{gstmver}/compositor-doc
572 %{_docdir}/gstreamer-%{gstmver}/encoding-doc
573 %{_docdir}/gstreamer-%{gstmver}/gio-doc
574 %{_docdir}/gstreamer-%{gstmver}/gl-doc
575 %{_docdir}/gstreamer-%{gstmver}/gl-egl-doc
576 %{_docdir}/gstreamer-%{gstmver}/gl-wayland-doc
577 %{_docdir}/gstreamer-%{gstmver}/gl-x11-doc
578 %{_docdir}/gstreamer-%{gstmver}/libvisual-doc
579 %{_docdir}/gstreamer-%{gstmver}/ogg-doc
580 %{_docdir}/gstreamer-%{gstmver}/opengl-doc
581 %{_docdir}/gstreamer-%{gstmver}/opus-doc
582 %{_docdir}/gstreamer-%{gstmver}/overlaycomposition-doc
583 %{_docdir}/gstreamer-%{gstmver}/pango-doc
584 %{_docdir}/gstreamer-%{gstmver}/pbtypes-doc
585 %{_docdir}/gstreamer-%{gstmver}/pbutils-doc
586 %{_docdir}/gstreamer-%{gstmver}/playback-doc
587 %{_docdir}/gstreamer-%{gstmver}/rawparse-doc
588 %{_docdir}/gstreamer-%{gstmver}/riff-doc
589 %{_docdir}/gstreamer-%{gstmver}/rtplib-doc
590 %{_docdir}/gstreamer-%{gstmver}/rtsplib-doc
591 %{_docdir}/gstreamer-%{gstmver}/sdp-doc
592 %{_docdir}/gstreamer-%{gstmver}/subparse-doc
593 %{_docdir}/gstreamer-%{gstmver}/tag-doc
594 %{_docdir}/gstreamer-%{gstmver}/tcp-doc
595 %{_docdir}/gstreamer-%{gstmver}/theora-doc
596 %{_docdir}/gstreamer-%{gstmver}/typefindfunctions-doc
597 %{_docdir}/gstreamer-%{gstmver}/video-doc
598 %{_docdir}/gstreamer-%{gstmver}/videoconvert-doc
599 %{_docdir}/gstreamer-%{gstmver}/videorate-doc
600 %{_docdir}/gstreamer-%{gstmver}/videoscale-doc
601 %{_docdir}/gstreamer-%{gstmver}/videotestsrc-doc
602 %{_docdir}/gstreamer-%{gstmver}/volume-doc
603 %{_docdir}/gstreamer-%{gstmver}/vorbis-doc
604 %{_docdir}/gstreamer-%{gstmver}/ximagesink-doc
605 %{_docdir}/gstreamer-%{gstmver}/xvimagesink-doc
606 %endif
607
608 %if %{with opengl}
609 %files -n gstreamer-gl-libs
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/libgstgl-%{gstmver}.so.*.*.*
612 %attr(755,root,root) %ghost %{_libdir}/libgstgl-%{gstmver}.so.0
613 %{_libdir}/girepository-1.0/GstGL-%{gstmver}.typelib
614 %{_libdir}/girepository-1.0/GstGLEGL-%{gstmver}.typelib
615 %{_libdir}/girepository-1.0/GstGLWayland-%{gstmver}.typelib
616 %{_libdir}/girepository-1.0/GstGLX11-%{gstmver}.typelib
617 # plugin itself
618 %attr(755,root,root) %{gstlibdir}/libgstopengl.so
619
620 %files -n gstreamer-gl-devel
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/libgstgl-%{gstmver}.so
623 # currently only gl lib provides header in this location, so package top dirs here
624 %dir %{gstlibdir}/include
625 %dir %{gstlibdir}/include/gst
626 %{gstlibdir}/include/gst/gl
627 %{gstincludedir}/gst/gl
628 %{_datadir}/gir-1.0/GstGL-%{gstmver}.gir
629 %{_datadir}/gir-1.0/GstGLEGL-%{gstmver}.gir
630 %{_datadir}/gir-1.0/GstGLWayland-%{gstmver}.gir
631 %{_datadir}/gir-1.0/GstGLX11-%{gstmver}.gir
632 %{_pkgconfigdir}/gstreamer-gl-%{gstmver}.pc
633 %{_pkgconfigdir}/gstreamer-gl-egl-%{gstmver}.pc
634 %{_pkgconfigdir}/gstreamer-gl-prototypes-%{gstmver}.pc
635 %{_pkgconfigdir}/gstreamer-gl-wayland-%{gstmver}.pc
636 %{_pkgconfigdir}/gstreamer-gl-x11-%{gstmver}.pc
637 %endif
638
639 ##
640 ## Plugins
641 ##
642
643 %files -n gstreamer-audiosink-alsa
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{gstlibdir}/libgstalsa.so
646
647 %files -n gstreamer-audio-effects-base
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{gstlibdir}/libgstadder.so
650 %attr(755,root,root) %{gstlibdir}/libgstaudioresample.so
651 %attr(755,root,root) %{gstlibdir}/libgstvolume.so
652
653 %files -n gstreamer-cdparanoia
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{gstlibdir}/libgstcdparanoia.so
656
657 %if %{with tremor}
658 %files -n gstreamer-ivorbisdec
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{gstlibdir}/libgstivorbisdec.so
661 %endif
662
663 %if %{with libvisual}
664 %files -n gstreamer-libvisual
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{gstlibdir}/libgstlibvisual.so
667 %endif
668
669 %files -n gstreamer-opus
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{gstlibdir}/libgstopus.so
672
673 %files -n gstreamer-pango
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{gstlibdir}/libgstpango.so
676
677 %files -n gstreamer-theora
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{gstlibdir}/libgsttheora.so
680
681 %files -n gstreamer-vorbis
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{gstlibdir}/libgstvorbis.so
684 %attr(755,root,root) %{gstlibdir}/libgstogg.so
685
686 %files -n gstreamer-imagesink-x
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{gstlibdir}/libgstximagesink.so
689
690 %files -n gstreamer-imagesink-xv
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{gstlibdir}/libgstxvimagesink.so
This page took 0.092461 seconds and 3 git commands to generate.