]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- BR: jasper-devel, twolame-devel
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # - new plugins:
3 #   - mplex (waiting for mjpegtools 1.9.0)
4 #   - ivorbisdec (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
5 #   - theoraexpdec (BR: libtheora-exp >= 1.0beta3, but currently disabled)
6 # - system libmodplug?
7 #
8 # Conditional build:
9 %bcond_without  cdaudio         # don't build cdaudio plugin
10 %bcond_without  dirac           # don't build Dirac plugin
11 %bcond_without  directfb        # don't build directfb videosink plugin
12 %bcond_without  dts             # don't build DTS plugin
13 %bcond_without  faad            # don't build faad plugin
14 %bcond_without  gsm             # don't build gsm plugin
15 %bcond_without  jack            # don't build JACK audio plugin
16 %bcond_without  ladspa          # don't build ladspa plugin
17 %bcond_without  mjpegtools      # don't build mpeg2enc plugin
18 %bcond_without  mms             # don't build mms plugin
19 %bcond_without  musepack        # don't build musepack plugin
20 %bcond_without  neon            # don't build neonhttpsrc plugin
21 %bcond_without  ofa             # don't build OFA plugin
22 %bcond_without  sdl             # don't build sdl plugin
23 %bcond_with     swfdec          # swfdec plugin
24 %bcond_without  spc             # don't build spc plugin
25 %bcond_without  wavpack         # don't build wavpack plugin
26 %bcond_without  xvid            # don't build XviD plugin
27 %bcond_with     amr             # build amrwb plugin
28 %bcond_with     divx4linux      # build divx4linux plugins
29 #
30 %define         gstname         gst-plugins-bad
31 %define         gst_major_ver   0.10
32 %define         gst_req_ver     0.10.20
33 #
34 Summary:        Bad GStreamer Streaming-media framework plugins
35 Summary(pl.UTF-8):      Złe wtyczki do środowiska obróbki strumieni GStreamer
36 Name:           gstreamer-plugins-bad
37 Version:        0.10.9
38 Release:        1
39 License:        LGPL v2+
40 Group:          Libraries
41 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
42 # Source0-md5:  ff555a86e74a9249e56b43405c8df3e4
43 Patch0:         %{name}-bashish.patch
44 Patch1:         %{name}-libdts.patch
45 Patch2:         %{name}-divx4linux.patch
46 Patch4:         %{name}-timidity.patch
47 Patch5:         %{name}-nas.patch
48 Patch6:         %{name}-x264.patch
49 URL:            http://gstreamer.freedesktop.org/
50 BuildRequires:  autoconf >= 2.59-9
51 BuildRequires:  automake >= 1.6
52 BuildRequires:  glib2-devel >= 1:2.12.0
53 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
54 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
55 BuildRequires:  gtk-doc >= 1.6
56 BuildRequires:  liboil-devel >= 0.3.6
57 BuildRequires:  libtool >= 1.4
58 BuildRequires:  pkgconfig >= 1:0.9.0
59 BuildRequires:  python-PyXML
60 BuildRequires:  rpmbuild(macros) >= 1.98
61 ##
62 ## plugins
63 ##
64 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
65 BuildRequires:  OpenGL-devel
66 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
67 BuildRequires:  alsa-lib-devel >= 0.9.1
68 %{?with_amr:BuildRequires:      amrwb-devel}
69 BuildRequires:  bzip2-devel
70 %{?with_dirac:BuildRequires:    dirac-devel >= 0.9}
71 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
72 BuildRequires:  faac-devel
73 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
74 BuildRequires:  gmyth-devel >= 0.7
75 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.99.10}
76 BuildRequires:  jasper-devel
77 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
78 %{?with_cdaudio:BuildRequires:  libcdaudio-devel}
79 BuildRequires:  libdc1394-devel >= 2.0.0
80 %{?with_dts:BuildRequires:      libdts-devel}
81 BuildRequires:  libdvdnav-devel >= 0.1.7
82 %{?with_gsm:BuildRequires:      libgsm-devel}
83 %{?with_mms:BuildRequires:      libmms-devel >= 0.2}
84 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
85 BuildRequires:  libmusicbrainz-devel >= 2.1.0
86 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
87 %{?with_spc:BuildRequires:      libopenspc-devel >= 0.3.99}
88 # for modplug and libSoundTouch
89 BuildRequires:  libstdc++-devel
90 BuildRequires:  libtimidity-devel
91 BuildRequires:  libx264-devel >= 0.1.2
92 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel < 1.9.0}
93 %{?with_mjpegtools:BuildRequires:       mjpegtools-devel >= 1.8.0-0.2}
94 %{?with_neon:BuildRequires:     neon-devel >= 0.26}
95 BuildRequires:  libsndfile-devel
96 BuildRequires:  nas-devel
97 BuildRequires:  soundtouch-devel >= 1.3.1
98 %if %{with swfdec}
99 BuildRequires:  swfdec-devel < 0.4.0
100 BuildRequires:  swfdec-devel >= 0.3.6
101 %endif
102 BuildRequires:  twolame-devel
103 BuildRequires:  wildmidi-devel
104 BuildRequires:  xorg-lib-libX11-devel
105 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
106 Requires:       gstreamer >= %{gst_req_ver}
107 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
108 Obsoletes:      gstreamer-quicktime
109 Obsoletes:      gstreamer-vcd
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
113
114 %description
115 GStreamer is a streaming-media framework, based on graphs of filters
116 which operate on media data. Applications using this library can do
117 anything from real-time sound processing to playing videos, and just
118 about anything else media-related. Its plugin-based architecture means
119 that new data types or processing capabilities can be added simply by
120 installing new plugins.
121
122 %description -l pl.UTF-8
123 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
124 grafie filtrów operujących na danych medialnych. Aplikacje używające
125 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
126 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
127 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
128 nowych typów danych lub możliwości obróbki.
129
130 %package devel
131 Summary:        Header files and API documentation for gstapp library
132 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API biblioteki gstapp
133 Group:          Development/Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description devel
137 Header files and API documentation for gstapp library.
138
139 %description devel -l pl.UTF-8
140 Pliki nagłówkowe i dokumentacja API biblioteki gstapp.
141
142 ## Plugins ##
143
144 %package -n gstreamer-aac
145 Summary:        GStreamer plugin for AAC audio encoding and decoding
146 Summary(pl.UTF-8):      Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
147 Group:          Libraries
148 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
149
150 %description -n gstreamer-aac
151 GStreamer plugin for AAC audio encoding and decoding.
152
153 %description -n gstreamer-aac -l pl.UTF-8
154 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
155
156 %package -n gstreamer-amrwb
157 Summary:        GStreamer plugin for AMR-WB audio encoding and decoding
158 Summary(pl.UTF-8):      Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie AMR-WB
159 Group:          Libraries
160 Requires:       gstreamer >= %{gst_req_ver}
161
162 %description -n gstreamer-amrwb
163 GStreamer plugin for AMR-WB audio encoding and decoding.
164
165 %description -n gstreamer-amrwb -l pl.UTF-8
166 Wtyczka GStreamera do kodowania i dekodowania dźwięku w formacie
167 AMR-WB.
168
169 %package -n gstreamer-audio-effects-bad
170 Summary:        Bad GStreamer audio effects plugins
171 Summary(pl.UTF-8):      Złe wtyczki efektów dźwiękowych do GStreamera
172 Group:          Libraries
173 Requires:       gstreamer >= %{gst_req_ver}
174 Obsoletes:      gstreamer-audio-effects
175
176 %description -n gstreamer-audio-effects-bad
177 Bad GStreamer audio effects plugins.
178
179 %description -n gstreamer-audio-effects-bad -l pl.UTF-8
180 Złe wtyczki efektów dźwiękowych do GStreamera.
181
182 %package -n gstreamer-audiosink-alsaspdif
183 Summary:        GStreamer ALSA plugin for S/PDIF output
184 Summary(pl.UTF-8):      Wtyczka ALSA GStreamera do wyjścia S/PDIF
185 Group:          Libraries
186 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
187 Provides:       gstreamer-audiosink = %{version}
188
189 %description -n gstreamer-audiosink-alsaspdif
190 GStreamer ALSA plugin for S/PDIF output.
191
192 %description -n gstreamer-audiosink-alsaspdif -l pl.UTF-8
193 Wtyczka ALSA GStreamera do wyjścia S/PDIF.
194
195 %package -n gstreamer-audiosink-nas
196 Summary:        GStreamer NAS audio output plugin
197 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku NAS dla GStreamera
198 Group:          Libraries
199 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
200 Provides:       gstreamer-audiosink = %{version}
201 Obsoletes:      gstreamer-nas
202
203 %description -n gstreamer-audiosink-nas
204 GStreamer NAS audio output plugin.
205
206 %description -n gstreamer-audiosink-nas -l pl.UTF-8
207 Wtyczka wyjścia dźwięku NAS dla GStreamera.
208
209 %package -n gstreamer-cdaudio
210 Summary:        GStreamer plugin for CD audio input using libcdaudio
211 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdaudio
212 Group:          Libraries
213 Requires:       gstreamer >= %{gst_req_ver}
214
215 %description -n gstreamer-cdaudio
216 Plugin for playing audio tracks using libcdaudio under GStreamer.
217
218 %description -n gstreamer-cdaudio -l pl.UTF-8
219 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
220 libcdaudio.
221
222 %package -n gstreamer-dc1394
223 Summary:        GStreamer 1394 IIDC (Firewire digital cameras) video source plugin
224 Summary(pl.UTF-8):      Wtyczka źródła obrazu 1394 IIDC (z kamer cyfrowych Firewire) do GStreamera
225 Group:          Libraries
226 Requires:       gstreamer >= %{gst_req_ver}
227
228 %description -n gstreamer-dc1394
229 GStreamer 1394 IIDC (Firewire digital cameras) video source plugin.
230
231 %description -n gstreamer-dc1394 -l pl.UTF-8
232 Wtyczka źródła obrazu 1394 IIDC (z kamer cyfrowych Firewire) do GStreamera.
233
234 %package -n gstreamer-dirac
235 Summary:        GStreamer Dirac plugin
236 Summary(pl.UTF-8):      Wtyczka Dirac do GStreamera
237 Group:          Libraries
238 Requires:       gstreamer >= %{gst_req_ver}
239 Requires:       dirac >= 0.9
240
241 %description -n gstreamer-dirac
242 GStreamer Dirac video decoder/encoder plugin.
243
244 %description -n gstreamer-dirac -l pl.UTF-8
245 Wtyczka dekodująca i kodująca obraz Dirac do GStreamera.
246
247 %package -n gstreamer-divx
248 Summary:        GStreamer divx plugin
249 Summary(pl.UTF-8):      Wtyczka divx do GStreamera
250 Group:          Libraries
251 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
252
253 %description -n gstreamer-divx
254 GStreamer divx plugin.
255
256 %description -n gstreamer-divx -l pl.UTF-8
257 Wtyczka divx do GStreamera.
258
259 %package -n gstreamer-dts
260 Summary:        GStreamer DTS plugin
261 Summary(pl.UTF-8):      Wtyczka DTS do GStreamera
262 Group:          Libraries
263 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
264
265 %description -n gstreamer-dts
266 Plugin for DTS Coherent Acoustics support.
267
268 %description -n gstreamer-dts -l pl.UTF-8
269 Wtyczka do GStreamera obsługująca DTS Coherent Acoustics.
270
271 %package -n gstreamer-gsm
272 Summary:        GStreamer plugin for GSM lossy audio format
273 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca stratny format dźwięku GSM
274 Group:          Libraries
275 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
276
277 %description -n gstreamer-gsm
278 Output plugin for GStreamer to convert to GSM lossy audio format.
279
280 %description -n gstreamer-gsm -l pl.UTF-8
281 Wtyczka wyjścia dźwięku GSteamera konwertująca do stratnego formatu
282 GSM.
283
284 %package -n gstreamer-jack
285 Summary:        GStreamer plugin for the JACK Sound Server
286 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
287 Group:          Libraries
288 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
289 Provides:       gstreamer-audiosink = %{version}
290
291 %description -n gstreamer-jack
292 Plugin for the JACK professional sound server.
293
294 %description -n gstreamer-jack -l pl.UTF-8
295 Wtyczka dla profesjonalnego serwera dźwięku JACK.
296
297 %package -n gstreamer-ladspa
298 Summary:        GStreamer wrapper for LADSPA plugins
299 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
300 Group:          Libraries
301 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
302
303 %description -n gstreamer-ladspa
304 Plugin which wraps LADSPA plugins for use by GStreamer applications.
305
306 %description -n gstreamer-ladspa -l pl.UTF-8
307 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
308 GStreamera.
309
310 %package -n gstreamer-mjpegtools
311 Summary:        GStreamer mpeg2enc plugin
312 Summary(pl.UTF-8):      Wtyczka mpeg2enc do GStreamera
313 Group:          Libraries
314
315 %description -n gstreamer-mjpegtools
316 GStreamer mpeg2enc plugin (based on mjpegtools libraries).
317
318 %description -n gstreamer-mjpegtools -l pl.UTF-8
319 Wtyczka mpeg2enc do GStreamera (oparta na bibliotekach mjpegtools).
320
321 %package -n gstreamer-mms
322 Summary:        GStreamer mms plugin
323 Summary(pl.UTF-8):      Wtyczka mms do GStreamera
324 Group:          Libraries
325 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
326
327 %description -n gstreamer-mms
328 GStreamer mms plugin.
329
330 %description -n gstreamer-mms -l pl.UTF-8
331 Wtyczka mms do GStreamera.
332
333 %package -n gstreamer-musepack
334 Summary:        GStreamer musepack plugin
335 Summary(pl.UTF-8):      Wtyczka musepack do GStreamera
336 Group:          Libraries
337 Requires:       gstreamer >= %{gst_req_ver}
338
339 %description -n gstreamer-musepack
340 GStreamer musepack plugin.
341
342 %description -n gstreamer-musepack -l pl.UTF-8
343 Wtyczka musepack do GStreamera.
344
345 %package -n gstreamer-mythtv
346 Summary:        GStreamer MythTV plugin
347 Summary(pl.UTF-8):      Wtyczka MythTV do GStreamera
348 Group:          Libraries
349 Requires:       gstreamer >= %{gst_req_ver}
350
351 %description -n gstreamer-mythtv
352 GStreamer MythTV plugin.
353
354 %description -n gstreamer-mythtv -l pl.UTF-8
355 Wtyczka MythTV do GStreamera.
356
357 %package -n gstreamer-musicbrainz
358 Summary:        GStreamer musicbrainz plugin
359 Summary(pl.UTF-8):      Wtyczka musicbrainz do GStreamera
360 Group:          Libraries
361 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
362
363 %description -n gstreamer-musicbrainz
364 GStreamer musicbrainz plugin - a TRM signature producer.
365
366 %description -n gstreamer-musicbrainz -l pl.UTF-8
367 Wtyczka musicbrainz do GStreamera, tworząca sygnatury TRM.
368
369 %package -n gstreamer-neon
370 Summary:        GStreamer neon HTTP source plugin
371 Summary(pl.UTF-8):      Wtyczka źródła HTTP neon do GStreamera
372 Group:          Libraries
373 Requires:       gstreamer >= %{gst_req_ver}
374
375 %description -n gstreamer-neon
376 GStreamer neon HTTP source plugin.
377
378 %description -n gstreamer-neon -l pl.UTF-8
379 Wtyczka źródła HTTP neon do GStreamera.
380
381 %package -n gstreamer-ofa
382 Summary:        GStreamer OFA fingerprint plugin
383 Summary(pl.UTF-8):      Wtyczka odcisków OFA do GStreamera
384 Group:          Libraries
385 Requires:       gstreamer >= %{gst_req_ver}
386 Requires:       libofa >= 0.9.3
387
388 %description -n gstreamer-ofa
389 GStreamer OFA plugin to calculate MusicIP fingerprints from audio
390 files.
391
392 %description -n gstreamer-ofa -l pl.UTF-8
393 Wtyczka OFA do GStreamera służąca do obliczania odcisków MusicIP
394 plików dźwiękowych.
395
396 %package -n gstreamer-oss4
397 Summary:        GStreamer OSS 4 audio sink, source and mixer plugin
398 Summary(pl.UTF-8):      Wtyczka wyjścia, wejścia i miksera dźwięku OSS 4 do GStreamera
399 Group:          Libraries
400 # for locales (when added to POTFILES)
401 #Requires:      %{name} = %{version}-%{release}
402 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
403 Provides:       gstreamer-audiosink = %{version}
404
405 %description -n gstreamer-oss4
406 GStreamer OSS (Open Sound System) 4 audio input/output/mixer plugin.
407
408 %description -n gstreamer-oss4 -l pl.UTF-8
409 Wtyczka wejścia/wyjścia/miksera dźwięku OSS (Open Sound System) 4 do
410 GStreamera.
411
412 %package -n gstreamer-resindvd
413 Summary:        GStreamer Resin DVD playback plugin
414 Summary(pl.UTF-8):      Wtyczka odtwarzania Resin DVD do GStreamera
415 Group:          Libraries
416 Requires:       gstreamer >= %{gst_req_ver}
417
418 %description -n gstreamer-resindvd
419 GStreamer Resin DVD playback plugin.
420
421 %description -n gstreamer-resindvd -l pl.UTF-8
422 Wtyczka odtwarzania Resin DVD do GStreamera.
423
424 %package -n gstreamer-soundtouch
425 Summary:        GStreamer soundtouch plugin
426 Summary(pl.UTF-8):      Wtyczka soundtouch do GStreamera
427 Group:          Libraries
428 Requires:       gstreamer >= %{gst_req_ver}
429
430 %description -n gstreamer-soundtouch
431 GStreamer soundtouch source plugin - audio pitch controller.
432
433 %description -n gstreamer-soundtouch -l pl.UTF-8
434 Wtyczka soundtouch do GStreamera, sterująca wysokością dźwięku.
435
436 %package -n gstreamer-sndfile
437 Summary:        GStreamer sndfile plugin
438 Summary(pl.UTF-8):      Wtyczka sndfile do GStreamera
439 Group:          Libraries
440 # for locales
441 Requires:       %{name} = %{version}-%{release}
442 Requires:       gstreamer >= %{gst_req_ver}
443
444 %description -n gstreamer-sndfile
445 GStreamer sndfile source plugin.
446
447 %description -n gstreamer-sndfile -l pl.UTF-8
448 Wtyczka sndfile do GStreamera.
449
450 %package -n gstreamer-spc
451 Summary:        GStreamer SPC plugin
452 Summary(pl.UTF-8):      Wtyczka SPC dla GStreamera
453 Group:          Libraries
454 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
455 Requires:       libopenspc >= 0.3.99
456
457 %description -n gstreamer-spc
458 GStreamer Plugin for playing SPC files using OpenSPC library.
459
460 %description -n gstreamer-spc -l pl.UTF-8
461 Wtyczka GStreamera odtwarzająca pliki SPC przy użyciu biblioteki
462 OpenSPC.
463
464 %package -n gstreamer-swfdec
465 Summary:        GStreamer Flash redering plugin
466 Summary(pl.UTF-8):      Wtyczka renderująca animacje flash dla GStreamera
467 Group:          Libraries
468 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
469 Requires:       swfdec >= 0.3.6
470
471 %description -n gstreamer-swfdec
472 Plugin for rendering Flash animations using swfdec library.
473
474 %description -n gstreamer-swfdec -l pl.UTF-8
475 Wtyczka renderująca animacje flash w oparciu o bibliotekę swfdec.
476
477 %package -n gstreamer-timidity
478 Summary:        timidity plugin for GStreamer
479 Summary(pl.UTF-8):      Wtyczka timidity do GStreamera
480 Group:          Libraries
481 Requires:       gstreamer >= %{gst_req_ver}
482
483 %description -n gstreamer-timidity
484 timidity plugin for GStreamer.
485
486 %description -n gstreamer-timidity -l pl.UTF-8
487 Wtyczka timidity do GStreamera.
488
489 %package -n gstreamer-videosink-sdl
490 Summary:        GStreamer plugin for outputing to SDL
491 Summary(pl.UTF-8):      Wtyczka wyjścia SDL do GStreamera
492 Group:          Libraries
493 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
494 Provides:       gstreamer-videosink = %{version}
495 Obsoletes:      gstreamer-SDL
496
497 %description -n gstreamer-videosink-sdl
498 Plugin for sending output to the Simple Direct Media architecture.
499 (http://www.libsdl.org/). Usefull for fullscreen playback.
500
501 %description -n gstreamer-videosink-sdl -l pl.UTF-8
502 Wtyczka przekazująca wyjście do architektury SDL. Użyteczna do
503 odtwarzania na pełnym ekranie.
504
505 %package -n gstreamer-videosink-directfb
506 Summary:        GStreamer DirectFB output plugin
507 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu DirectFB do GStreamera
508 Group:          Libraries
509 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
510 Provides:       gstreamer-videosink = %{version}
511
512 %description -n gstreamer-videosink-directfb
513 GStreamer DirectFB output plugin.
514
515 %description -n gstreamer-videosink-directfb -l pl.UTF-8
516 Wtyczka wyjścia obrazu DirectFB do GStreamera.
517
518 %package -n gstreamer-wildmidi
519 Summary:        wildmidi plugin for GStreamer
520 Summary(pl.UTF-8):      Wtyczka wildmidi do GStreamera
521 Group:          Libraries
522 Requires:       gstreamer >= %{gst_req_ver}
523
524 %description -n gstreamer-wildmidi
525 wildmidi plugin for GStreamer.
526
527 %description -n gstreamer-wildmidi -l pl.UTF-8
528 Wtyczka wildmidi do GStreamera.
529
530 %package -n gstreamer-xvid
531 Summary:        GStreamer xvid decoder plugin
532 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid
533 Group:          Libraries
534 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
535
536 %description -n gstreamer-xvid
537 GStreamer xvid decoder plugin.
538
539 %description -n gstreamer-xvid -l pl.UTF-8
540 Wtyczka do GStreamera dekodująca przy użyciu biblioteki xvid.
541
542 %package -n gstreamer-x264
543 Summary:        GStreamer x264 decoder plugin
544 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264
545 Group:          Libraries
546 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
547
548 %description -n gstreamer-x264
549 GStreamer x264 decoder plugin.
550
551 %description -n gstreamer-x264 -l pl.UTF-8
552 Wtyczka do GStreamera dekodująca przy użyciu biblioteki x264.
553
554 %prep
555 %setup -q -n %{gstname}-%{version}
556 %patch0 -p1
557 %patch1 -p1
558 %patch2 -p1
559 %patch4 -p1
560 %patch5 -p1
561 %patch6 -p1
562
563 %build
564 %{__libtoolize}
565 %{__aclocal} -I m4 -I common/m4
566 %{__autoconf}
567 %{__autoheader}
568 %{__automake}
569 %configure \
570         %{!?with_amr:--disable-amrwb} \
571         %{!?with_cdaudio:--disable-cdaudio} \
572         %{!?with_divx4linux:--disable-divx} \
573         %{!?with_dirac:--disable-dirac} \
574         %{!?with_dts:--disable-dts} \
575         %{!?with_faad:--disable-faad} \
576         %{!?with_gsm:--disable-gsm} \
577         %{!?with_jack:--disable-jack} \
578         %{!?with_ladspa:--disable-ladspa} \
579         %{!?with_mms:--disable-libmms} \
580         %{!?with_mjpegtools:--disable-mpeg2enc} \
581         %{!?with_musepack:--disable-musepack} \
582         %{!?with_neon:--disable-neon} \
583         %{!?with_ofa:--disable-ofa} \
584         %{!?with_sdl:--disable-sdl} \
585         %{!?with_sdl:--disable-sdltest} \
586         %{!?with_spc:--disable-spc} \
587         %{!?with_swfdec:--disable-swfdec} \
588         %{!?with_xvid:--disable-xvid} \
589         --disable-static \
590         --enable-experimental \
591         --enable-gtk-doc \
592         --with-html-dir=%{_gtkdocdir}
593
594 %{__make}
595
596 %install
597 rm -rf $RPM_BUILD_ROOT
598
599 %{__make} install \
600         DESTDIR=$RPM_BUILD_ROOT
601
602 # We don't need plugins' *.la files
603 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
604
605 %find_lang %{gstname}-%{gst_major_ver}
606
607 %clean
608 rm -rf $RPM_BUILD_ROOT
609
610 %post   -p /sbin/ldconfig
611 %postun -p /sbin/ldconfig
612
613 %files -f %{gstname}-%{gst_major_ver}.lang
614 %defattr(644,root,root,755)
615 %doc AUTHORS ChangeLog NEWS README RELEASE
616 %attr(755,root,root) %{_libdir}/libgstapp-*.so.*.*.*
617 %attr(755,root,root) %ghost %{_libdir}/libgstapp-*.so.0
618 %attr(755,root,root) %{gstlibdir}/libgstaiffparse.so
619 %attr(755,root,root) %{gstlibdir}/libgstapexsink.so
620 # R: libgstapp-*
621 %attr(755,root,root) %{gstlibdir}/libgstapp.so
622 %attr(755,root,root) %{gstlibdir}/libgstbayer.so
623 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
624 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
625 %attr(755,root,root) %{gstlibdir}/libgstdccp.so
626 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
627 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace2.so
628 # R: gst-plugins-bad locales
629 %attr(755,root,root) %{gstlibdir}/libgstdvb.so
630 %attr(755,root,root) %{gstlibdir}/libgstdvdspu.so
631 %attr(755,root,root) %{gstlibdir}/libgstfbdevsink.so
632 %attr(755,root,root) %{gstlibdir}/libgstfestival.so
633 %attr(755,root,root) %{gstlibdir}/libgstfilter.so
634 %attr(755,root,root) %{gstlibdir}/libgstflv.so
635 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
636 %attr(755,root,root) %{gstlibdir}/libgsth264parse.so
637 %attr(755,root,root) %{gstlibdir}/libgstjp2k.so
638 %attr(755,root,root) %{gstlibdir}/libgstmetadata.so
639 %attr(755,root,root) %{gstlibdir}/libgstmodplug.so
640 %attr(755,root,root) %{gstlibdir}/libgstmpeg4videoparse.so
641 %attr(755,root,root) %{gstlibdir}/libgstmpegdemux.so
642 %attr(755,root,root) %{gstlibdir}/libgstmpegtsmux.so
643 %attr(755,root,root) %{gstlibdir}/libgstmpegvideoparse.so
644 %attr(755,root,root) %{gstlibdir}/libgstmve.so
645 %attr(755,root,root) %{gstlibdir}/libgstnsf.so
646 %attr(755,root,root) %{gstlibdir}/libgstnuvdemux.so
647 %attr(755,root,root) %{gstlibdir}/libgstpcapparse.so
648 %attr(755,root,root) %{gstlibdir}/libgstrawparse.so
649 %ifarch %{ix86} %{x8664}
650 %attr(755,root,root) %{gstlibdir}/libgstreal.so
651 %endif
652 %attr(755,root,root) %{gstlibdir}/libgstrfbsrc.so
653 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
654 %attr(755,root,root) %{gstlibdir}/libgstscaletempoplugin.so
655 %attr(755,root,root) %{gstlibdir}/libgstsdpelem.so
656 %attr(755,root,root) %{gstlibdir}/libgstselector.so
657 %attr(755,root,root) %{gstlibdir}/libgstspeexresample.so
658 %attr(755,root,root) %{gstlibdir}/libgststereo.so
659 %attr(755,root,root) %{gstlibdir}/libgstsubenc.so
660 %attr(755,root,root) %{gstlibdir}/libgsttta.so
661 %attr(755,root,root) %{gstlibdir}/libgsttwolame.so
662 %attr(755,root,root) %{gstlibdir}/libgstvcdsrc.so
663 %attr(755,root,root) %{gstlibdir}/libgstvideosignal.so
664 %attr(755,root,root) %{gstlibdir}/libgstvmnc.so
665 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
666 %{_gtkdocdir}/gst-plugins-bad-plugins-*
667
668 %files devel
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/libgstapp-*.so
671 %{_libdir}/libgstapp-*.la
672 %{_includedir}/gstreamer-*/gst/app
673
674 ##
675 ## Plugins
676 ##
677
678 %if %{with faad}
679 %files -n gstreamer-aac
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
682 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
683 %endif
684
685 %if %{with amr}
686 %files -n gstreamer-amrwb
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{gstlibdir}/libgstamrwb.so
689 %endif
690
691 %files -n gstreamer-audio-effects-bad
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
694
695 %files -n gstreamer-audiosink-alsaspdif
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{gstlibdir}/libgstalsaspdif.so
698
699 %files -n gstreamer-audiosink-nas
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{gstlibdir}/libgstnassink.so
702
703 %if %{with cdaudio}
704 %files -n gstreamer-cdaudio
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{gstlibdir}/libgstcdaudio.so
707 %endif
708
709 %files -n gstreamer-dc1394
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{gstlibdir}/libgstdc1394.so
712
713 %if %{with dirac}
714 %files -n gstreamer-dirac
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{gstlibdir}/libgstdirac.so
717 %endif
718
719 %if %{with divx4linux}
720 %files -n gstreamer-divx
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
723 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
724 %endif
725
726 %if %{with dts}
727 %files -n gstreamer-dts
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
730 %endif
731
732 %if %{with gsm}
733 %files -n gstreamer-gsm
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
736 %endif
737
738 %if %{with jack}
739 %files -n gstreamer-jack
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{gstlibdir}/libgstjack.so
742 %endif
743
744 %if %{with ladspa}
745 %files -n gstreamer-ladspa
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{gstlibdir}/libgstladspa.so
748 %endif
749
750 %if %{with mjpegtools}
751 %files -n gstreamer-mjpegtools
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{gstlibdir}/libgstmpeg2enc.so
754 %endif
755
756 %if %{with mms}
757 %files -n gstreamer-mms
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{gstlibdir}/libgstmms.so
760 %endif
761
762 %if %{with musepack}
763 %files -n gstreamer-musepack
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
766 %endif
767
768 %files -n gstreamer-musicbrainz
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{gstlibdir}/libgsttrm.so
771
772 %files -n gstreamer-mythtv
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{gstlibdir}/libgstmythtvsrc.so
775
776 %if %{with neon}
777 %files -n gstreamer-neon
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
780 %endif
781
782 %if %{with ofa}
783 %files -n gstreamer-ofa
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{gstlibdir}/libgstofa.so
786 %endif
787
788 %files -n gstreamer-oss4
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{gstlibdir}/libgstoss4audio.so
791
792 %files -n gstreamer-resindvd
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{gstlibdir}/libresindvd.so
795
796 %files -n gstreamer-soundtouch
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{gstlibdir}/libgstsoundtouch.so
799
800 %files -n gstreamer-sndfile
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{gstlibdir}/libgstsndfile.so
803
804 %if %{with spc}
805 %files -n gstreamer-spc
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{gstlibdir}/libgstspc.so
808 %endif
809
810 %if %{with swfdec}
811 %files -n gstreamer-swfdec
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
814 %endif
815
816 %files -n gstreamer-timidity
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{gstlibdir}/libgsttimidity.so
819
820 %files -n gstreamer-wildmidi
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{gstlibdir}/libgstwildmidi.so
823
824 %if %{with sdl}
825 %files -n gstreamer-videosink-sdl
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{gstlibdir}/libgstsdl.so
828 %endif
829
830 %if %{with directfb}
831 %files -n gstreamer-videosink-directfb
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
834 %endif
835
836 %if %{with xvid}
837 %files -n gstreamer-xvid
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
840 %endif
841
842 %files -n gstreamer-x264
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.147078 seconds and 4 git commands to generate.