]> git.pld-linux.org Git - packages/gstreamer-plugins-bad.git/blob - gstreamer-plugins-bad.spec
- use pkgconfig name for soundtouch 1.3.1
[packages/gstreamer-plugins-bad.git] / gstreamer-plugins-bad.spec
1 # TODO:
2 # new plugins:
3 # - ivorbis (BR: tremor-devel, CVS versions only, http://www.xiph.org/vorbis/)
4 #
5 # Conditional build:
6 %bcond_without  directfb        # don't build directfb videosink plugin
7 %bcond_without  dts             # don't build DTS plugin
8 %bcond_without  faad            # don't build faad plugin
9 %bcond_without  gsm             # don't build gsm plugin
10 %bcond_without  mms             # don't build mms plugin
11 %bcond_without  musepack        # don't build musepack plugin
12 %bcond_without  neon            # don't build neonhttpsrc plugin
13 %bcond_without  sdl             # don't build sdl plugin
14 %bcond_without  swfdec          # don't build swfdec plugin
15 %bcond_without  wavpack         # don't build wavpack support
16 %bcond_without  xvid            # don't build XviD support
17 %bcond_with     divx4linux      # build with divx4linux support
18 #
19 %define         gstname         gst-plugins-bad
20 %define         gst_major_ver   0.10
21 %define         gst_req_ver     0.10.3
22 #
23 Summary:        Bad GStreamer Streaming-media framework plugins
24 Summary(pl):    Z³e wtyczki do ¶rodowiska obróbki strumieni GStreamer
25 Name:           gstreamer-plugins-bad
26 Version:        0.10.1
27 Release:        1
28 License:        LGPL
29 Group:          Libraries
30 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{gstname}-%{version}.tar.bz2
31 # Source0-md5:  398729b82b911eebb14156c2fa02525b
32 Patch0:         %{name}-bashish.patch
33 Patch1:         %{name}-opengl.patch
34 Patch2:         %{name}-libdts.patch
35 Patch3:         %{name}-divx4linux.patch
36 URL:            http://gstreamer.freedesktop.org/
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake >= 1.6
39 BuildRequires:  bzip2-devel
40 BuildRequires:  glib2-devel >= 1:2.6.0
41 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
42 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
43 BuildRequires:  gtk-doc >= 1.3
44 BuildRequires:  liboil-devel >= 0.3.0
45 BuildRequires:  libtool >= 1.4
46 BuildRequires:  pkgconfig >= 1:0.9.0
47 BuildRequires:  rpmbuild(macros) >= 1.98
48 ##
49 ## plugins
50 ##
51 %{?with_directfb:BuildRequires: DirectFB-devel >= 1:0.9.24}
52 BuildRequires:  OpenGL-devel
53 %{?with_sdl:BuildRequires:      SDL-devel >= 0.11}
54 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.05.20030428}
55 BuildRequires:  faac-devel
56 %{?with_faad:BuildRequires:     faad2-devel >= 2.0-2}
57 %{?with_dts:BuildRequires:      libdts-devel}
58 %{?with_gsm:BuildRequires:      libgsm-devel}
59 %{?with_mms:BuildRequires:      libmms-devel >= 0.1}
60 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2}
61 %{?with_neon:BuildRequires:     neon-devel = 0.25.5}
62 %{?with_swfdec:BuildRequires:   swfdec-devel >= 0.3.6}
63 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.2}
64 %{?with_xvid:BuildRequires:     xvid-devel >= 1.0.0}
65 Requires:       gstreamer >= %{gst_req_ver}
66 Obsoletes:      gstreamer-quicktime
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
70
71 %description
72 GStreamer is a streaming-media framework, based on graphs of filters
73 which operate on media data. Applications using this library can do
74 anything from real-time sound processing to playing videos, and just
75 about anything else media-related. Its plugin-based architecture means
76 that new data types or processing capabilities can be added simply by
77 installing new plugins.
78
79 %description -l pl
80 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
81 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
82 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
83 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
84 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
85 nowych typów danych lub mo¿liwo¶ci obróbki.
86
87 ##
88 ## Plugins
89 ##
90
91 %package -n gstreamer-aac
92 Summary:        GStreamer plugin for AAC audio encoding and decoding
93 Summary(pl):    Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC
94 Group:          Libraries
95 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
96
97 %description -n gstreamer-aac
98 GStreamer plugin for AAC audio encoding and decoding.
99
100 %description -n gstreamer-aac -l pl
101 Wtyczka do GStreamera do kodowania i dekodowania plików audio AAC.
102
103 %package -n gstreamer-audio-effects-bad
104 Summary:        Bad GStreamer audio effects plugins
105 Summary(pl):    Z³e wtyczki efektów d¼wiêkowych do GStreamera
106 Group:          Libraries
107 Requires:       gstreamer >= %{gst_req_ver}
108 Obsoletes:      gstreamer-audio-effects
109
110 %description -n gstreamer-audio-effects-bad
111 Bad GStreamer audio effects plugins.
112
113 %description -n gstreamer-audio-effects-bad -l pl
114 Z³e wtyczki efektów d¼wiêkowych do GStreamera.
115
116 %package -n gstreamer-divx
117 Summary:        GStreamer divx plugin
118 Summary(pl):    Wtyczka divx do GStreamera
119 Group:          Libraries
120 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
121
122 %description -n gstreamer-divx
123 GStreamer divx plugin.
124
125 %description -n gstreamer-divx -l pl
126 Wtyczka divx do GStreamera.
127
128 %package -n gstreamer-dts
129 Summary:        GStreamer DTS plugin
130 Summary(pl):    Wtyczka DTS do GStreamera
131 Group:          Libraries
132 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
133
134 %description -n gstreamer-dts
135 Plugin for DTS Coherent Acoustics support.
136
137 %description -n gstreamer-dts -l pl
138 Wtyczka do GStreamera obs³uguj±ca DTS Coherent Acoustics.
139
140 %package -n gstreamer-gsm
141 Summary:        GStreamer plugin for GSM lossy audio format
142 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca stratny format d¼wiêku GSM
143 Group:          Libraries
144 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
145
146 %description -n gstreamer-gsm
147 Output plugin for GStreamer to convert to GSM lossy audio format.
148
149 %description -n gstreamer-gsm -l pl
150 Wtyczka wyj¶cia d¼wiêku GSteamera konwertuj±ca do stratnego formatu
151 GSM.
152
153 %package -n gstreamer-imagesink-gl
154 Summary:        GStreamer plugin for outputing to OpenGL
155 Summary(pl):    Wtyczka wyj¶cia OpenGL do GStreamera
156 Group:          Libraries
157 Requires:       gstreamer >= %{gst_req_ver}
158 Provides:       gstreamer-imagesink = %{version}
159
160 %description -n gstreamer-imagesink-gl
161 GStreamer plugin for outputing to OpenGL.
162
163 %description -n gstreamer-imagesink-gl -l pl
164 Wtyczka wyj¶cia OpenGL do GStreamera.
165
166 %package -n gstreamer-mms
167 Summary:        GStreamer mms plugin
168 Summary(pl):    Wtyczka mms do GStreamera
169 Group:          Libraries
170 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
171
172 %description -n gstreamer-mms
173 GStreamer mms plugin.
174
175 %description -n gstreamer-mms -l pl
176 Wtyczka mms do GStreamera.
177
178 %package -n gstreamer-musepack
179 Summary:        GStreamer musepack plugin
180 Summary(pl):    Wtyczka musepack do GStreamera
181 Group:          Libraries
182 Requires:       gstreamer >= %{gst_req_ver}
183
184 %description -n gstreamer-musepack
185 GStreamer musepack plugin.
186
187 %description -n gstreamer-musepack -l pl
188 Wtyczka musepack do GStreamera.
189
190 %package -n gstreamer-neon
191 Summary:        GStreamer neon HTTP source plugin
192 Summary(pl):    Wtyczka ¼ród³a HTTP neon do GStreamera
193 Group:          Libraries
194 Requires:       gstreamer >= %{gst_req_ver}
195
196 %description -n gstreamer-neon
197 GStreamer neon HTTP source plugin.
198
199 %description -n gstreamer-neon -l pl
200 Wtyczka ¼ród³a HTTP neon do GStreamera.
201
202 %package -n gstreamer-swfdec
203 Summary:        GStreamer Flash redering plugin
204 Summary(pl):    Wtyczka renderuj±ca animacje flash dla GStreamera
205 Group:          Libraries
206 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
207 Requires:       swfdec >= 0.3.6
208
209 %description -n gstreamer-swfdec
210 Plugin for rendering Flash animations using swfdec library.
211
212 %description -n gstreamer-swfdec -l pl
213 Wtyczka renderuj±ca animacje flash w oparciu o bibliotekê swfdec.
214
215 %package -n gstreamer-videosink-sdl
216 Summary:        GStreamer plugin for outputing to SDL
217 Summary(pl):    Wtyczka wyj¶cia SDL do GStreamera
218 Group:          Libraries
219 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
220 Provides:       gstreamer-videosink = %{version}
221 Obsoletes:      gstreamer-SDL
222
223 %description -n gstreamer-videosink-sdl
224 Plugin for sending output to the Simple Direct Media architecture.
225 (http://www.libsdl.org/). Usefull for fullscreen playback.
226
227 %description -n gstreamer-videosink-sdl -l pl
228 Wtyczka przekazuj±ca wyj¶cie do architektury SDL. U¿yteczna do
229 odtwarzania na pe³nym ekranie.
230
231 %package -n gstreamer-videosink-directfb
232 Summary:        GStreamer DirectFB output plugin
233 Summary(pl):    Wtyczka wyj¶cia obrazu DirectFB do GStreamera
234 Group:          Libraries
235 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
236 Provides:       gstreamer-videosink = %{version}
237
238 %description -n gstreamer-videosink-directfb
239 GStreamer DirectFB output plugin.
240
241 %description -n gstreamer-videosink-directfb -l pl
242 Wtyczka wyj¶cia obrazu DirectFB do GStreamera.
243
244 %package -n gstreamer-wavpack
245 Summary:        GStreamer plugin for Wavpack lossless audio format
246 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku Wavpack
247 Group:          Libraries
248 Requires:       gstreamer >= %{gst_req_ver}
249
250 %description -n gstreamer-wavpack
251 Plugin for lossless Wavpack audio format.
252
253 %description -n gstreamer-wavpack -l pl
254 Wtyczka obs³uguj±ca bezstratny format d¼wiêku Wavpack.
255
256 %package -n gstreamer-xvid
257 Summary:        GStreamer xvid decoder plugin
258 Summary(pl):    Wtyczka do GStreamera dekoduj±ca przy u¿yciu biblioteki xvid
259 Group:          Libraries
260 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
261
262 %description -n gstreamer-xvid
263 GStreamer xvid decoder plugin.
264
265 %description -n gstreamer-xvid -l pl
266 Wtyczka do GStreamera dekoduj±ca przy u¿yciu biblioteki xvid.
267
268 %prep
269 %setup -q -n %{gstname}-%{version}
270 %patch0 -p1
271 %patch1 -p1
272 %patch2 -p1
273
274 %build
275 %{__libtoolize}
276 %{__aclocal} -I m4 -I common/m4
277 %{__autoconf}
278 %{__autoheader}
279 %{__automake}
280 %configure \
281         %{!?with_divx4linux:--disable-divx} \
282         %{!?with_dts:--disable-dts} \
283         %{!?with_faad:--disable-faad} \
284         %{!?with_gsm:--disable-gsm} \
285         %{!?with_mms:--disable-libmms} \
286         %{!?with_musepack:--disable-musepack} \
287         %{!?with_neon:--disable-neon} \
288         %{!?with_sdl:--disable-sdl} \
289         %{!?with_sdl:--disable-sdltest} \
290         %{!?with_swfdec:--disable-swfdec} \
291         %{!?with_wavpack:--disable-wavpack} \
292         %{!?with_xvid:--disable-xvid} \
293         --disable-static \
294         --enable-gtk-doc \
295         --with-html-dir=%{_gtkdocdir}
296
297 %{__make}
298
299 %install
300 rm -rf $RPM_BUILD_ROOT
301
302 %{__make} install \
303         DESTDIR=$RPM_BUILD_ROOT
304
305 # We don't need plugins' *.la files
306 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
307
308 %clean
309 rm -rf $RPM_BUILD_ROOT
310
311 %files
312 %defattr(644,root,root,755)
313 %doc AUTHORS ChangeLog NEWS README RELEASE
314 %attr(755,root,root) %{gstlibdir}/libgstbz2.so
315 %attr(755,root,root) %{gstlibdir}/libgstcdxaparse.so
316 %attr(755,root,root) %{gstlibdir}/libgstfreeze.so
317 %attr(755,root,root) %{gstlibdir}/libgstqtdemux.so
318 %attr(755,root,root) %{gstlibdir}/libgsttta.so
319 %{_gtkdocdir}/gst-plugins-bad-plugins-*
320
321 ##
322 ## Plugins
323 ##
324
325 %if %{with faad}
326 %files -n gstreamer-aac
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{gstlibdir}/libgstfaac.so
329 %attr(755,root,root) %{gstlibdir}/libgstfaad.so
330 %endif
331
332 %files -n gstreamer-audio-effects-bad
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{gstlibdir}/libgstspeed.so
335
336 %if %{with divx4linux}
337 %files -n gstreamer-divx
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{gstlibdir}/libgstdivxdec.so
340 %attr(755,root,root) %{gstlibdir}/libgstdivxenc.so
341 %endif
342
343 %if %{with dts}
344 %files -n gstreamer-dts
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{gstlibdir}/libgstdtsdec.so
347 %endif
348
349 %if %{with gsm}
350 %files -n gstreamer-gsm
351 %defattr(644,root,root,755)
352 %attr(755,root,root) %{gstlibdir}/libgstgsm.so
353 %endif
354
355 %files -n gstreamer-imagesink-gl
356 %defattr(644,root,root,755)
357 %attr(755,root,root) %{gstlibdir}/libgstglimagesink.so
358
359 %if %{with mms}
360 %files -n gstreamer-mms
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{gstlibdir}/libgstmms.so
363 %endif
364
365 %if %{with neon}
366 %files -n gstreamer-neon
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{gstlibdir}/libgstneonhttpsrc.so
369 %endif
370
371 %if %{with musepack}
372 %files -n gstreamer-musepack
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{gstlibdir}/libgstmusepack.so
375 %endif
376
377 %if %{with swfdec}
378 %files -n gstreamer-swfdec
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{gstlibdir}/libgstswfdec.so
381 %endif
382
383 %if %{with sdl}
384 %files -n gstreamer-videosink-sdl
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{gstlibdir}/libgstsdlvideosink.so
387 %endif
388
389 %if %{with directfb}
390 %files -n gstreamer-videosink-directfb
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{gstlibdir}/libgstdfbvideosink.so
393 %endif
394
395 %if %{with wavpack}
396 %files -n gstreamer-wavpack
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
399 %endif
400
401 %if %{with xvid}
402 %files -n gstreamer-xvid
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{gstlibdir}/libgstxvid.so
405 %endif
This page took 0.056578 seconds and 3 git commands to generate.